aboutsummaryrefslogtreecommitdiff
path: root/devel/py-qt4-core
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-09-13 18:15:58 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-09-13 18:15:58 +0000
commit71fee7a28f398a2397323d85043fe27f64592ff3 (patch)
tree1bd1d6b6cd839caa689ea882fe31da6bd8c7ae79 /devel/py-qt4-core
parent3a031558959ee2330ba8253b9752de0ea489d195 (diff)
downloadports-71fee7a28f398a2397323d85043fe27f64592ff3.tar.gz
ports-71fee7a28f398a2397323d85043fe27f64592ff3.zip
Notes
Diffstat (limited to 'devel/py-qt4-core')
-rw-r--r--devel/py-qt4-core/Makefile56
-rw-r--r--devel/py-qt4-core/distinfo6
-rw-r--r--devel/py-qt4-core/files/Qt.py49
-rw-r--r--devel/py-qt4-core/files/patch-configure.py413
-rw-r--r--devel/py-qt4-core/pkg-plist19
5 files changed, 400 insertions, 143 deletions
diff --git a/devel/py-qt4-core/Makefile b/devel/py-qt4-core/Makefile
index 8e34d773b491..6b07e29dd61f 100644
--- a/devel/py-qt4-core/Makefile
+++ b/devel/py-qt4-core/Makefile
@@ -5,8 +5,8 @@
# $FreeBSD$
PORTNAME= core
-PORTVERSION= 4.2
-PORTREVISION= 1
+PORTVERSION= 4.3
+PORTREVISION= # zero
CATEGORIES= devel python
MASTER_SITES= http://www.riverbankcomputing.com/Downloads/PyQt4/GPL/ \
http://freebsd.ricin.com/ports/distfiles/
@@ -20,7 +20,7 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/sip:${PORTSDIR}/devel/py-sip
RUN_DEPENDS= ${BUILD_DEPENDS}
HAS_CONFIGURE= yes
-USE_PYTHON= 2.3+
+USE_PYTHON= 2.5+
USE_QT_VER= 4
QT_COMPONENTS= corelib qmake
@@ -30,54 +30,58 @@ OPTIONS= API "Install QtCore API for QScintilla2" on \
TRACING "Enable tracing in generated code" off
OPTIONSFILE= ${PORT_DBDIR}/py-qt4-${PORTNAME}/options
-APIFILE= ${QT_PREFIX}/share/qt4/qsci/api/python/QtCore.api
SIPDIR= ${PREFIX}/share/py-sip
-ARGS= -b ${PREFIX}/bin -c -j 2 -d ${PYTHONPREFIX_SITELIBDIR}/PyQt4 \
- -q ${QT_PREFIX}/bin/qmake-qt4 -a
+CONFIGURE_ENV+= PYQT4_COMPONENT="${PORTNAME}"
+ARGS= -b ${PREFIX}/bin\
+ -d ${PYTHON_SITELIBDIR}\
+ -q ${QT_PREFIX}/bin/qmake-qt4
.include <bsd.port.pre.mk>
.if defined(WITH_DEBUG)
-ARGS+= -u
+ARGS+= --debug
.endif
.if defined(WITHOUT_API)
+ARGS+= --no-qsci-api
PLIST_SUB+= API="@comment "
PLIST_SUB+= APIFILE="@comment "
.else
-LIB_DEPENDS+= qscintilla2.1:${PORTSDIR}/devel/qscintilla2
+LIB_DEPENDS+= qscintilla2.2:${PORTSDIR}/devel/qscintilla2
+ARGS+= --qsci-api
PLIST_SUB+= API=""
PLIST_SUB+= APIFILE="share/qt4/qsci/api/python/QtCore.api"
.endif
.if defined(WITHOUT_SIPFILES)
-ARGS+= -v /dev/null
+ARGS+= --no-sip-files
PLIST_SUB+= SIPFILES="@comment "
PLIST_SUB+= SIPDIR="@comment "
.else
-ARGS+= -v ${SIPDIR}
+ARGS+= --sipdir ${SIPDIR}
PLIST_SUB+= SIPFILES=""
PLIST_SUB+= SIPDIR="share/py-sip"
.endif
.if defined(WITH_TRACING)
-ARGS+= -r
-.endif
-.if ${PYTHON_VER} >= 2.5
-PLIST_SUB+= ELTREE="@comment "
-.else
-PLIST_SUB+= ELTREE=""
+ARGS+= --trace
.endif
+ARGS+= --enable QtCore
do-configure:
- ( cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${PYTHON_CMD} configure.py ${ARGS} )
+ cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV}\
+ ${PYTHON_CMD} configure.py ${ARGS}
+
+post-configure:
+ ${REINPLACE_CMD} -e 's|mkspecs/freebsd-g++|share/qt4/mkspecs/freebsd-g++|'\
+ -e 's|CC = cc|CC = ${CC}|'\
+ -e 's|CXX = c++|CXX = ${CXX}|'\
+ -e 's|LINK = c++|LINK = ${CXX}|'\
+ ${WRKSRC}/QtCore/Makefile
post-install:
- ( cd ${PYTHONPREFIX_SITELIBDIR}/PyQt4 && \
- ${PYTHON_CMD} ${PYTHON_LIBDIR}/py_compile.py \
- `ls *.py */*.py */*/*.py` && \
- ${PYTHON_CMD} -O ${PYTHON_LIBDIR}/py_compile.py \
- `ls *.py */*.py */*/*.py`)
-.if defined(WITHOUT_API)
- ( ${RM} ${APIFILE} )
-.endif
+ ${INSTALL_DATA} ${FILESDIR}/Qt.py ${PYTHON_SITELIBDIR}/PyQt4 &&\
+ cd ${PYTHON_SITELIBDIR}/PyQt4 &&\
+ ${PYTHON_CMD} ${PYTHON_LIBDIR}/py_compile.py\
+ `ls *.py */*.py */*/*.py` &&\
+ ${PYTHON_CMD} -O ${PYTHON_LIBDIR}/py_compile.py\
+ `ls *.py */*.py */*/*.py`
.include <bsd.port.post.mk>
diff --git a/devel/py-qt4-core/distinfo b/devel/py-qt4-core/distinfo
index 3317bc659e04..504192030ea8 100644
--- a/devel/py-qt4-core/distinfo
+++ b/devel/py-qt4-core/distinfo
@@ -1,3 +1,3 @@
-MD5 (PyQt-x11-gpl-4.2.tar.gz) = af4baa7f7441914f9a527ef3cf788fef
-SHA256 (PyQt-x11-gpl-4.2.tar.gz) = 6fa8a853a66ae500f36629793e7d4c54896c7ccf6337c2b90ea0175b28aa7ae6
-SIZE (PyQt-x11-gpl-4.2.tar.gz) = 5661258
+MD5 (PyQt-x11-gpl-4.3.tar.gz) = 3bb0c0064dc6b8b80413f87a14e5553c
+SHA256 (PyQt-x11-gpl-4.3.tar.gz) = c184c3df596c13e9ed610aa8fa0504881976c4d972ccab1b739738a95f4ab0e5
+SIZE (PyQt-x11-gpl-4.3.tar.gz) = 6036193
diff --git a/devel/py-qt4-core/files/Qt.py b/devel/py-qt4-core/files/Qt.py
new file mode 100644
index 000000000000..8239535019fb
--- /dev/null
+++ b/devel/py-qt4-core/files/Qt.py
@@ -0,0 +1,49 @@
+# Replacement for the composite module PyQt4.Qt for FreeBSD
+# Provides namespace for all installed PyQt4 modules by importing them
+
+from PyQt4.QtCore import *
+
+try:
+ from PyQt4.QtGui import *
+except ImportError:
+ pass
+try:
+ from PyQt4.QtXml import *
+except ImportError:
+ pass
+try:
+ from PyQt4.QtAssistant import *
+except ImportError:
+ pass
+try:
+ from PyQt4.QtDesigner import *
+except ImportError:
+ pass
+try:
+ from PyQt4.QtNetwork import *
+except ImportError:
+ pass
+try:
+ from PyQt4.QtOpenGL import *
+except ImportError:
+ pass
+try:
+ from PyQt4.QtScript import *
+except ImportError:
+ pass
+try:
+ from PyQt4.QtSql import *
+except ImportError:
+ pass
+try:
+ from PyQt4.QtSvg import *
+except ImportError:
+ pass
+try:
+ from PyQt4.QtTest import *
+except ImportError:
+ pass
+try:
+ from PyQt4.Qsci import *
+except:
+ pass
diff --git a/devel/py-qt4-core/files/patch-configure.py b/devel/py-qt4-core/files/patch-configure.py
index 15124b8d0be8..825f18e0a2e5 100644
--- a/devel/py-qt4-core/files/patch-configure.py
+++ b/devel/py-qt4-core/files/patch-configure.py
@@ -1,145 +1,354 @@
---- configure.py.orig Tue Apr 10 17:59:52 2007
-+++ configure.py Thu Apr 12 20:48:21 2007
-@@ -140,24 +140,24 @@
- def check_modules(self):
- pyqt_modules.append("QtCore")
-
-- check_module("QtGui", "qwidget.h", "new QWidget()")
-- check_module("QtNetwork", "qhostaddress.h", "new QHostAddress()")
-- check_module("QtOpenGL", "qgl.h", "new QGLWidget()")
-- check_module("QtSql", "qsqldatabase.h", "new QSqlDatabase()")
-- check_module("QtSvg", "qsvgwidget.h", "new QSvgWidget()")
-- check_module("QtTest", "QtTest", "QTest::qSleep(0)")
-- check_module("QtXml", "qdom.h", "new QDomDocument()")
-- check_module("QtAssistant", "qassistantclient.h", "new QAssistantClient(\"foo\")")
-+ #check_module("QtGui", "qwidget.h", "new QWidget()")
-+ #check_module("QtNetwork", "qhostaddress.h", "new QHostAddress()")
-+ #check_module("QtOpenGL", "qgl.h", "new QGLWidget()")
-+ #check_module("QtSql", "qsqldatabase.h", "new QSqlDatabase()")
-+ #check_module("QtSvg", "qsvgwidget.h", "new QSvgWidget()")
-+ #check_module("QtTest", "QtTest", "QTest::qSleep(0)")
-+ #check_module("QtXml", "qdom.h", "new QDomDocument()")
-+ #check_module("QtAssistant", "qassistantclient.h", "new QAssistantClient(\"foo\")")
-+
-+ #if sipcfg.universal:
-+ # sipconfig.inform("QtDesigner module disabled with universal binaries")
-+ #else:
-+ # check_module("QtDesigner", "QExtensionFactory", "new QExtensionFactory()")
-
-- if sipcfg.universal:
-- sipconfig.inform("QtDesigner module disabled with universal binaries")
-- else:
-- check_module("QtDesigner", "QExtensionFactory", "new QExtensionFactory()")
+--- configure.py.orig Mon Jul 30 18:11:39 2007
++++ configure.py Fri Aug 10 22:22:34 2007
+@@ -29,6 +29,10 @@
+
+ import sipconfig
+
++# FreeBSD check and which component (port)
++freebsd, freebsd_port = False, ''
++if sys.platform[:-1] == 'freebsd': freebsd = True
++if freebsd: freebsd_port = os.environ['PYQT4_COMPONENT']
+
+ # Initialise the globals.
+ pyqt_version = 0x040300
+@@ -62,7 +66,6 @@
+ dbuslibdirs = []
+ dbuslibs = []
+
-
-- check_module("QAxContainer", "qaxobject.h", "new QAxObject()", "QAxContainer")
-+ #check_module("QAxContainer", "qaxobject.h", "new QAxObject()", "QAxContainer")
+ # Under Windows qmake and the Qt DLLs must be into the system PATH otherwise
+ # the dynamic linker won't be able to resolve the symbols. On other systems we
+ # assume we can just run qmake by using its full pathname.
+@@ -276,14 +279,23 @@
+ elif sipcfg.universal:
+ sipconfig.inform("QtDesigner module disabled with universal binaries.")
+ else:
+- check_module("QtDesigner", "QExtensionFactory",
+- "new QExtensionFactory()")
++ if freebsd:
++ if freebsd_port.startswith('designer'):
++ check_module("QtDesigner", "QExtensionFactory",
++ "new QExtensionFactory()")
++ else:
++ check_module("QtDesigner", "QExtensionFactory",
++ "new QExtensionFactory()")
+
+ check_module("QAxContainer", "qaxobject.h", "new QAxObject()",
+ extra_libs=["QAxContainer"])
-- if os.path.isdir("dbus"):
+ if os.path.isdir("dbus"):
- check_dbus()
-+ #if os.path.isdir("dbus"):
-+ # check_dbus()
++ if freebsd:
++ if freebsd_port == 'dbus':
++ check_dbus()
++ else:
++ check_dbus()
def code(self):
- # Note that the order of the dependent modules is important.
-@@ -211,31 +211,31 @@
- generate_code("QAxContainer", ["QAxContainer", "QtGui", "QtCore"])
-
- # Generate the consolidated module.
-- sipconfig.inform("Creating Qt consolidated module...")
-- f = open("Qt.py", "w")
-+ #sipconfig.inform("Creating Qt consolidated module...")
-+ #f = open("Qt.py", "w")
-
-- for m in pyqt_modules:
-- f.write("from PyQt4.%s import *\n" % m)
-+ #for m in pyqt_modules:
-+ # f.write("from PyQt4.%s import *\n" % m)
+ cons_xtra_incdirs = []
+@@ -304,6 +316,10 @@
+ cons_xtra_libs.extend(sp_libs)
-- f.close()
-+ #f.close()
+ generate_code("QtCore")
++ elif freebsd:
++ if freebsd_port == 'core':
++ generate_code("QtCore", extra_include_dirs=sp_incdirs,
++ extra_lib_dirs=sp_libdirs, extra_libs=sp_libs)
+ else:
+ generate_code("QtCore", extra_include_dirs=sp_incdirs,
+ extra_lib_dirs=sp_libdirs, extra_libs=sp_libs)
+@@ -472,19 +488,28 @@
+ sipconfig.inform("Unable to find the following static plugins: %s" % ", ".join(opts.staticplugins))
# Generate the QScintilla API file.
- sipconfig.inform("Creating QScintilla API file...")
- f = open("PyQt4.api", "w")
-+ #sipconfig.inform("Creating QScintilla API file...")
-+ #f = open("PyQt4.api", "w")
++ if freebsd:
++ if not freebsd_port in ('dbus', 'designerplugin', 'demo', 'doc'):
++ sipconfig.inform("Creating QScintilla API file...")
++
++ else:
++ sipconfig.inform("Creating QScintilla API file...")
- for m in pyqt_modules:
- api = open(m + ".api")
-+ #for m in pyqt_modules:
-+ # api = open(m + ".api")
++ if not freebsd:
++ # aggregating like below would kill packaging
++ # instead the port installs the seperate module APIs
++ f = open("PyQt4.api", "w")
- for l in api:
- f.write("PyQt4." + l)
-+ # for l in api:
-+ # f.write("PyQt4." + l)
++ for m in pyqt_modules:
++ api = open(m + ".api")
- api.close()
- os.remove(m + ".api")
-+ # api.close()
-+ # os.remove(m + ".api")
++ for l in api:
++ f.write("PyQt4." + l)
- f.close()
-+ #f.close()
++ api.close()
++ os.remove(m + ".api")
++
++ f.close()
+
+ def _static_plugins(self, mname):
+ """Return a tuple of the libraries (in platform neutral format) and the
+@@ -555,7 +580,13 @@
+ return libs, libdirs
def module_installs(self):
-- return ["__init__.py", "Qt.py", "pyqtconfig.py"]
-+ return ["__init__.py", "pyqtconfig.py"]
+- return ["__init__.py", "pyqtconfig.py"]
++ if freebsd:
++ if freebsd_port == 'core':
++ return ["__init__.py", "pyqtconfig.py"]
++ else:
++ return []
++ else:
++ return ["__init__.py", "pyqtconfig.py"]
def qpylibs(self):
# See which QPy libraries to build.
-@@ -376,7 +376,8 @@
+@@ -641,23 +672,43 @@
+ # Create the pyuic4 wrapper. Use the GUI version on MacOS (so that
+ # previews work properly and normal console use will work anyway), but
+ # not on Windows (so that normal console use will work).
+- sipconfig.inform("Creating pyuic4 wrapper...")
++ if freebsd:
++ if freebsd_port == 'core':
++ sipconfig.inform("Creating pyuic4 wrapper...")
++
++ uicdir=os.path.join(pyqt_modroot, "uic")
++ wrapper = sipconfig.create_wrapper(os.path.join(uicdir, "pyuic.py"), os.path.join("pyuic", "pyuic4"), (sys.platform == "darwin"))
++
++ sipconfig.inform("Creating pyuic4 Makefile...")
++
++ makefile = sipconfig.PythonModuleMakefile(
++ configuration=sipcfg,
++ dstdir=uicdir,
++ srcdir="uic",
++ dir="pyuic",
++ installs=[[os.path.basename(wrapper), opts.pyqtbindir]]
++ )
++
++ makefile.generate()
++ tool.append("pyuic")
++ else:
++ sipconfig.inform("Creating pyuic4 wrapper...")
+
+- uicdir=os.path.join(pyqt_modroot, "uic")
+- wrapper = sipconfig.create_wrapper(os.path.join(uicdir, "pyuic.py"), os.path.join("pyuic", "pyuic4"), (sys.platform == "darwin"))
++ uicdir=os.path.join(pyqt_modroot, "uic")
++ wrapper = sipconfig.create_wrapper(os.path.join(uicdir, "pyuic.py"), os.path.join("pyuic", "pyuic4"), (sys.platform == "darwin"))
+
+- sipconfig.inform("Creating pyuic4 Makefile...")
++ sipconfig.inform("Creating pyuic4 Makefile...")
+
+- makefile = sipconfig.PythonModuleMakefile(
+- configuration=sipcfg,
+- dstdir=uicdir,
+- srcdir="uic",
+- dir="pyuic",
+- installs=[[os.path.basename(wrapper), opts.pyqtbindir]]
+- )
++ makefile = sipconfig.PythonModuleMakefile(
++ configuration=sipcfg,
++ dstdir=uicdir,
++ srcdir="uic",
++ dir="pyuic",
++ installs=[[os.path.basename(wrapper), opts.pyqtbindir]]
++ )
+
+- makefile.generate()
+- tool.append("pyuic")
++ makefile.generate()
++ tool.append("pyuic")
+
+ if "QtXml" in pyqt_modules:
+ sipconfig.inform("Creating pylupdate4 Makefile...")
+@@ -694,7 +745,10 @@
makefile.generate()
tool.append("pyrcc")
else:
- sipconfig.inform("pylupdate4 and pyrcc4 will not be built because the Qt XML module is missing.")
-+ #sipconfig.inform("pylupdate4 and pyrcc4 will not be built because the Qt XML module is missing.")
-+ pass
++ if freebsd:
++ pass
++ else:
++ sipconfig.inform("pylupdate4 and pyrcc4 will not be built because the Qt XML module is missing.")
if "QtDesigner" in pyqt_modules:
enabled = True
-@@ -460,7 +461,7 @@
+@@ -719,6 +773,12 @@
+ glob.glob("%s/lib/libpython%d.%d*" % (ducfg["prefix"], py_major, py_minor))):
+ lib_dir_flag = quote("-L%s/lib" % ducfg["prefix"])
+ link = "%s -lpython%d.%d" % (lib_dir_flag, py_major, py_minor)
++ elif freebsd:
++ # We do have shared libpython, but also static. Alas
++ # static is built *first*, and to distutils it looks as
++ # if we have static py only
++ lib_dir_flag = quote("-L%s/lib" % ducfg["prefix"])
++ link = "%s -lpython%d.%d" % (lib_dir_flag, py_major, py_minor)
+ else:
+ sipconfig.inform("Qt Designer plugin disabled because Python library is static")
+ enabled = False
+@@ -791,19 +851,44 @@
+ sipconfig.inform("The %s %s library is in %s." % (lib_type, qt_lib, qt_libdir))
+ sipconfig.inform("The Qt binaries are in %s." % qt_bindir)
sipconfig.inform("The Qt mkspecs directory is in %s." % qt_datadir)
- sipconfig.inform("These PyQt modules will be built: %s." % string.join(pyqt_modules))
- sipconfig.inform("The PyQt modules will be installed in %s." % opt_pyqtmoddir)
-- sipconfig.inform("The Designer plugin will be installed in %s." % os.path.join(opt_plugindir, "designer"))
-+ #sipconfig.inform("The Designer plugin will be installed in %s." % os.path.join(opt_plugindir, "designer"))
+- sipconfig.inform("These PyQt modules will be built: %s." % string.join(pyqt_modules))
+- sipconfig.inform("The PyQt Python package will be installed in %s." % opts.pyqtmoddir)
+- sipconfig.inform("The Designer plugin will be installed in %s." % os.path.join(opts.plugindir, "designer"))
++ if freebsd:
++ if not freebsd_port in ('dbus', 'demo', 'designerplugin'):
++ sipconfig.inform("This PyQt module will be built: %s." % pyqt_modules[-1])
++ sipconfig.inform("The PyQt Python package will be installed in %s." % opts.pyqtmoddir)
++ if freebsd_port == 'designerplugin':
++ sipconfig.inform("The Designer plugin will be installed in %s." % os.path.join(opts.plugindir, "designer"))
++ else:
++ sipconfig.inform("These PyQt modules will be built: %s." % string.join(pyqt_modules))
++ sipconfig.inform("The PyQt Python package will be installed in %s." % opts.pyqtmoddir)
++ sipconfig.inform("The Designer plugin will be installed in %s." % os.path.join(opts.plugindir, "designer"))
+
+ if opts.api:
+- sipconfig.inform("The QScintilla API file will be installed in %s." % os.path.join(opts.qscidir, "api", "python"))
++ if freebsd:
++ if not freebsd_port in ('dbus', 'demo', 'doc', 'designerplugin'):
++ sipconfig.inform("The QScintilla API file will be installed in %s." % os.path.join(opts.qscidir, "api", "python"))
++ else:
++ sipconfig.inform("The QScintilla API file will be installed in %s." % os.path.join(opts.qscidir, "api", "python"))
- if opt_api:
- sipconfig.inform("The QScintilla API file will be installed in %s." % os.path.join(opt_qscidir, "api", "python"))
-@@ -470,7 +471,7 @@
+ if pydbusmoddir:
+- sipconfig.inform("The dbus support module will be installed in %s." % pydbusmoddir)
++ if freebsd:
++ if freebsd_port == 'dbus':
++ sipconfig.inform("The dbus support module will be installed in %s." % pydbusmoddir)
++ else:
++ sipconfig.inform("The dbus support module will be installed in %s." % pydbusmoddir)
- sipconfig.inform("The PyQt .sip files will be installed in %s." % opt_pyqtsipdir)
+- sipconfig.inform("The PyQt .sip files will be installed in %s." % opts.pyqtsipdir)
++ if freebsd:
++ if not freebsd_port in ('dbus', 'demo', 'designerplugin'):
++ sipconfig.inform("The PyQt .sip files will be installed in %s." % opts.pyqtsipdir)
++ else:
++ sipconfig.inform("The PyQt .sip files will be installed in %s." % opts.pyqtsipdir)
-- sipconfig.inform("pyuic4, pyrcc4 and pylupdate4 will be installed in %s." % opt_pyqtbindir)
-+ sipconfig.inform("pyuic4 will be installed in %s." % opt_pyqtbindir)
+- sipconfig.inform("pyuic4, pyrcc4 and pylupdate4 will be installed in %s." % opts.pyqtbindir)
++ if freebsd:
++ if freebsd_port == 'core':
++ sipconfig.inform("pyuic4 will be installed in %s." % opts.pyqtbindir)
++ elif freebsd_port == 'xml':
++ sipconfig.inform("pyrcc4 and pylupdate4 will be installed in %s." % opts.pyqtbindir)
++ else:
++ sipconfig.inform("pyuic4, pyrcc4 and pylupdate4 will be installed in %s." % opts.pyqtbindir)
- if opt_vendorcheck:
+ if opts.vendorcheck:
sipconfig.inform("PyQt will only be usable with signed interpreters.")
-@@ -873,7 +874,7 @@
- sipconfig.error("This version of PyQt and the %s edition of Qt have incompatible licenses." % qted)
-
- # Confirm the license.
-- print
-+ """print
- print "Type 'L' to view the license."
- print "Type 'yes' to accept the terms of the license."
- print "Type 'no' to decline the terms of the license."
-@@ -895,7 +896,7 @@
-
- if resp == "l":
- os.system("more LICENSE")
--
-+ """
- # If there should be a license file then check it is where it should be.
- if lfile:
- if os.access(os.path.join("sip", lfile), os.F_OK):
-@@ -1434,7 +1435,7 @@
- installs=[(pyqt.module_installs(), opt_pyqtmoddir)]
+@@ -1171,7 +1256,11 @@
+ of libraries.
+ extra_sip_flags is an optional list of additional flags to pass to SIP.
+ """
+- sipconfig.inform("Generating the C++ source for the %s module..." % mname)
++ if freebsd:
++ if mname != 'Qt':
++ sipconfig.inform("Generating the C++ source for the %s module..." % mname)
++ else:
++ sipconfig.inform("Generating the C++ source for the %s module..." % mname)
+
+ mk_clean_dir(mname)
+
+@@ -1243,7 +1332,11 @@
+ sipconfig.error("Unable to create the C++ code.")
+
+ # Generate the Makefile.
+- sipconfig.inform("Creating the Makefile for the %s module..." % mname)
++ if freebsd:
++ if mname != 'Qt':
++ sipconfig.inform("Creating the Makefile for the %s module..." % mname)
++ else:
++ sipconfig.inform("Creating the Makefile for the %s module..." % mname)
+
+ installs = []
+
+@@ -1786,13 +1879,25 @@
+ p.print_help()
+ sys.exit(2)
+
++ if freebsd:
++ # avoid picking up the Qt3 headers instead
++ macros['INCDIR'] = '.'
++
+ sipcfg.set_build_macros(macros)
- if opt_api:
-- installs.append(("PyQt4.api", os.path.join(opt_qscidir, "api", "python")))
-+ installs.append(("QtCore.api", os.path.join(opt_qscidir, "api", "python")))
+ # Check Qt is what we need.
+ pyqt = check_qt_installation(macros)
+ # Check the licenses are compatible.
+- check_license()
++ if not freebsd:
++ check_license()
++ else:
++ print
++ sipconfig.inform("NOTE: This port uses the GPL licensed version of PyQt4.")
++ sipconfig.inform("If you require a commercial license or are unsure, please")
++ sipconfig.inform("read http://www.riverbankcomputing.co.uk/pyqt/index.php\n")
++ print
++ # Sorry, we can't hang auto builds for confirmation and GPL doesn't need it
+
+ # Check which modules to build.
+ pyqt.check_modules()
+@@ -1815,9 +1920,18 @@
+ installs=[(pyqt.module_installs(), pyqt_modroot)]
+
+ if opts.api:
+- installs.append(("PyQt4.api", os.path.join(opts.qscidir, "api", "python")))
++ if freebsd:
++ # Don't break package lists
++ if not freebsd_port in ('dbus', 'designerplugin', 'demo', 'doc'):
++ apifile = pyqt_modules[-1] + '.api'
++ installs.append((apifile, os.path.join(opts.qscidir, "api", "python")))
++ else:
++ installs.append(("PyQt4.api", os.path.join(opts.qscidir, "api", "python")))
+
+- xtra_modules = ["Qt"]
++ if freebsd:
++ xtra_modules = []
++ else:
++ xtra_modules = ["Qt"]
+
+ if opts.bigqt:
+ xtra_modules.append("_qt")
+@@ -1828,14 +1942,31 @@
+ if opts.mwg_qwt_dir:
+ xtra_modules.append("Qwt5")
+
++ if freebsd:
++ if freebsd_port == 'dbus':
++ s = pyqt.tools()
++ elif freebsd_port == 'designer':
++ s = pyqt.qpylibs() + [pyqt_modules[-1]]
++ elif freebsd_port == 'designerplugin':
++ s = pyqt.tools()
++ else:
++ s = [pyqt_modules[-1]]
++ if freebsd_port in ('core', 'xml'):
++ s += pyqt.tools()
++ else: s = pyqt.qpylibs() + pyqt_modules + xtra_modules + pyqt.tools()
++
sipconfig.ParentMakefile(
configuration=sipcfg,
+- subdirs=pyqt.qpylibs() + pyqt_modules + xtra_modules + pyqt.tools(),
++ subdirs=s,
+ installs=installs
+ ).generate()
+
+ # Install the configuration module.
+- create_config("pyqtconfig.py", "pyqtconfig.py.in", macros)
++ if freebsd:
++ if freebsd_port == 'core':
++ create_config("pyqtconfig.py", "pyqtconfig.py.in", macros)
++ else:
++ create_config("pyqtconfig.py", "pyqtconfig.py.in", macros)
+
+
+ ###############################################################################
diff --git a/devel/py-qt4-core/pkg-plist b/devel/py-qt4-core/pkg-plist
index f2d84d3fb389..c28cbe56bdbc 100644
--- a/devel/py-qt4-core/pkg-plist
+++ b/devel/py-qt4-core/pkg-plist
@@ -1,17 +1,11 @@
bin/pyuic4
+%%PYTHON_SITELIBDIR%%/PyQt4/Qt.py
+%%PYTHON_SITELIBDIR%%/PyQt4/Qt.pyc
+%%PYTHON_SITELIBDIR%%/PyQt4/Qt.pyo
%%PYTHON_SITELIBDIR%%/PyQt4/QtCore.so
%%PYTHON_SITELIBDIR%%/PyQt4/__init__.py
%%PYTHON_SITELIBDIR%%/PyQt4/__init__.pyc
%%PYTHON_SITELIBDIR%%/PyQt4/__init__.pyo
-%%ELTREE%%%%PYTHON_SITELIBDIR%%/PyQt4/elementtree/ElementPath.py
-%%ELTREE%%%%PYTHON_SITELIBDIR%%/PyQt4/elementtree/ElementPath.pyc
-%%ELTREE%%%%PYTHON_SITELIBDIR%%/PyQt4/elementtree/ElementPath.pyo
-%%ELTREE%%%%PYTHON_SITELIBDIR%%/PyQt4/elementtree/ElementTree.py
-%%ELTREE%%%%PYTHON_SITELIBDIR%%/PyQt4/elementtree/ElementTree.pyc
-%%ELTREE%%%%PYTHON_SITELIBDIR%%/PyQt4/elementtree/ElementTree.pyo
-%%ELTREE%%%%PYTHON_SITELIBDIR%%/PyQt4/elementtree/__init__.py
-%%ELTREE%%%%PYTHON_SITELIBDIR%%/PyQt4/elementtree/__init__.pyc
-%%ELTREE%%%%PYTHON_SITELIBDIR%%/PyQt4/elementtree/__init__.pyo
%%PYTHON_SITELIBDIR%%/PyQt4/pyqtconfig.py
%%PYTHON_SITELIBDIR%%/PyQt4/pyqtconfig.pyc
%%PYTHON_SITELIBDIR%%/PyQt4/pyqtconfig.pyo
@@ -78,9 +72,11 @@ bin/pyuic4
%%SIPFILES%%%%SIPDIR%%/QtCore/qchar.sip
%%SIPFILES%%%%SIPDIR%%/QtCore/qcoreapplication.sip
%%SIPFILES%%%%SIPDIR%%/QtCore/qcoreevent.sip
+%%SIPFILES%%%%SIPDIR%%/QtCore/qcryptographichash.sip
%%SIPFILES%%%%SIPDIR%%/QtCore/qdatastream.sip
%%SIPFILES%%%%SIPDIR%%/QtCore/qdatetime.sip
%%SIPFILES%%%%SIPDIR%%/QtCore/qdir.sip
+%%SIPFILES%%%%SIPDIR%%/QtCore/qdiriterator.sip
%%SIPFILES%%%%SIPDIR%%/QtCore/qeventloop.sip
%%SIPFILES%%%%SIPDIR%%/QtCore/qfile.sip
%%SIPFILES%%%%SIPDIR%%/QtCore/qfileinfo.sip
@@ -98,6 +94,7 @@ bin/pyuic4
%%SIPFILES%%%%SIPDIR%%/QtCore/qmimedata.sip
%%SIPFILES%%%%SIPDIR%%/QtCore/qmutex.sip
%%SIPFILES%%%%SIPDIR%%/QtCore/qnamespace.sip
+%%SIPFILES%%%%SIPDIR%%/QtCore/qnumeric.sip
%%SIPFILES%%%%SIPDIR%%/QtCore/qobject.sip
%%SIPFILES%%%%SIPDIR%%/QtCore/qobjectcleanuphandler.sip
%%SIPFILES%%%%SIPDIR%%/QtCore/qobjectdefs.sip
@@ -129,15 +126,13 @@ bin/pyuic4
%%SIPFILES%%%%SIPDIR%%/QtCore/qvariant.sip
%%SIPFILES%%%%SIPDIR%%/QtCore/qvector.sip
%%SIPFILES%%%%SIPDIR%%/QtCore/qwaitcondition.sip
-%%ELTREE%%@dirrm %%PYTHON_SITELIBDIR%%/PyQt4/elementtree
+%%API%%%%APIFILE%%
@dirrm %%PYTHON_SITELIBDIR%%/PyQt4/uic/Compiler
@dirrm %%PYTHON_SITELIBDIR%%/PyQt4/uic/Loader
@dirrm %%PYTHON_SITELIBDIR%%/PyQt4/uic/widget-plugins
@dirrm %%PYTHON_SITELIBDIR%%/PyQt4/uic
%%SIPFILES%%@dirrm %%SIPDIR%%/QtCore
@dirrm %%PYTHON_SITELIBDIR%%/PyQt4
-@cwd %%LOCALBASE%%
-%%API%%%%APIFILE%%
%%API%%@dirrmtry share/qt4/qsci/api/python
%%API%%@dirrmtry share/qt4/qsci/api
%%API%%@dirrmtry share/qt4/qsci