aboutsummaryrefslogtreecommitdiff
path: root/devel/py-qt4-core
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-10-02 09:58:36 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-10-02 09:58:36 +0000
commit5d6ad60da0b5a4d20f001d1296ce01376c919d4c (patch)
tree0f64111843859243cc4eb6b3127ce94f0770ad75 /devel/py-qt4-core
parentf7d08c88e932d2b5a99115d83909fc698e5a4b59 (diff)
downloadports-5d6ad60da0b5a4d20f001d1296ce01376c919d4c.tar.gz
ports-5d6ad60da0b5a4d20f001d1296ce01376c919d4c.zip
Notes
Diffstat (limited to 'devel/py-qt4-core')
-rw-r--r--devel/py-qt4-core/Makefile2
-rw-r--r--devel/py-qt4-core/distinfo6
-rw-r--r--devel/py-qt4-core/files/patch-configure.py18
3 files changed, 16 insertions, 10 deletions
diff --git a/devel/py-qt4-core/Makefile b/devel/py-qt4-core/Makefile
index 6b07e29dd61f..39cae21ffabe 100644
--- a/devel/py-qt4-core/Makefile
+++ b/devel/py-qt4-core/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= core
-PORTVERSION= 4.3
+PORTVERSION= 4.3.1
PORTREVISION= # zero
CATEGORIES= devel python
MASTER_SITES= http://www.riverbankcomputing.com/Downloads/PyQt4/GPL/ \
diff --git a/devel/py-qt4-core/distinfo b/devel/py-qt4-core/distinfo
index 504192030ea8..7f92e8fa957f 100644
--- a/devel/py-qt4-core/distinfo
+++ b/devel/py-qt4-core/distinfo
@@ -1,3 +1,3 @@
-MD5 (PyQt-x11-gpl-4.3.tar.gz) = 3bb0c0064dc6b8b80413f87a14e5553c
-SHA256 (PyQt-x11-gpl-4.3.tar.gz) = c184c3df596c13e9ed610aa8fa0504881976c4d972ccab1b739738a95f4ab0e5
-SIZE (PyQt-x11-gpl-4.3.tar.gz) = 6036193
+MD5 (PyQt-x11-gpl-4.3.1.tar.gz) = 5d0095d7f08a973b4a04e09e7f6ab568
+SHA256 (PyQt-x11-gpl-4.3.1.tar.gz) = ed65a89360746a6e07113441a66fbcc545570391ae382fc1004b2f728805d861
+SIZE (PyQt-x11-gpl-4.3.1.tar.gz) = 6176590
diff --git a/devel/py-qt4-core/files/patch-configure.py b/devel/py-qt4-core/files/patch-configure.py
index 825f18e0a2e5..8e5a1c5eda50 100644
--- a/devel/py-qt4-core/files/patch-configure.py
+++ b/devel/py-qt4-core/files/patch-configure.py
@@ -1,5 +1,5 @@
---- configure.py.orig Mon Jul 30 18:11:39 2007
-+++ configure.py Fri Aug 10 22:22:34 2007
+--- configure.py.orig 2007-07-30 18:11:39.000000000 +0200
++++ configure.py 2007-09-29 18:26:58.000000000 +0200
@@ -29,6 +29,10 @@
import sipconfig
@@ -179,19 +179,25 @@
if "QtDesigner" in pyqt_modules:
enabled = True
-@@ -719,6 +773,12 @@
+@@ -719,11 +773,17 @@
glob.glob("%s/lib/libpython%d.%d*" % (ducfg["prefix"], py_major, py_minor))):
lib_dir_flag = quote("-L%s/lib" % ducfg["prefix"])
link = "%s -lpython%d.%d" % (lib_dir_flag, py_major, py_minor)
+ elif freebsd:
-+ # We do have shared libpython, but also static. Alas
-+ # static is built *first*, and to distutils it looks as
-+ # if we have static py only
+ lib_dir_flag = quote("-L%s/lib" % ducfg["prefix"])
+ link = "%s -lpython%d.%d" % (lib_dir_flag, py_major, py_minor)
else:
sipconfig.inform("Qt Designer plugin disabled because Python library is static")
enabled = False
+
+- pysh_lib = ducfg["LDLIBRARY"]
++ if freebsd:
++ pysh_lib = "libpython%d.%d" % (py_major, py_minor)
++ else:
++ pysh_lib = ducfg["LDLIBRARY"]
+
+ if enabled:
+ sipconfig.inform("Creating Qt Designer plugin Makefile...")
@@ -791,19 +851,44 @@
sipconfig.inform("The %s %s library is in %s." % (lib_type, qt_lib, qt_libdir))
sipconfig.inform("The Qt binaries are in %s." % qt_bindir)