aboutsummaryrefslogtreecommitdiff
path: root/devel/py-qt4-designerplugin
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-27 10:04:15 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-27 10:04:15 +0000
commitb2108a0d7cf71d8dadd6724227fdfca6b5f87fd2 (patch)
treec590971a8097e3095e25747fcf5ac4a2c208ac0e /devel/py-qt4-designerplugin
parent0ee9f92c3553b970a5fa7653d9b53737f760467c (diff)
downloadports-b2108a0d7cf71d8dadd6724227fdfca6b5f87fd2.tar.gz
ports-b2108a0d7cf71d8dadd6724227fdfca6b5f87fd2.zip
Notes
Diffstat (limited to 'devel/py-qt4-designerplugin')
-rw-r--r--devel/py-qt4-designerplugin/Makefile47
-rw-r--r--devel/py-qt4-designerplugin/distinfo3
-rw-r--r--devel/py-qt4-designerplugin/files/patch-configure.py194
-rw-r--r--devel/py-qt4-designerplugin/pkg-descr4
-rw-r--r--devel/py-qt4-designerplugin/pkg-plist5
5 files changed, 253 insertions, 0 deletions
diff --git a/devel/py-qt4-designerplugin/Makefile b/devel/py-qt4-designerplugin/Makefile
new file mode 100644
index 000000000000..847b8ee9f417
--- /dev/null
+++ b/devel/py-qt4-designerplugin/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: py-qt4-designerplugin
+# Date created: 2007-02-20
+# Whom: Danny Pansters <danny@ricin.com>
+#
+# $FreeBSD$
+
+PORTNAME= designerplugin
+PORTVERSION= 20070318
+CATEGORIES= devel python
+MASTER_SITES= http://www.riverbankcomputing.com/Downloads/Snapshots/PyQt4/ \
+ http://freebsd.ricin.com/ports/distfiles/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}qt4-
+DISTNAME= PyQt-x11-gpl-4-snapshot-${PORTVERSION}
+
+MAINTAINER= danny@ricin.com
+COMMENT= Python bindings for the Qt4 toolkit, QtDesigner plugin
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/PyQt4/QtDesigner.so:${PORTSDIR}/devel/py-qt4-designer \
+ ${PYTHON_SITELIBDIR}/PyQt4/QtXml.so:${PORTSDIR}/textproc/py-qt4-xml
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+HAS_CONFIGURE= yes
+USE_PYTHON= 2.3+
+USE_QT_VER= 4
+QT_COMPONENTS= designer moc qmake xml
+
+OPTIONS= DEBUG "Enable debugging in generated code" off \
+ TRACING "Enable tracing in generated code" off
+
+OPTIONSFILE= ${PORT_DBDIR}/py-qt4-${PORTNAME}/options
+ARGS= -b ${PREFIX}/bin -c -j 2 -d ${PYTHONPREFIX_SITELIBDIR}/PyQt4 \
+ -q ${QT_PREFIX}/bin/qmake-qt4
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_DEBUG)
+ARGS+= -u
+.endif
+.if defined(WITH_TRACING)
+ARGS+= -r
+.endif
+
+do-configure:
+ ( cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
+ ${PYTHON_CMD} configure.py ${ARGS} )
+
+.include <bsd.port.post.mk>
diff --git a/devel/py-qt4-designerplugin/distinfo b/devel/py-qt4-designerplugin/distinfo
new file mode 100644
index 000000000000..b42fc45ded6f
--- /dev/null
+++ b/devel/py-qt4-designerplugin/distinfo
@@ -0,0 +1,3 @@
+MD5 (PyQt-x11-gpl-4-snapshot-20070318.tar.gz) = 538cd5167ccb14a6b6a3ee687432617a
+SHA256 (PyQt-x11-gpl-4-snapshot-20070318.tar.gz) = d98516e20b02194264c199deddda2562845efca64315608522cc05a36c9210c7
+SIZE (PyQt-x11-gpl-4-snapshot-20070318.tar.gz) = 1076275
diff --git a/devel/py-qt4-designerplugin/files/patch-configure.py b/devel/py-qt4-designerplugin/files/patch-configure.py
new file mode 100644
index 000000000000..4337fca664b7
--- /dev/null
+++ b/devel/py-qt4-designerplugin/files/patch-configure.py
@@ -0,0 +1,194 @@
+--- configure.py.orig Mon Mar 19 04:33:57 2007
++++ configure.py Mon Mar 19 20:02:07 2007
+@@ -133,21 +133,21 @@
+ }
+
+ def check_modules(self):
+- pyqt_modules.append("QtCore")
++ #pyqt_modules.append("QtCore")
+
+- check_module("QtGui", "qwidget.h", "new QWidget()")
+- check_module("QtNetwork", "qhostaddress.h", "new QHostAddress()")
+- check_module("QtOpenGL", "qgl.h", "new QGLWidget()")
+- check_module("QtSql", "qsqldatabase.h", "new QSqlDatabase()")
+- check_module("QtSvg", "qsvgwidget.h", "new QSvgWidget()")
+- check_module("QtTest", "QtTest", "QTest::qSleep(0)")
+- check_module("QtXml", "qdom.h", "new QDomDocument()")
+- check_module("QtAssistant", "qassistantclient.h", "new QAssistantClient(\"foo\")")
++ #check_module("QtGui", "qwidget.h", "new QWidget()")
++ #check_module("QtNetwork", "qhostaddress.h", "new QHostAddress()")
++ #check_module("QtOpenGL", "qgl.h", "new QGLWidget()")
++ #check_module("QtSql", "qsqldatabase.h", "new QSqlDatabase()")
++ #check_module("QtSvg", "qsvgwidget.h", "new QSvgWidget()")
++ #check_module("QtTest", "QtTest", "QTest::qSleep(0)")
++ #check_module("QtXml", "qdom.h", "new QDomDocument()")
++ #check_module("QtAssistant", "qassistantclient.h", "new QAssistantClient(\"foo\")")
+ check_module("QtDesigner", "QExtensionFactory", "new QExtensionFactory()")
+- check_module("QAxContainer", "qaxobject.h", "new QAxObject()", "QAxContainer")
++ #check_module("QAxContainer", "qaxobject.h", "new QAxObject()", "QAxContainer")
+
+- if os.path.isdir("dbus"):
+- check_dbus()
++ #if os.path.isdir("dbus"):
++ # check_dbus()
+
+ def code(self):
+ # Note that the order of the dependent modules is important.
+@@ -201,31 +201,31 @@
+ generate_code("QAxContainer", ["QAxContainer", "QtGui", "QtCore"])
+
+ # Generate the consolidated module.
+- sipconfig.inform("Creating Qt consolidated module...")
+- f = open("Qt.py", "w")
++ #sipconfig.inform("Creating Qt consolidated module...")
++ #f = open("Qt.py", "w")
+
+- for m in pyqt_modules:
+- f.write("from PyQt4.%s import *\n" % m)
++ #for m in pyqt_modules:
++ # f.write("from PyQt4.%s import *\n" % m)
+
+- f.close()
++ #f.close()
+
+ # Generate the QScintilla API file.
+- sipconfig.inform("Creating QScintilla API file...")
+- f = open("PyQt4.api", "w")
++ #sipconfig.inform("Creating QScintilla API file...")
++ #f = open("PyQt4.api", "w")
+
+- for m in pyqt_modules:
+- api = open(m + ".api")
++ #for m in pyqt_modules:
++ # api = open(m + ".api")
+
+- for l in api:
+- f.write("PyQt4." + l)
++ # for l in api:
++ # f.write("PyQt4." + l)
+
+- api.close()
+- os.remove(m + ".api")
++ # api.close()
++ # os.remove(m + ".api")
+
+- f.close()
++ #f.close()
+
+ def module_installs(self):
+- return ["__init__.py", "Qt.py", "pyqtconfig.py"]
++ return []
+
+ def qpylibs(self):
+ # See which QPy libraries to build.
+@@ -278,7 +278,7 @@
+ tool.append("dbus")
+
+ # Only include ElementTree for older versions of Python.
+- if sipcfg.py_version < 0x020500:
++ """if sipcfg.py_version < 0x020500:
+ sipconfig.inform("Creating elementtree Makefile...")
+
+ makefile = sipconfig.PythonModuleMakefile(
+@@ -309,7 +309,7 @@
+ )
+
+ makefile.generate()
+- tool.append("pyuic")
++ tool.append("pyuic")"""
+
+ if "QtXml" in pyqt_modules:
+ sipconfig.inform("Creating pylupdate4 Makefile...")
+@@ -344,7 +344,8 @@
+ makefile.generate()
+ tool.append("pyrcc")
+ else:
+- sipconfig.inform("pylupdate4 and pyrcc4 will not be built because the Qt XML module is missing.")
++ #sipconfig.inform("pylupdate4 and pyrcc4 will not be built because the Qt XML module is missing.")
++ pass
+
+ if "QtDesigner" in pyqt_modules:
+ enabled = True
+@@ -364,7 +365,10 @@
+ # We need to work out how to specify the right framework
+ # version.
+ link = "-framework Python"
+- elif ("--enable-shared" in ducfg.get("CONFIG_ARGS", "") and
++ # FreeBSD python port configures and builds for static first,
++ # then builds for shared later, so this test won't work:
++ #elif ("--enable-shared" in ducfg.get("CONFIG_ARGS", "") and
++ elif (sys.platform[:-1] == "freebsd" and
+ glob.glob("%s/lib/libpython%d.%d*" % (ducfg["prefix"], py_major, py_minor))):
+ link = "-L%s/lib -lpython%d.%d" % (ducfg["prefix"], py_major, py_minor)
+ else:
+@@ -420,16 +424,16 @@
+ sipconfig.inform("The %s Qt library is in %s." % (qt_lib, qt_libdir))
+ sipconfig.inform("The Qt binaries are in %s." % qt_bindir)
+ sipconfig.inform("The Qt mkspecs directory is in %s." % qt_datadir)
+- sipconfig.inform("These PyQt modules will be built: %s." % string.join(pyqt_modules))
++ #sipconfig.inform("These PyQt modules will be built: %s." % string.join(pyqt_modules))
+
+- sipconfig.inform("The PyQt modules will be installed in %s." % opt_pyqtmoddir)
++ #sipconfig.inform("The PyQt modules will be installed in %s." % opt_pyqtmoddir)
+
+ if pydbusmoddir:
+ sipconfig.inform("The dbus support module will be installed in %s." % pydbusmoddir)
+
+- sipconfig.inform("The PyQt .sip files will be installed in %s." % opt_pyqtsipdir)
++ #sipconfig.inform("The PyQt .sip files will be installed in %s." % opt_pyqtsipdir)
+
+- sipconfig.inform("pyuic4, pyrcc4 and pylupdate4 will be installed in %s." % opt_pyqtbindir)
++ #sipconfig.inform("pyuic4, pyrcc4 and pylupdate4 will be installed in %s." % opt_pyqtbindir)
+
+ if opt_vendorcheck:
+ sipconfig.inform("PyQt will only be usable with signed interpreters.")
+@@ -767,7 +771,8 @@
+ sipfiles = []
+
+ for s in glob.glob("sip/" + mname + "/*.sip"):
+- sipfiles.append(os.path.join("..", "sip", mname, os.path.basename(s)))
++ if mname == "":
++ sipfiles.append(os.path.join("..", "sip", mname, os.path.basename(s)))
+
+ installs.append([sipfiles, os.path.join(opt_pyqtsipdir, mname)])
+
+@@ -831,7 +836,7 @@
+ sipconfig.error("This version of PyQt and the %s edition of Qt have incompatible licenses." % qted)
+
+ # Confirm the license.
+- print
++ """print
+ print "Type 'L' to view the license."
+ print "Type 'yes' to accept the terms of the license."
+ print "Type 'no' to decline the terms of the license."
+@@ -853,7 +858,7 @@
+
+ if resp == "l":
+ os.system("more LICENSE")
+-
++ """
+ # If there should be a license file then check it is where it should be.
+ if lfile:
+ if os.access(os.path.join("sip", lfile), os.F_OK):
+@@ -1372,17 +1377,17 @@
+
+ scidir = os.path.join(qt_datadir, "qsci")
+
+- if opt_api or os.path.isdir(scidir):
+- installs.append(("PyQt4.api", os.path.join(scidir, "api", "python")))
++ #if opt_api or os.path.isdir(scidir):
++ # installs.append(("PyQt4.api", os.path.join(scidir, "api", "python")))
+
+ sipconfig.ParentMakefile(
+ configuration=sipcfg,
+- subdirs=pyqt.qpylibs() + pyqt_modules + pyqt.tools(),
++ subdirs=pyqt.qpylibs() + pyqt.tools(),
+ installs=installs
+ ).generate()
+
+ # Install the configuration module.
+- create_config("pyqtconfig.py", "pyqtconfig.py.in", macros)
++ #create_config("pyqtconfig.py", "pyqtconfig.py.in", macros)
+
+
+ ###############################################################################
diff --git a/devel/py-qt4-designerplugin/pkg-descr b/devel/py-qt4-designerplugin/pkg-descr
new file mode 100644
index 000000000000..423666c7ab5c
--- /dev/null
+++ b/devel/py-qt4-designerplugin/pkg-descr
@@ -0,0 +1,4 @@
+PyQt4 is a set of Python bindings for Trolltech's Qt4 application framework.
+This package provides the QtDesigner plugin.
+
+WWW: http://www.riverbankcomputing.co.uk/pyqt/
diff --git a/devel/py-qt4-designerplugin/pkg-plist b/devel/py-qt4-designerplugin/pkg-plist
new file mode 100644
index 000000000000..1dd17eb17355
--- /dev/null
+++ b/devel/py-qt4-designerplugin/pkg-plist
@@ -0,0 +1,5 @@
+@cwd %%LOCALBASE%%
+lib/plugins/designer/libpythonplugin.so
+@exec mkdir -p %D/lib/plugins/designer/python
+@dirrmtry lib/plugins/designer/python
+@dirrmtry lib/plugins/designer