aboutsummaryrefslogtreecommitdiff
path: root/devel/py-qt4-designerplugin
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-09-13 18:15:58 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-09-13 18:15:58 +0000
commit71fee7a28f398a2397323d85043fe27f64592ff3 (patch)
tree1bd1d6b6cd839caa689ea882fe31da6bd8c7ae79 /devel/py-qt4-designerplugin
parent3a031558959ee2330ba8253b9752de0ea489d195 (diff)
Notes
Diffstat (limited to 'devel/py-qt4-designerplugin')
-rw-r--r--devel/py-qt4-designerplugin/Makefile33
-rw-r--r--devel/py-qt4-designerplugin/distinfo6
-rw-r--r--devel/py-qt4-designerplugin/files/patch-configure.py204
-rw-r--r--devel/py-qt4-designerplugin/pkg-plist9
4 files changed, 28 insertions, 224 deletions
diff --git a/devel/py-qt4-designerplugin/Makefile b/devel/py-qt4-designerplugin/Makefile
index 3afc1254c8b2..c36ba454c5d8 100644
--- a/devel/py-qt4-designerplugin/Makefile
+++ b/devel/py-qt4-designerplugin/Makefile
@@ -5,8 +5,8 @@
# $FreeBSD$
PORTNAME= designerplugin
-PORTVERSION= 4.2
-PORTREVISION= 1
+PORTVERSION= 4.3
+PORTREVISION= # zero
CATEGORIES= devel python
MASTER_SITES= http://www.riverbankcomputing.com/Downloads/PyQt4/GPL/ \
http://freebsd.ricin.com/ports/distfiles/
@@ -16,33 +16,42 @@ DISTNAME= PyQt-x11-gpl-${PORTVERSION}
MAINTAINER= danny@ricin.com
COMMENT= Python bindings for the Qt4 toolkit, QtDesigner plugin
-BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/PyQt4/QtDesigner.so:${PORTSDIR}/devel/py-qt4-designer \
- ${PYTHON_SITELIBDIR}/PyQt4/QtXml.so:${PORTSDIR}/textproc/py-qt4-xml
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${LOCALBASE}/bin/sip:${PORTSDIR}/devel/py-sip
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/PyQt4/QtDesigner.so:${PORTSDIR}/devel/py-qt4-designer
HAS_CONFIGURE= yes
-USE_PYTHON= 2.3+
+USE_PYTHON= 2.5+
USE_QT_VER= 4
-QT_COMPONENTS= designer moc qmake xml
+QT_COMPONENTS= designer moc gui xml qmake
OPTIONS= DEBUG "Enable debugging in generated code" off \
TRACING "Enable tracing in generated code" off
+PATCHDIR= ${PORTSDIR}/devel/py-qt4-core/files
OPTIONSFILE= ${PORT_DBDIR}/py-qt4-${PORTNAME}/options
-ARGS= -b ${PREFIX}/bin -c -j 2 -d ${PYTHONPREFIX_SITELIBDIR}/PyQt4 \
+CONFIGURE_ENV+= PYQT4_COMPONENT="${PORTNAME}"
+ARGS= -b ${PREFIX}/bin\
+ -d ${PYTHON_SITELIBDIR}\
-q ${QT_PREFIX}/bin/qmake-qt4
.include <bsd.port.pre.mk>
.if defined(WITH_DEBUG)
-ARGS+= -u
+ARGS+= --debug
.endif
.if defined(WITH_TRACING)
-ARGS+= -r
+ARGS+= --trace
.endif
+ARGS+= --enable QtDesigner
do-configure:
- ( cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${PYTHON_CMD} configure.py ${ARGS} )
+ cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV}\
+ ${PYTHON_CMD} configure.py ${ARGS}
+
+post-configure:
+ ${REINPLACE_CMD} -e 's|CC = cc|CC = ${CC}|'\
+ -e 's|CXX = c++|CXX = ${CXX}|'\
+ -e 's|LINK = c++|LINK = ${CXX}|'\
+ ${WRKSRC}/designer/Makefile
.include <bsd.port.post.mk>
diff --git a/devel/py-qt4-designerplugin/distinfo b/devel/py-qt4-designerplugin/distinfo
index 3317bc659e04..504192030ea8 100644
--- a/devel/py-qt4-designerplugin/distinfo
+++ b/devel/py-qt4-designerplugin/distinfo
@@ -1,3 +1,3 @@
-MD5 (PyQt-x11-gpl-4.2.tar.gz) = af4baa7f7441914f9a527ef3cf788fef
-SHA256 (PyQt-x11-gpl-4.2.tar.gz) = 6fa8a853a66ae500f36629793e7d4c54896c7ccf6337c2b90ea0175b28aa7ae6
-SIZE (PyQt-x11-gpl-4.2.tar.gz) = 5661258
+MD5 (PyQt-x11-gpl-4.3.tar.gz) = 3bb0c0064dc6b8b80413f87a14e5553c
+SHA256 (PyQt-x11-gpl-4.3.tar.gz) = c184c3df596c13e9ed610aa8fa0504881976c4d972ccab1b739738a95f4ab0e5
+SIZE (PyQt-x11-gpl-4.3.tar.gz) = 6036193
diff --git a/devel/py-qt4-designerplugin/files/patch-configure.py b/devel/py-qt4-designerplugin/files/patch-configure.py
deleted file mode 100644
index 387ab8215400..000000000000
--- a/devel/py-qt4-designerplugin/files/patch-configure.py
+++ /dev/null
@@ -1,204 +0,0 @@
---- configure.py.orig Tue Apr 10 17:59:52 2007
-+++ configure.py Thu Apr 12 21:36:39 2007
-@@ -138,26 +138,26 @@
- }
-
- def check_modules(self):
-- pyqt_modules.append("QtCore")
-+ #pyqt_modules.append("QtCore")
-
-- check_module("QtGui", "qwidget.h", "new QWidget()")
-- check_module("QtNetwork", "qhostaddress.h", "new QHostAddress()")
-- check_module("QtOpenGL", "qgl.h", "new QGLWidget()")
-- check_module("QtSql", "qsqldatabase.h", "new QSqlDatabase()")
-- check_module("QtSvg", "qsvgwidget.h", "new QSvgWidget()")
-- check_module("QtTest", "QtTest", "QTest::qSleep(0)")
-- check_module("QtXml", "qdom.h", "new QDomDocument()")
-- check_module("QtAssistant", "qassistantclient.h", "new QAssistantClient(\"foo\")")
-+ #check_module("QtGui", "qwidget.h", "new QWidget()")
-+ #check_module("QtNetwork", "qhostaddress.h", "new QHostAddress()")
-+ #check_module("QtOpenGL", "qgl.h", "new QGLWidget()")
-+ #check_module("QtSql", "qsqldatabase.h", "new QSqlDatabase()")
-+ #check_module("QtSvg", "qsvgwidget.h", "new QSvgWidget()")
-+ #check_module("QtTest", "QtTest", "QTest::qSleep(0)")
-+ #check_module("QtXml", "qdom.h", "new QDomDocument()")
-+ #check_module("QtAssistant", "qassistantclient.h", "new QAssistantClient(\"foo\")")
-
- if sipcfg.universal:
- sipconfig.inform("QtDesigner module disabled with universal binaries")
- else:
- check_module("QtDesigner", "QExtensionFactory", "new QExtensionFactory()")
-
-- check_module("QAxContainer", "qaxobject.h", "new QAxObject()", "QAxContainer")
-+ #check_module("QAxContainer", "qaxobject.h", "new QAxObject()", "QAxContainer")
-
-- if os.path.isdir("dbus"):
-- check_dbus()
-+ #if os.path.isdir("dbus"):
-+ # check_dbus()
-
- def code(self):
- # Note that the order of the dependent modules is important.
-@@ -211,31 +211,31 @@
- generate_code("QAxContainer", ["QAxContainer", "QtGui", "QtCore"])
-
- # Generate the consolidated module.
-- sipconfig.inform("Creating Qt consolidated module...")
-- f = open("Qt.py", "w")
-+ #sipconfig.inform("Creating Qt consolidated module...")
-+ #f = open("Qt.py", "w")
-
-- for m in pyqt_modules:
-- f.write("from PyQt4.%s import *\n" % m)
-+ #for m in pyqt_modules:
-+ # f.write("from PyQt4.%s import *\n" % m)
-
-- f.close()
-+ #f.close()
-
- # Generate the QScintilla API file.
-- sipconfig.inform("Creating QScintilla API file...")
-- f = open("PyQt4.api", "w")
-+ #sipconfig.inform("Creating QScintilla API file...")
-+ #f = open("PyQt4.api", "w")
-
-- for m in pyqt_modules:
-- api = open(m + ".api")
-+ #for m in pyqt_modules:
-+ # api = open(m + ".api")
-
-- for l in api:
-- f.write("PyQt4." + l)
-+ # for l in api:
-+ # f.write("PyQt4." + l)
-
-- api.close()
-- os.remove(m + ".api")
-+ # api.close()
-+ # os.remove(m + ".api")
-
-- f.close()
-+ #f.close()
-
- def module_installs(self):
-- return ["__init__.py", "Qt.py", "pyqtconfig.py"]
-+ return []
-
- def qpylibs(self):
- # See which QPy libraries to build.
-@@ -308,7 +308,7 @@
- tool.append("dbus")
-
- # Only include ElementTree for older versions of Python.
-- if sipcfg.py_version < 0x020500:
-+ """if sipcfg.py_version < 0x020500:
- sipconfig.inform("Creating elementtree Makefile...")
-
- makefile = sipconfig.PythonModuleMakefile(
-@@ -339,7 +339,7 @@
- )
-
- makefile.generate()
-- tool.append("pyuic")
-+ tool.append("pyuic")"""
-
- if "QtXml" in pyqt_modules:
- sipconfig.inform("Creating pylupdate4 Makefile...")
-@@ -376,7 +376,8 @@
- makefile.generate()
- tool.append("pyrcc")
- else:
-- sipconfig.inform("pylupdate4 and pyrcc4 will not be built because the Qt XML module is missing.")
-+ #sipconfig.inform("pylupdate4 and pyrcc4 will not be built because the Qt XML module is missing.")
-+ pass
-
- if "QtDesigner" in pyqt_modules:
- enabled = True
-@@ -396,7 +397,10 @@
- # We need to work out how to specify the right framework
- # version.
- link = "-framework Python"
-- elif ("--enable-shared" in ducfg.get("CONFIG_ARGS", "") and
-+ # FreeBSD python port configures and builds for static first,
-+ # then builds for shared later, so this test won't work:
-+ #elif ("--enable-shared" in ducfg.get("CONFIG_ARGS", "") and
-+ elif (sys.platform[:-1] == "freebsd" and
- glob.glob("%s/lib/libpython%d.%d*" % (ducfg["prefix"], py_major, py_minor))):
- link = "-L%s/lib -lpython%d.%d" % (ducfg["prefix"], py_major, py_minor)
- else:
-@@ -458,19 +462,19 @@
- sipconfig.inform("The %s Qt library is in %s." % (qt_lib, qt_libdir))
- sipconfig.inform("The Qt binaries are in %s." % qt_bindir)
- sipconfig.inform("The Qt mkspecs directory is in %s." % qt_datadir)
-- sipconfig.inform("These PyQt modules will be built: %s." % string.join(pyqt_modules))
-- sipconfig.inform("The PyQt modules will be installed in %s." % opt_pyqtmoddir)
-+ #sipconfig.inform("These PyQt modules will be built: %s." % string.join(pyqt_modules))
-+ #sipconfig.inform("The PyQt modules will be installed in %s." % opt_pyqtmoddir)
- sipconfig.inform("The Designer plugin will be installed in %s." % os.path.join(opt_plugindir, "designer"))
-
-- if opt_api:
-- sipconfig.inform("The QScintilla API file will be installed in %s." % os.path.join(opt_qscidir, "api", "python"))
-+ #if opt_api:
-+ # sipconfig.inform("The QScintilla API file will be installed in %s." % os.path.join(opt_qscidir, "api", "python"))
-
- if pydbusmoddir:
- sipconfig.inform("The dbus support module will be installed in %s." % pydbusmoddir)
-
-- sipconfig.inform("The PyQt .sip files will be installed in %s." % opt_pyqtsipdir)
-+ #sipconfig.inform("The PyQt .sip files will be installed in %s." % opt_pyqtsipdir)
-
-- sipconfig.inform("pyuic4, pyrcc4 and pylupdate4 will be installed in %s." % opt_pyqtbindir)
-+ #sipconfig.inform("pyuic4, pyrcc4 and pylupdate4 will be installed in %s." % opt_pyqtbindir)
-
- if opt_vendorcheck:
- sipconfig.inform("PyQt will only be usable with signed interpreters.")
-@@ -808,7 +812,8 @@
- sipfiles = []
-
- for s in glob.glob("sip/" + mname + "/*.sip"):
-- sipfiles.append(os.path.join("..", "sip", mname, os.path.basename(s)))
-+ if mname == "":
-+ sipfiles.append(os.path.join("..", "sip", mname, os.path.basename(s)))
-
- installs.append([sipfiles, os.path.join(opt_pyqtsipdir, mname)])
-
-@@ -873,7 +878,7 @@
- sipconfig.error("This version of PyQt and the %s edition of Qt have incompatible licenses." % qted)
-
- # Confirm the license.
-- print
-+ """print
- print "Type 'L' to view the license."
- print "Type 'yes' to accept the terms of the license."
- print "Type 'no' to decline the terms of the license."
-@@ -895,7 +900,7 @@
-
- if resp == "l":
- os.system("more LICENSE")
--
-+ """
- # If there should be a license file then check it is where it should be.
- if lfile:
- if os.access(os.path.join("sip", lfile), os.F_OK):
-@@ -1433,17 +1438,17 @@
-
- installs=[(pyqt.module_installs(), opt_pyqtmoddir)]
-
-- if opt_api:
-- installs.append(("PyQt4.api", os.path.join(opt_qscidir, "api", "python")))
-+ #if opt_api:
-+ # installs.append(("PyQt4.api", os.path.join(opt_qscidir, "api", "python")))
-
- sipconfig.ParentMakefile(
- configuration=sipcfg,
-- subdirs=pyqt.qpylibs() + pyqt_modules + pyqt.tools(),
-+ subdirs=pyqt.qpylibs() + pyqt.tools(),
- installs=installs
- ).generate()
-
- # Install the configuration module.
-- create_config("pyqtconfig.py", "pyqtconfig.py.in", macros)
-+ #create_config("pyqtconfig.py", "pyqtconfig.py.in", macros)
-
-
- ###############################################################################
diff --git a/devel/py-qt4-designerplugin/pkg-plist b/devel/py-qt4-designerplugin/pkg-plist
index 1dd17eb17355..ca9111d0f20f 100644
--- a/devel/py-qt4-designerplugin/pkg-plist
+++ b/devel/py-qt4-designerplugin/pkg-plist
@@ -1,5 +1,4 @@
-@cwd %%LOCALBASE%%
-lib/plugins/designer/libpythonplugin.so
-@exec mkdir -p %D/lib/plugins/designer/python
-@dirrmtry lib/plugins/designer/python
-@dirrmtry lib/plugins/designer
+lib/qt4/plugins/designer/libpythonplugin.so
+@exec mkdir -p %D/lib/qt4/plugins/designer/python
+@dirrmtry lib/qt4/plugins/designer/python
+@dirrmtry lib/qt4/plugins/designer