aboutsummaryrefslogtreecommitdiff
path: root/devel/py-qt4-qscintilla2
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-09 20:51:20 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-09 20:51:20 +0000
commit5bc4de91b66b5cec18e98ad9233fa5fd78809634 (patch)
treef61087f51404fcd525ac801e1fe66cbd35bc278d /devel/py-qt4-qscintilla2
parent514d2687901bb6c21fd4e396907688472b3ff30a (diff)
downloadports-5bc4de91b66b5cec18e98ad9233fa5fd78809634.tar.gz
ports-5bc4de91b66b5cec18e98ad9233fa5fd78809634.zip
Notes
Diffstat (limited to 'devel/py-qt4-qscintilla2')
-rw-r--r--devel/py-qt4-qscintilla2/Makefile6
-rw-r--r--devel/py-qt4-qscintilla2/files/Makefile.in7
2 files changed, 9 insertions, 4 deletions
diff --git a/devel/py-qt4-qscintilla2/Makefile b/devel/py-qt4-qscintilla2/Makefile
index e2a60da6e7ec..f749e613d1a6 100644
--- a/devel/py-qt4-qscintilla2/Makefile
+++ b/devel/py-qt4-qscintilla2/Makefile
@@ -6,7 +6,7 @@
PORTNAME= qscintilla2
PORTVERSION= ${QSCI2_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= devel
@@ -26,6 +26,8 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
HAS_CONFIGURE= yes
USE_PYTHON= 2.5+
+USE_QT_VER= 4
+QT_COMPONENTS= gui
OPTIONS= API "Install binding API for QScintilla2" on \
DEBUG "Enable debugging in generated code" off \
@@ -73,6 +75,8 @@ do-configure:
post-configure:
${CP} ${FILESDIR}/Makefile.in ${WRKSRC}/Makefile &&\
${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g'\
+ -e 's|%%QT_INCDIR%%|${QT_INCDIR}|g'\
+ -e 's|%%QT_LIBDIR%%|${QT_LIBDIR}|g'\
-e 's|%%PYVER%%|${PYVER}|g'\
-e 's|CC = cc|CC = ${CC}|'\
-e 's|CXX = c++|CXX = ${CXX}|'\
diff --git a/devel/py-qt4-qscintilla2/files/Makefile.in b/devel/py-qt4-qscintilla2/files/Makefile.in
index 09a79f24b290..803ee3682314 100644
--- a/devel/py-qt4-qscintilla2/files/Makefile.in
+++ b/devel/py-qt4-qscintilla2/files/Makefile.in
@@ -8,13 +8,14 @@ LINK = c++
CPPFLAGS = -DQT_NO_DEBUG -DQT_CORE_LIB -DQT_GUI_LIB\
-I%%LOCALBASE%%/include/python%%PYVER%%\
-I%%LOCALBASE%%/share/qt4/mkspecs/freebsd-g++\
- -I%%LOCALBASE%%/include/QtCore\
- -I%%LOCALBASE%%/include/QtGui\
+ -I%%QT_INCDIR%%/QtCore\
+ -I%%QT_INCDIR%%/QtGui\
+ -I%%QT_INCDIR%%\
-I. -I%%LOCALBASE%%/include
CFLAGS = -pipe -fPIC -O2 -fno-strict-aliasing -Wall -W
CXXFLAGS = -pipe -fPIC -O2 -fno-strict-aliasing -Wall -W
LFLAGS = -shared -pthread -Wl,-rpath,%%LOCALBASE%%/lib
-LIBS = -L%%LOCALBASE%%/lib -lqscintilla2 -lQtCore -lz -lm -pthread\
+LIBS = -L%%QT_LIBDIR%% -L%%LOCALBASE%%/lib -lqscintilla2 -lQtCore -lz -lm -pthread\
-lgthread-2.0 -lglib-2.0 -liconv -lQtGui -lXt -lpng -lSM -lICE\
-lXi -lXrender -lXrandr -lXfixes -lXcursor -lXinerama -lfreetype\
-lfontconfig -lXext -lX11