aboutsummaryrefslogtreecommitdiff
path: root/devel/py-qt4-scripttools
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-08-04 19:18:49 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-08-04 19:18:49 +0000
commitf037f3f08c20862f3f0de36ca6e6309ba5f5feca (patch)
treecf92630ee7d19069a213e6cbffcc9a7c08090fb2 /devel/py-qt4-scripttools
parentdfffa548f03f2cd770e60b6375b3e95c7ccae695 (diff)
downloadports-f037f3f08c20862f3f0de36ca6e6309ba5f5feca.tar.gz
ports-f037f3f08c20862f3f0de36ca6e6309ba5f5feca.zip
Notes
Diffstat (limited to 'devel/py-qt4-scripttools')
-rw-r--r--devel/py-qt4-scripttools/Makefile80
-rw-r--r--devel/py-qt4-scripttools/distinfo3
-rw-r--r--devel/py-qt4-scripttools/pkg-descr4
-rw-r--r--devel/py-qt4-scripttools/pkg-plist6
4 files changed, 93 insertions, 0 deletions
diff --git a/devel/py-qt4-scripttools/Makefile b/devel/py-qt4-scripttools/Makefile
new file mode 100644
index 000000000000..c57d75e70f98
--- /dev/null
+++ b/devel/py-qt4-scripttools/Makefile
@@ -0,0 +1,80 @@
+# New ports collection makefile for: py-qt4-scripttools
+# Date created: 2009-07-12
+# Whom: Max Brazhnikov <makc@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= scripttools
+PORTVERSION= ${PYQT4_VERSION}
+PORTEPOCH= 1
+CATEGORIES= devel python
+MASTER_SITES= ${MASTER_SITES_PYQT4}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}qt4-
+DISTNAME= ${PYQT4_DISTNAME}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Python bindings for the Qt4 toolkit, QtScriptTools module
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sip>=${SIP_VERSION}:${PORTSDIR}/devel/py-sip
+RUN_DEPENDS= ${PKGNAMEPREFIX}core>=${PYQT4_VERSION}:${PORTSDIR}/devel/py-qt4-core
+
+HAS_CONFIGURE= yes
+USE_PYTHON= 2.5+
+USE_QT_VER= 4
+QT_COMPONENTS= scripttools qmake_build
+
+OPTIONS= API "Install QtScript API for QScintilla2" on \
+ DEBUG "Enable debugging in generated code" off \
+ SIPFILES "Install the QtScript SIP files" on \
+ TRACING "Enable tracing in generated code" off
+
+PATCHDIR= ${PORTSDIR}/devel/py-qt4-core/files
+OPTIONSFILE= ${PORT_DBDIR}/py-qt4-${PORTNAME}/options
+SIPDIR= ${PREFIX}/share/py-sip
+QSCIDIR= ${PREFIX}/share/qt4/qsci
+CONFIGURE_ENV+= PYQT4_COMPONENT="${PORTNAME}"
+ARGS= -b ${PREFIX}/bin\
+ -d ${PYTHONPREFIX_SITELIBDIR}\
+ -p ${PREFIX}/${QT_PLUGINDIR_REL}\
+ -q ${QMAKE}\
+ --confirm-license\
+ --enable QtScriptTools
+
+.include "../py-sip/files/bsd.pyqt.mk"
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_DEBUG)
+ARGS+= --debug
+.endif
+.if defined(WITHOUT_API)
+ARGS+= --no-qsci-api
+PLIST_SUB+= API="@comment "
+.else
+LIB_DEPENDS+= qscintilla2.5:${PORTSDIR}/devel/qscintilla2
+ARGS+= --qsci-api --qsci-api-destdir=${QSCIDIR}
+PLIST_SUB+= API=""
+.endif
+.if defined(WITHOUT_SIPFILES)
+ARGS+= --no-sip-files
+PLIST_SUB+= SIP="@comment "
+.else
+ARGS+= --sipdir ${SIPDIR}
+PLIST_SUB+= SIP=""
+.endif
+.if defined(WITH_TRACING)
+ARGS+= --trace
+.endif
+
+do-configure:
+ cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV}\
+ ${PYTHON_CMD} configure.py ${ARGS}
+
+post-configure:
+ ${REINPLACE_CMD} -e 's|mkspecs/freebsd-g++|share/qt4/mkspecs/freebsd-g++|'\
+ -e 's|CC = cc|CC = ${CC}|'\
+ -e 's|CXX = c++|CXX = ${CXX}|'\
+ -e 's|LINK = c++|LINK = ${CXX}|'\
+ ${WRKSRC}/QtScriptTools/Makefile
+
+.include <bsd.port.post.mk>
diff --git a/devel/py-qt4-scripttools/distinfo b/devel/py-qt4-scripttools/distinfo
new file mode 100644
index 000000000000..a312fab4a870
--- /dev/null
+++ b/devel/py-qt4-scripttools/distinfo
@@ -0,0 +1,3 @@
+MD5 (PyQt-x11-gpl-4.5.4.tar.gz) = b721266d14c450dd7045025e042819ec
+SHA256 (PyQt-x11-gpl-4.5.4.tar.gz) = b3d06c7bda701055769add93b48103ee35c6fc9a4b00c67599cb426f9efda5a8
+SIZE (PyQt-x11-gpl-4.5.4.tar.gz) = 6970552
diff --git a/devel/py-qt4-scripttools/pkg-descr b/devel/py-qt4-scripttools/pkg-descr
new file mode 100644
index 000000000000..7746c223c3df
--- /dev/null
+++ b/devel/py-qt4-scripttools/pkg-descr
@@ -0,0 +1,4 @@
+PyQt4 is a set of Python bindings for Trolltech's Qt4 application framework.
+This package provides the QtScript module.
+
+WWW: http://www.riverbankcomputing.co.uk/pyqt/
diff --git a/devel/py-qt4-scripttools/pkg-plist b/devel/py-qt4-scripttools/pkg-plist
new file mode 100644
index 000000000000..3f16512cfe4f
--- /dev/null
+++ b/devel/py-qt4-scripttools/pkg-plist
@@ -0,0 +1,6 @@
+%%PYTHON_SITELIBDIR%%/PyQt4/QtScriptTools.so
+%%SIP%%share/py-sip/QtScriptTools/QtScriptToolsmod.sip
+%%SIP%%share/py-sip/QtScriptTools/qscriptenginedebugger.sip
+%%API%%share/qt4/qsci/api/python/QtScriptTools.api
+%%SIP%%@dirrm share/py-sip/QtScriptTools
+@dirrmtry %%PYTHON_SITELIBDIR%%/PyQt4