aboutsummaryrefslogtreecommitdiff
path: root/devel/py-qt5-dbus
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-11-22 20:18:37 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-11-22 20:18:37 +0000
commitcc8a667aa283dbd1c377aa55dd4b47568cebc6b9 (patch)
tree61cb3664013fb792e76869e17b47783aadc54052 /devel/py-qt5-dbus
parent9ea8c5a60afa67ef2f40c0e73594522c3aec51a6 (diff)
downloadports-cc8a667aa283dbd1c377aa55dd4b47568cebc6b9.tar.gz
ports-cc8a667aa283dbd1c377aa55dd4b47568cebc6b9.zip
Notes
Diffstat (limited to 'devel/py-qt5-dbus')
-rw-r--r--devel/py-qt5-dbus/Makefile5
-rw-r--r--devel/py-qt5-dbus/pkg-plist2
2 files changed, 3 insertions, 4 deletions
diff --git a/devel/py-qt5-dbus/Makefile b/devel/py-qt5-dbus/Makefile
index f1c18ab07bc2..7afc27694e49 100644
--- a/devel/py-qt5-dbus/Makefile
+++ b/devel/py-qt5-dbus/Makefile
@@ -1,7 +1,6 @@
# $FreeBSD$
PORTNAME= dbus
-PORTREVISION= 5
CATEGORIES= devel python
MAINTAINER= kde@FreeBSD.org
@@ -12,7 +11,7 @@ PYQT_DIST= yes
USES= python pyqt:5 qt:5
USE_PYQT= sip_build core_run
-USE_PYTHON= flavors
+USE_PYTHON= concurrent flavors py3kplist
USE_QT= core dbus qmake_build
OPTIONS_DEFINE= API DEBUG
@@ -20,7 +19,7 @@ OPTIONS_DEFAULT=API
OPTIONS_SUB= yes
API_DESC= Install QtDBus API for QScintilla2
-API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${QSCIDIR}
+API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${PYQT_APIDIR}
API_CONFIGURE_OFF= --no-qsci-api
API_LIB_DEPENDS= libqscintilla2_qt5.so:devel/qscintilla2-qt5
DEBUG_CONFIGURE_ON= --debug --trace
diff --git a/devel/py-qt5-dbus/pkg-plist b/devel/py-qt5-dbus/pkg-plist
index aff2cb6bfb44..2effa002dbcf 100644
--- a/devel/py-qt5-dbus/pkg-plist
+++ b/devel/py-qt5-dbus/pkg-plist
@@ -15,4 +15,4 @@
%%PYQT_SIPDIR%%/QtDBus/qdbusunixfiledescriptor.sip
%%PYQT_SIPDIR%%/QtDBus/qpydbuspendingreply.sip
%%PYQT_SIPDIR%%/QtDBus/qpydbusreply.sip
-%%API%%share/qt5/qsci/api/python/QtDBus.api
+%%API%%%%PYQT_APIDIR%%/api/python/QtDBus.api