aboutsummaryrefslogtreecommitdiff
path: root/devel/py-rbtree
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2007-04-05 02:17:16 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2007-04-05 02:17:16 +0000
commit96a3596ae518e6f5911604df0814e64021659c1f (patch)
treec5815484c82e13ff0935bba249e3f225c2385a43 /devel/py-rbtree
parente53f7075b23e166d59e6c7a6b9fbe52e00390406 (diff)
downloadports-96a3596ae518e6f5911604df0814e64021659c1f.tar.gz
ports-96a3596ae518e6f5911604df0814e64021659c1f.zip
Notes
Diffstat (limited to 'devel/py-rbtree')
-rw-r--r--devel/py-rbtree/Makefile35
-rw-r--r--devel/py-rbtree/distinfo6
-rw-r--r--devel/py-rbtree/files/patch-setup.py23
-rw-r--r--devel/py-rbtree/files/patch-src__rbtree.pyx20
4 files changed, 51 insertions, 33 deletions
diff --git a/devel/py-rbtree/Makefile b/devel/py-rbtree/Makefile
index 004707da90a1..18f141630732 100644
--- a/devel/py-rbtree/Makefile
+++ b/devel/py-rbtree/Makefile
@@ -6,25 +6,42 @@
#
PORTNAME= rbtree
-PORTVERSION= 0.7
+PORTVERSION= 0.8.0
CATEGORIES= devel python
MASTER_SITES= http://cheeseshop.python.org/packages/source/r/rbtree/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DIST_SUBDIR= python
-MAINTAINER= mnag@FreeBSD.org
+MAINTAINER= python@FreeBSD.org
COMMENT= A fast tree with ordered data and expanded iterator support
-BUILD_DEPENDS= pyrexc:${PORTSDIR}/devel/pyrex
+BUILD_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools \
+ pyrexc:${PORTSDIR}/devel/pyrex
+RUN_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools
-DIST_SUBDIR= python
USE_PYTHON= yes
USE_PYDISTUTILS= yes
-DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+PYDISTUTILS_BUILD_TARGET= bdist_egg
+PYDISTUTILS_INSTALL_TARGET= easy_install
+PYDISTUTILS_INSTALLARGS= -O 1 -N -S ${PYTHON_SITELIBDIR} ${WRKSRC}/dist/${PYRBTREE_EGG}
+
+PYRBTREE_EGG= ${PORTNAME}-${PORTVERSION}-py${PYTHON_VER}-${OSINFOS}.egg
+OSINFOS= ${OPSYS:L}-${OSRELEASE}-${ARCH}
-PLIST_FILES= %%PYTHON_SITELIBDIR%%/rbtree.so
+PLIST_SUB+= PYRBTREE_EGG=${PYRBTREE_EGG}
+.if !defined(NOPORTDOCS)
+DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
PORTDOCS= *
+.endif
+
+pre-build:
+ @cd ${WRKSRC} && ${PYTHON_CMD} setup.py setopt -c build -o build-platlib -s lib.${OSINFOS}
+ @cd ${WRKSRC} && ${PYTHON_CMD} setup.py setopt -c build -o build-temp -s temp.${OSINFOS}-${PYTHON_VER}
+ @cd ${WRKSRC} && ${PYTHON_CMD} setup.py setopt -c bdist_egg -o plat-name -s ${OSINFOS}
+ @cd ${WRKSRC} && ${PYTHON_CMD} setup.py setopt -c bdist -o plat-name -s ${OSINFOS}
+
post-install:
.if !defined(NOPORTDOCS)
@@ -35,4 +52,8 @@ post-install:
test: build
(cd ${WRKSRC} && ${PYTHON_CMD} test_rbtree.py)
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+OSRELEASE!= uname -r
+
+.include <bsd.port.post.mk>
diff --git a/devel/py-rbtree/distinfo b/devel/py-rbtree/distinfo
index 3459087d2e06..d8b0d88d5f26 100644
--- a/devel/py-rbtree/distinfo
+++ b/devel/py-rbtree/distinfo
@@ -1,3 +1,3 @@
-MD5 (python/rbtree-0.7.tar.gz) = 86d93a8866c65a1774bd6b84389d8909
-SHA256 (python/rbtree-0.7.tar.gz) = 46498f40cf27fe21a8c74c698fe27cfc115664b99118781d604cde9d8681c042
-SIZE (python/rbtree-0.7.tar.gz) = 27817
+MD5 (python/rbtree-0.8.0.tar.gz) = 6975331773f9d3e8bd5a24e547077347
+SHA256 (python/rbtree-0.8.0.tar.gz) = ba79b993a428c7bde555faa1c189b60607f9860d1e29a54d3e91b0104f4b86b9
+SIZE (python/rbtree-0.8.0.tar.gz) = 11869
diff --git a/devel/py-rbtree/files/patch-setup.py b/devel/py-rbtree/files/patch-setup.py
deleted file mode 100644
index 995857d3205a..000000000000
--- a/devel/py-rbtree/files/patch-setup.py
+++ /dev/null
@@ -1,23 +0,0 @@
-#
-# Do not use py-setuptools
-#
---- setup.py.orig Thu Jun 15 02:43:12 2006
-+++ setup.py Mon Jul 10 12:12:43 2006
-@@ -1,8 +1,6 @@
--import ez_setup
--ez_setup.use_setuptools()
--
--from setuptools import setup, find_packages
--from setuptools.extension import Extension
-+from distutils.core import setup
-+from distutils.extension import Extension
-+from Pyrex.Distutils import build_ext
-
- classifiers = [
- "Development Status :: 4 - Beta",
-@@ -31,4 +29,5 @@
- include_dirs=['src',],
- ),
- ],
-+ cmdclass = {'build_ext': build_ext}
- )
diff --git a/devel/py-rbtree/files/patch-src__rbtree.pyx b/devel/py-rbtree/files/patch-src__rbtree.pyx
new file mode 100644
index 000000000000..9e00ea09f72f
--- /dev/null
+++ b/devel/py-rbtree/files/patch-src__rbtree.pyx
@@ -0,0 +1,20 @@
+--- ./src/rbtree.pyx.orig Sat Feb 10 06:49:24 2007
++++ ./src/rbtree.pyx Mon Mar 26 10:19:44 2007
+@@ -83,7 +83,7 @@
+ cdef int _done
+ cdef iter_direction _direction
+
+- def __new__(self, RBTree tree, int itype):
++ def __new__(self, RBTree tree, itype):
+ self._T = tree
+ self._iter = NULL
+ self._type = itype
+@@ -93,7 +93,7 @@
+ property direction:
+ def __get__(self):
+ return self._direction
+- def __set__(self, int value):
++ def __set__(self, value):
+ self._direction = value
+
+ cdef _position(self, iter_direction direction):