aboutsummaryrefslogtreecommitdiff
path: root/devel/py-simplejson
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2006-04-26 03:24:41 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2006-04-26 03:24:41 +0000
commit8dcf764e240baf0f1a9b6b794b6c7def2e5b1b29 (patch)
tree81d826045d378b1820668d09b3618f39eaff4b84 /devel/py-simplejson
parent2eb2494df459a21f645daa5b900bfa8c74278bc8 (diff)
downloadports-8dcf764e240baf0f1a9b6b794b6c7def2e5b1b29.tar.gz
ports-8dcf764e240baf0f1a9b6b794b6c7def2e5b1b29.zip
Notes
Diffstat (limited to 'devel/py-simplejson')
-rw-r--r--devel/py-simplejson/Makefile23
-rw-r--r--devel/py-simplejson/distinfo3
-rw-r--r--devel/py-simplejson/pkg-descr15
-rw-r--r--devel/py-simplejson/pkg-plist1
4 files changed, 42 insertions, 0 deletions
diff --git a/devel/py-simplejson/Makefile b/devel/py-simplejson/Makefile
new file mode 100644
index 000000000000..ea69d7a732c8
--- /dev/null
+++ b/devel/py-simplejson/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: py-simplejson
+# Date created: 25 Apr 2006
+# Whom: Alexander Botero-Lowry <alex@foxybanana.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= simplejson
+PORTVERSION= 1.3
+CATEGORIES= devel python
+MASTER_SITES= http://cheeseshop.python.org/packages/source/s/simplejson/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= alex@foxybanana.com
+COMMENT= Simplejson is a simple, fast, extensible JSON encoder/decoder
+
+BUILD_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-simplejson/distinfo b/devel/py-simplejson/distinfo
new file mode 100644
index 000000000000..1af4dcb2fd1e
--- /dev/null
+++ b/devel/py-simplejson/distinfo
@@ -0,0 +1,3 @@
+MD5 (simplejson-1.3.tar.gz) = fbe039b9b863572651a0f665acea34c9
+SHA256 (simplejson-1.3.tar.gz) = e68c59d56ba92bded0189a02e39d2483aea20cd23b6ec1b5d8fe1b4900d1cb26
+SIZE (simplejson-1.3.tar.gz) = 49181
diff --git a/devel/py-simplejson/pkg-descr b/devel/py-simplejson/pkg-descr
new file mode 100644
index 000000000000..1efb480589e7
--- /dev/null
+++ b/devel/py-simplejson/pkg-descr
@@ -0,0 +1,15 @@
+simplejson is a simple, fast, extensible JSON encoder/decoder for Python
+
+simplejson is compatible with Python 2.3 and later with no external
+dependencies. It covers the full JSON specification for both encoding and
+decoding, with unicode support. By default, encoding is done in an encoding
+neutral fashion (plain ASCII with \uXXXX escapes for unicode characters).
+
+The encoder may be subclassed to provide serialization in any kind of
+situation, without any special support by the objects to be serialized
+(somewhat like pickle).
+
+The decoder can handle incoming JSON strings of any specified encoding
+(UTF-8 by default).
+
+WWW: http://svn.red-bean.com/bob/simplejson/
diff --git a/devel/py-simplejson/pkg-plist b/devel/py-simplejson/pkg-plist
new file mode 100644
index 000000000000..0d85ab7e6f35
--- /dev/null
+++ b/devel/py-simplejson/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/simplejson-1.3-py2.4.egg