aboutsummaryrefslogtreecommitdiff
path: root/devel/py-simplejson
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-09-24 14:41:58 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-09-24 14:41:58 +0000
commit8184bf635094752e154119c35539f6f1099d0419 (patch)
treef775a26ec0b62642771e3f82b3ac513a7f592a74 /devel/py-simplejson
parent233241a7eba3337272c9b7530e2199b78856c97d (diff)
downloadports-8184bf635094752e154119c35539f6f1099d0419.tar.gz
ports-8184bf635094752e154119c35539f6f1099d0419.zip
Notes
Diffstat (limited to 'devel/py-simplejson')
-rw-r--r--devel/py-simplejson/Makefile14
-rw-r--r--devel/py-simplejson/distinfo9
-rw-r--r--devel/py-simplejson/pkg-plist17
3 files changed, 32 insertions, 8 deletions
diff --git a/devel/py-simplejson/Makefile b/devel/py-simplejson/Makefile
index 5b5a8dc6ea67..29fbd2f38a81 100644
--- a/devel/py-simplejson/Makefile
+++ b/devel/py-simplejson/Makefile
@@ -6,10 +6,14 @@
#
PORTNAME= simplejson
-PORTVERSION= 1.9.2
+PORTVERSION= 1.9.3
CATEGORIES= devel python
-MASTER_SITES= CHEESESHOP
+MASTER_SITES= CHEESESHOP:source1 \
+ http://peak.telecommunity.com/dist/:source2
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz:source1 \
+ ez_setup.py:source2
+EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}.tar.gz
MAINTAINER= python@FreeBSD.org
COMMENT= Simplejson is a simple, fast, extensible JSON encoder/decoder
@@ -18,13 +22,13 @@ USE_PYTHON= yes
USE_PYDISTUTILS= easy_install
PYEASYINSTALL_ARCHDEP= yes
-DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
-PORTDOCS= *
-
.if !defined(NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}
${CP} -R ${WRKSRC}/docs/ ${DOCSDIR}
.endif
+post-extract:
+ ${CP} ${DISTDIR}/ez_setup.py ${WRKSRC}
+
.include <bsd.port.mk>
diff --git a/devel/py-simplejson/distinfo b/devel/py-simplejson/distinfo
index f20bd20f365c..ac35014ea647 100644
--- a/devel/py-simplejson/distinfo
+++ b/devel/py-simplejson/distinfo
@@ -1,3 +1,6 @@
-MD5 (simplejson-1.9.2.tar.gz) = 9fe5d9a98da5ffc347bfee2ccf386fcb
-SHA256 (simplejson-1.9.2.tar.gz) = 64daccbd34c3bbc19a9a9f44d35d6c52a10d28559dd0f626022e9ef6c5b6c54e
-SIZE (simplejson-1.9.2.tar.gz) = 70928
+MD5 (simplejson-1.9.3.tar.gz) = 321f7ad3a347e5a11814bcfecf8b9d11
+SHA256 (simplejson-1.9.3.tar.gz) = da6e4f66cb54f399eb8825de5e3986adaab9ebd8c47ef5fddda8a47519b2ff7b
+SIZE (simplejson-1.9.3.tar.gz) = 69989
+MD5 (ez_setup.py) = 94ce3ba3f5933e3915e999c26da9563b
+SHA256 (ez_setup.py) = c11139b66d5e1e3bda2c2dd395d94ec66cfb7f85232ababd3b9bf664be4e737e
+SIZE (ez_setup.py) = 9419
diff --git a/devel/py-simplejson/pkg-plist b/devel/py-simplejson/pkg-plist
index 7767d3e76aa1..495f4ab5a550 100644
--- a/devel/py-simplejson/pkg-plist
+++ b/devel/py-simplejson/pkg-plist
@@ -1,2 +1,19 @@
@comment $FreeBSD$
%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+%%PORTDOCS%%%%DOCSDIR%%/class-simplejson.JSONDecoder.html
+%%PORTDOCS%%%%DOCSDIR%%/class-simplejson.JSONEncoder.html
+%%PORTDOCS%%%%DOCSDIR%%/class_to_source.js
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/layout.css
+%%PORTDOCS%%%%DOCSDIR%%/module-index.html
+%%PORTDOCS%%%%DOCSDIR%%/module-simplejson-index.html
+%%PORTDOCS%%%%DOCSDIR%%/module-simplejson.html
+%%PORTDOCS%%%%DOCSDIR%%/pudge.css
+%%PORTDOCS%%%%DOCSDIR%%/rst.css
+%%PORTDOCS%%%%DOCSDIR%%/simplejson/__init__.py.html
+%%PORTDOCS%%%%DOCSDIR%%/simplejson/decoder.py.html
+%%PORTDOCS%%%%DOCSDIR%%/simplejson/encoder.py.html
+%%PORTDOCS%%%%DOCSDIR%%/simplejson/jsonfilter.py.html
+%%PORTDOCS%%%%DOCSDIR%%/simplejson/scanner.py.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/simplejson
+%%PORTDOCS%%@dirrm %%DOCSDIR%%