aboutsummaryrefslogtreecommitdiff
path: root/devel/py-six/Makefile
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2014-08-25 09:44:56 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2014-08-25 09:44:56 +0000
commit82e33fe2b8c0d783c8f7122ef714eca7f1f62ce6 (patch)
tree6545bfc92859af30075c4799a98301a5a78e037f /devel/py-six/Makefile
parentfb76ea5da2894141d4b6c1e0836a98f46cfb709a (diff)
downloadports-82e33fe2b8c0d783c8f7122ef714eca7f1f62ce6.tar.gz
ports-82e33fe2b8c0d783c8f7122ef714eca7f1f62ce6.zip
Notes
Diffstat (limited to 'devel/py-six/Makefile')
-rw-r--r--devel/py-six/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/devel/py-six/Makefile b/devel/py-six/Makefile
index 4328abdd7808..81dba528b55c 100644
--- a/devel/py-six/Makefile
+++ b/devel/py-six/Makefile
@@ -3,6 +3,7 @@
PORTNAME= six
PORTVERSION= 1.7.3
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,8 +12,14 @@ MAINTAINER= python@FreeBSD.org
COMMENT= Python 2 and 3 compatibility utilities
LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:${PORTSDIR}/devel/py-pytest
USES= python
USE_PYTHON= autoplist concurrent distutils
+regression-test: build
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -v
+
.include <bsd.port.mk>