aboutsummaryrefslogtreecommitdiff
path: root/devel/py-tables/Makefile
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2009-01-21 09:05:20 +0000
committerBeech Rintoul <beech@FreeBSD.org>2009-01-21 09:05:20 +0000
commit876e3e7aa967e31d48e224334d466980c4505ebe (patch)
treed14f104dcfe7317cba59544a91a10e0fbb43813c /devel/py-tables/Makefile
parent32fd8a7e92ca7bc8f31c4fb3af59c62da46934e2 (diff)
Notes
Diffstat (limited to 'devel/py-tables/Makefile')
-rw-r--r--devel/py-tables/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/devel/py-tables/Makefile b/devel/py-tables/Makefile
index 4bf6ea9d2b91..536e113bfd4b 100644
--- a/devel/py-tables/Makefile
+++ b/devel/py-tables/Makefile
@@ -7,12 +7,13 @@
#
PORTNAME= tables
-PORTVERSION= 2.0.4
+PORTVERSION= 2.1
CATEGORIES= devel python
MASTER_SITES= http://www.pytables.org/download/stable/ \
http://www.pytables.org/download/py${PORTNAME}-${PORTVERSION}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= pytables-${PORTVERSION}
+DISTFILES= tables-${PORTVERSION}.tar.gz pytablesmanual-${PORTVERSION}.pdf
+EXTRACT_ONLY= tables-${PORTVERSION}.tar.gz
MAINTAINER= wenheping@gmail.com
COMMENT= A hierarchical database for Python
@@ -45,7 +46,17 @@ post-install:
${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
@${FIND} ${PYTHONPREFIX_SITELIBDIR}/tables -type d | ${SORT} -r | \
${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+
.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DISTDIR}/pytablesmanual-${PORTVERSION}.pdf ${DOCSDIR}
+ ${ECHO} '${DOCSDIR}/pytablesmanual-${PORTVERSION}.pdf' | ${SED} 's,^${PREFIX}/,,' \
+ >> ${TMPPLIST}
+ ${ECHO} '${DOCSDIR}' | ${SED} 's,^${PREFIX}/,@dirrm ,' \
+ >> ${TMPPLIST}
+.endif
+
+.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/*.py ${EXAMPLESDIR}
@${FIND} ${EXAMPLESDIR} ! -type d | \