aboutsummaryrefslogtreecommitdiff
path: root/devel/py-tables/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-12-19 03:41:34 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-12-19 03:41:34 +0000
commit2f1c532aaa440b2fe6f4611a37aaf9d876519af4 (patch)
tree8948bf7620cb404735394b49c2da179847cd42ac /devel/py-tables/Makefile
parent7fafa757de69325c7fbfe12833cd666b7e5448c3 (diff)
downloadports-2f1c532aaa440b2fe6f4611a37aaf9d876519af4.tar.gz
ports-2f1c532aaa440b2fe6f4611a37aaf9d876519af4.zip
Notes
Diffstat (limited to 'devel/py-tables/Makefile')
-rw-r--r--devel/py-tables/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/devel/py-tables/Makefile b/devel/py-tables/Makefile
new file mode 100644
index 000000000000..5f6476196f73
--- /dev/null
+++ b/devel/py-tables/Makefile
@@ -0,0 +1,35 @@
+# ex:ts=8
+# Ports collection makefile for: PyTables
+# Date created: Dec 19, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= tables
+PORTVERSION= 0.7.2
+CATEGORIES= devel python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= pytables
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pytables-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A hierarchical database for Python
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numarray/__init__.py:${PORTSDIR}/math/py-numarray
+LIB_DEPENDS= hdf5.0:${PORTSDIR}/graphics/hdf5 \
+ lzo.1:${PORTSDIR}/archivers/lzo \
+ ucl.0:${PORTSDIR}/archivers/ucl
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/numarray/__init__.py:${PORTSDIR}/math/py-numarray
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/*.py ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>