aboutsummaryrefslogtreecommitdiff
path: root/devel/py-tables
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2006-07-27 16:24:12 +0000
committerXin LI <delphij@FreeBSD.org>2006-07-27 16:24:12 +0000
commitc6df86859dce1a7aceaafe2a7b09e19eefe7fb9b (patch)
treea57b59bd45e168f6519583c0a359f9c447d45b4b /devel/py-tables
parent7344b58d22b3b84f17d69af7a307d6a55854b69b (diff)
downloadports-c6df86859dce1a7aceaafe2a7b09e19eefe7fb9b.tar.gz
ports-c6df86859dce1a7aceaafe2a7b09e19eefe7fb9b.zip
Notes
Diffstat (limited to 'devel/py-tables')
-rw-r--r--devel/py-tables/Makefile15
-rw-r--r--devel/py-tables/distinfo6
-rw-r--r--devel/py-tables/files/patch-setup.py12
3 files changed, 21 insertions, 12 deletions
diff --git a/devel/py-tables/Makefile b/devel/py-tables/Makefile
index 7b48429ca092..60f5814e0e91 100644
--- a/devel/py-tables/Makefile
+++ b/devel/py-tables/Makefile
@@ -7,14 +7,14 @@
#
PORTNAME= tables
-PORTVERSION= 1.1
+PORTVERSION= 1.3.2
CATEGORIES= devel python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pytables
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= pytables-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= quakelee@cn.freebsd.org
COMMENT= A hierarchical database for Python
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numarray/__init__.py:${PORTSDIR}/math/py-numarray
@@ -28,6 +28,15 @@ USE_PYDISTUTILS= yes
PLIST_FILES= bin/nctoh5 bin/ptdump bin/ptrepack
+OPTIONS= PYREX "Use code generated by Pyrex to build" off
+OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_PYREX)
+BUILD_DEPENDS+= ${PYTHON_SITELIBDIR}/Pyrex/__init__.py:${PORTSDIR}/devel/pyrex
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s,%%LOCALBASE%%,${LOCALBASE}," ${WRKSRC}/setup.py
@@ -45,4 +54,4 @@ post-install:
${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/py-tables/distinfo b/devel/py-tables/distinfo
index 34da0aa3bd82..4855e0d9f74a 100644
--- a/devel/py-tables/distinfo
+++ b/devel/py-tables/distinfo
@@ -1,3 +1,3 @@
-MD5 (pytables-1.1.tar.gz) = 62be2271cab933b9c0712887d15522f2
-SHA256 (pytables-1.1.tar.gz) = b021642e9cb69ea13d2637411005f6b9073e820b87c8914391fcb18f69155245
-SIZE (pytables-1.1.tar.gz) = 2693924
+MD5 (pytables-1.3.2.tar.gz) = ba4df36a1b0702eb0314c24c49992fec
+SHA256 (pytables-1.3.2.tar.gz) = b67e524a71c74407c2c3184a2807f847fa374f0b8990dad5fac37d9bced1a06b
+SIZE (pytables-1.3.2.tar.gz) = 3834747
diff --git a/devel/py-tables/files/patch-setup.py b/devel/py-tables/files/patch-setup.py
index d53d1b3aec63..2fd91c8c8b84 100644
--- a/devel/py-tables/files/patch-setup.py
+++ b/devel/py-tables/files/patch-setup.py
@@ -1,13 +1,13 @@
---- setup.py.orig Wed May 11 11:04:04 2005
-+++ setup.py Wed May 11 11:04:38 2005
-@@ -30,8 +30,8 @@
+--- setup.py.orig Wed Jul 26 23:43:50 2006
++++ setup.py Wed Jul 26 23:44:46 2006
+@@ -72,8 +72,8 @@
+ debug = '--debug' in sys.argv
# Global variables
- lflags_arg = []
-lib_dirs = []
-inc_dirs = []
+lib_dirs = ['%%LOCALBASE%%/lib']
+inc_dirs = ['%%LOCALBASE%%/include']
+ optional_libs = []
- # Some useful functions
- def check_lib_unix(where, libname, headername, compulsory):
+ default_header_dirs = None