aboutsummaryrefslogtreecommitdiff
path: root/devel/py-twistedRunner
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-04-15 04:50:23 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-04-15 04:50:23 +0000
commit3bb6d83b8e94bedeb0f8170ec2489de9847a6e3e (patch)
tree9d4f24a9259dd68a898e37078f74796b8f4c47bb /devel/py-twistedRunner
parent2af6f4b7b0bc30334090b093739810d977105f48 (diff)
downloadports-3bb6d83b8e94bedeb0f8170ec2489de9847a6e3e.tar.gz
ports-3bb6d83b8e94bedeb0f8170ec2489de9847a6e3e.zip
Notes
Diffstat (limited to 'devel/py-twistedRunner')
-rw-r--r--devel/py-twistedRunner/Makefile29
-rw-r--r--devel/py-twistedRunner/distinfo2
-rw-r--r--devel/py-twistedRunner/pkg-descr5
-rw-r--r--devel/py-twistedRunner/pkg-plist21
4 files changed, 57 insertions, 0 deletions
diff --git a/devel/py-twistedRunner/Makefile b/devel/py-twistedRunner/Makefile
new file mode 100644
index 000000000000..22ab1278147e
--- /dev/null
+++ b/devel/py-twistedRunner/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: py-twistedRunner
+# Date created: 14 April 2005
+# Whom: Neal Nelson <neal@nelson.name>
+#
+# $FreeBSD$
+#
+
+PORTNAME= twistedRunner
+PORTVERSION= 0.1.0
+CATEGORIES= devel net python
+MASTER_SITES= http://twistedmatrix.com/downloads/Runner/0.1/ \
+ http://tmrc.mit.edu/mirror/twisted/Runner/0.1/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= TwistedRunner-${PORTVERSION}
+
+MAINTAINER= neal@nelson.name
+COMMENT= Runner has process management, including an inetd replacement
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/twisted:${PORTSDIR}/devel/py-twistedCore
+
+WRKSRC= ${WRKDIR}/TwistedRunner-${PORTVERSION}
+
+USE_BZIP2= yes
+USE_PYTHON= 2.2+
+USE_PYDISTUTILS= yes
+
+PLIST_SUB+= S=${PYTHONPREFIX_SITELIBDIR:S;${PREFIX}/;;}
+
+.include <bsd.port.mk>
diff --git a/devel/py-twistedRunner/distinfo b/devel/py-twistedRunner/distinfo
new file mode 100644
index 000000000000..624bc6ce48fa
--- /dev/null
+++ b/devel/py-twistedRunner/distinfo
@@ -0,0 +1,2 @@
+MD5 (TwistedRunner-0.1.0.tar.bz2) = 6829d0c85c6b4398f715f7a0f5e34e4b
+SIZE (TwistedRunner-0.1.0.tar.bz2) = 8089
diff --git a/devel/py-twistedRunner/pkg-descr b/devel/py-twistedRunner/pkg-descr
new file mode 100644
index 000000000000..05601d34e67d
--- /dev/null
+++ b/devel/py-twistedRunner/pkg-descr
@@ -0,0 +1,5 @@
+Twisted Runner has process management, including an inetd replacement.
+
+Twisted Lore is available under the MIT Free Software licence.
+
+WWW: http://twistedmatrix.com/
diff --git a/devel/py-twistedRunner/pkg-plist b/devel/py-twistedRunner/pkg-plist
new file mode 100644
index 000000000000..5a9130405c5e
--- /dev/null
+++ b/devel/py-twistedRunner/pkg-plist
@@ -0,0 +1,21 @@
+%%S%%/twisted/runner/__init__.py
+%%S%%/twisted/runner/__init__.pyc
+%%S%%/twisted/runner/__init__.pyo
+%%S%%/twisted/runner/inetd.py
+%%S%%/twisted/runner/inetd.pyc
+%%S%%/twisted/runner/inetd.pyo
+%%S%%/twisted/runner/inetdconf.py
+%%S%%/twisted/runner/inetdconf.pyc
+%%S%%/twisted/runner/inetdconf.pyo
+%%S%%/twisted/runner/inetdtap.py
+%%S%%/twisted/runner/inetdtap.pyc
+%%S%%/twisted/runner/inetdtap.pyo
+%%S%%/twisted/runner/portmap.c
+%%S%%/twisted/runner/portmap.so
+%%S%%/twisted/runner/procmon.py
+%%S%%/twisted/runner/procmon.pyc
+%%S%%/twisted/runner/procmon.pyo
+%%S%%/twisted/runner/procutils.py
+%%S%%/twisted/runner/procutils.pyc
+%%S%%/twisted/runner/procutils.pyo
+@dirrm %%S%%/twisted/runner