aboutsummaryrefslogtreecommitdiff
path: root/devel/py-vcrpy/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
commit551be3c7231225ed9c26479af2b8914fb2ef0ea8 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /devel/py-vcrpy/Makefile
parent02f9c9be1699251467efc027f210049dfe14f9c5 (diff)
downloadports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.tar.gz
ports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.zip
Notes
Diffstat (limited to 'devel/py-vcrpy/Makefile')
-rw-r--r--devel/py-vcrpy/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/devel/py-vcrpy/Makefile b/devel/py-vcrpy/Makefile
index 09d4fc7d177f..c159e3f7358d 100644
--- a/devel/py-vcrpy/Makefile
+++ b/devel/py-vcrpy/Makefile
@@ -14,11 +14,11 @@ COMMENT= Automatically mock HTTP interactions to simplify and speed up testing
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml \
- ${PYTHON_PKGNAMEPREFIX}wrapt>0:devel/py-wrapt \
- ${PYTHON_PKGNAMEPREFIX}six>=1.5:devel/py-six
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest \
- ${PYTHON_PKGNAMEPREFIX}pytest-localserver>0:devel/py-pytest-localserver
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wrapt>0:devel/py-wrapt@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.5:devel/py-six@${FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-localserver>0:devel/py-pytest-localserver@${FLAVOR}
USES= python
USE_PYTHON= autoplist distutils
@@ -32,8 +32,8 @@ NO_ARCH= yes
.include <bsd.port.pre.mk>
.if ${PYTHON_REL} < 3300
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock \
- ${PYTHON_PKGNAMEPREFIX}contextlib2>0:devel/py-contextlib2
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}contextlib2>0:devel/py-contextlib2@${FLAVOR}
.endif
post-patch: