aboutsummaryrefslogtreecommitdiff
path: root/devel/py-xdg
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:54:54 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:54:54 +0000
commit29747f458a1eb2ce23b4594b09d0256dd62760b8 (patch)
tree1b71ba5d9ffdd308b6c18130f7c116f5bab5dc12 /devel/py-xdg
parent7aad84f808b93baa6a7077ce0b47573b9c4c79a0 (diff)
downloadports-29747f458a1eb2ce23b4594b09d0256dd62760b8.tar.gz
ports-29747f458a1eb2ce23b4594b09d0256dd62760b8.zip
Notes
Diffstat (limited to 'devel/py-xdg')
-rw-r--r--devel/py-xdg/Makefile5
-rw-r--r--devel/py-xdg/files/patch-xdg::BaseDirectory.py2
-rw-r--r--devel/py-xdg/files/patch-xdg::IconTheme.py2
-rw-r--r--devel/py-xdg/files/patch-xdg_Menu.py13
4 files changed, 18 insertions, 4 deletions
diff --git a/devel/py-xdg/Makefile b/devel/py-xdg/Makefile
index 335205ff8ca9..02ba1a264f72 100644
--- a/devel/py-xdg/Makefile
+++ b/devel/py-xdg/Makefile
@@ -3,11 +3,12 @@
# Whom: michael johnson <ahze@ahze.net>
#
# $FreeBSD$
-# $MCom: ports-stable/devel/py-xdg/Makefile,v 1.4 2005/08/12 00:08:44 ahze Exp $
+# $MCom: ports/devel/py-xdg/Makefile,v 1.2 2006/09/02 14:38:55 ahze Exp $
#
PORTNAME= xdg
PORTVERSION= 0.15
+PORTREVISION= 2
CATEGORIES= devel python
MASTER_SITES= http://www.freedesktop.org/~lanius/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -21,7 +22,7 @@ USE_PYDISTUTILS=yes
post-patch:
@${REINPLACE_CMD} -e \
- 's|/etc|${X11BASE}/etc|g ; \
+ 's|/etc|${LOCALBASE}/etc|g ; \
s|%%X11BASE%%|${X11BASE}|g ; \
s|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/xdg/BaseDirectory.py \
diff --git a/devel/py-xdg/files/patch-xdg::BaseDirectory.py b/devel/py-xdg/files/patch-xdg::BaseDirectory.py
index 52e303d8124c..47bd3f33a7ab 100644
--- a/devel/py-xdg/files/patch-xdg::BaseDirectory.py
+++ b/devel/py-xdg/files/patch-xdg::BaseDirectory.py
@@ -5,7 +5,7 @@
xdg_data_dirs = [xdg_data_home] + \
- os.environ.get('XDG_DATA_DIRS', '/usr/local/share:/usr/share').split(':')
-+ os.environ.get('XDG_DATA_DIRS', '%%X11BASE%%/share/gnome:%%X11BASE%%/share:%%LOCALBASE%%/share:/usr/share').split(':')
++ os.environ.get('XDG_DATA_DIRS', '%%LOCALBASE%%/share/gnome:%%LOCALBASE%%/share:/usr/share').split(':')
xdg_config_home = os.environ.get('XDG_CONFIG_HOME',
os.path.join(_home, '.config'))
diff --git a/devel/py-xdg/files/patch-xdg::IconTheme.py b/devel/py-xdg/files/patch-xdg::IconTheme.py
index c368e385f246..cc5714b82a78 100644
--- a/devel/py-xdg/files/patch-xdg::IconTheme.py
+++ b/devel/py-xdg/files/patch-xdg::IconTheme.py
@@ -7,7 +7,7 @@
-icondirs.append("/usr/share/pixmaps")
+icondirs.append("%%X11BASE%%/share/pixmaps")
+icondirs.append("%%LOCALBASE%%/share/pixmaps")
-+icondirs.append("%%X11BASE%%/share/gnome/pixmaps")
++icondirs.append("%%LOCALBASE%%/share/gnome/pixmaps")
+icondirs.append("%%X11BASE%%/share/icons")
+icondirs.append("%%LOCALBASE%%/share/icons")
icondirs.append(os.path.expanduser("~/.icons"))
diff --git a/devel/py-xdg/files/patch-xdg_Menu.py b/devel/py-xdg/files/patch-xdg_Menu.py
new file mode 100644
index 000000000000..186fda59171f
--- /dev/null
+++ b/devel/py-xdg/files/patch-xdg_Menu.py
@@ -0,0 +1,13 @@
+--- xdg/Menu.py.orig Thu Aug 11 07:37:48 2005
++++ xdg/Menu.py Sat Sep 2 05:10:19 2006
+@@ -494,6 +494,10 @@
+ if not filename:
+ filename = __getFileName("applications.menu")
+
++ # use gnome if no filename given
++ if not filename:
++ filename = __getFileName("gnome-applications.menu")
++
+ if not filename:
+ raise ParsingError('File not found', "/etc/xdg/menus/applications.menu")
+