aboutsummaryrefslogtreecommitdiff
path: root/devel/pygobject3-common/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /devel/pygobject3-common/Makefile
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
downloadports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.tar.gz
ports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.zip
Notes
Diffstat (limited to 'devel/pygobject3-common/Makefile')
-rw-r--r--devel/pygobject3-common/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/devel/pygobject3-common/Makefile b/devel/pygobject3-common/Makefile
index bbbb800bed5a..9a16d8016f7e 100644
--- a/devel/pygobject3-common/Makefile
+++ b/devel/pygobject3-common/Makefile
@@ -1,9 +1,9 @@
# Created by: Gustau Perez i Querol <gustau.perez@gmail.com>
# $FreeBSD$
-# $MCom: ports/trunk/devel/pygobject3-common/Makefile 19685 2014-05-25 13:11:28Z kwm $
+# $MCom: ports/trunk/devel/pygobject3-common/Makefile 19953 2014-10-15 08:51:31Z gusi $
PORTNAME= gobject
-PORTVERSION= 3.8.1
+PORTVERSION= 3.14.0
PORTREVISION?= 0
CATEGORIES= devel python
MASTER_SITES= GNOME
@@ -23,23 +23,24 @@ SLAVE_PORT?= no
USES= gmake libtool pathfix pkgconfig tar:xz
GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
# this port doesn't work with py-gobject < 2.28.6_2, clungle below
CONFLICTS= py*-gtk-0* py*-gobject-2.*.[0-6] py*-gobject-2.*.[7-9] \
py*-gobject-2.*.6_1
PLIST_SUB= ARCH=${ARCH} UNAME_R=${UNAME_R} VERSION=${PORTVERSION} \
- OPSYS=${OPSYS:tl} PYTHON_VER=${PYTHON_VER}
+ OPSYS=${OPSYS:tl}
.if ${SLAVE_PORT} == no
BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/pycairo.pc:${PORTSDIR}/graphics/py-cairo
-USES+= python:2,build
+USES+= python:build
USE_GNOME= glib20:build introspection:build
NO_BUILD= yes
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/include/pygobject-3.0/
- ${INSTALL_DATA} ${WRKSRC}/gi/_gobject/pygobject.h \
+ ${INSTALL_DATA} ${WRKSRC}/gi/pygobject.h \
${STAGEDIR}${PREFIX}/include/pygobject-3.0/pygobject.h
${INSTALL_DATA} ${WRKSRC}/pygobject-3.0.pc \
${STAGEDIR}${PREFIX}/libdata/pkgconfig/pygobject-3.0.pc
@@ -62,7 +63,6 @@ PLIST_SUB+= PYTVER=${PYTHON_VER:S/.//}
.endif
post-install:
- @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/gi/*.so
@${RM} -rf ${STAGEDIR}${PREFIX}/include/pygobject-3.0 \
${STAGEDIR}${PREFIX}/libdata/pkgconfig/pygobject-3.0.pc
.endif