aboutsummaryrefslogtreecommitdiff
path: root/devel/pysvn
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-27 09:29:44 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-27 09:29:44 +0000
commitc0eadcb971028a0649420223d852144da0539cdd (patch)
treeb8e5424c63c2841a58c0fae3b0678caf3d7f6266 /devel/pysvn
parent50ba73ea587910685a3ad2b210b166438d649893 (diff)
The pysvn module is a python interface to the Subversion version control
system. This API exposes client interfaces for managing a working copy, querying a repository, and synchronizing the two. This API cannot create new repositories; it can only interact with existing repositories. If you need to create a repository, use the svnadmin command from Subversion. Using the API, you can check out a working copy, add, edit, and remove working files, and check in, compare, or discard your changes. Repository properties such as keyword expansion, end of line characters, and ignore lists can also be examined and manipulated. WWW: http://pysvn.tigris.org/ PR: ports/122986 Submitted by: Attila Nagy <bra@fsn.hu>
Notes
Notes: svn path=/head/; revision=212094
Diffstat (limited to 'devel/pysvn')
-rw-r--r--devel/pysvn/Makefile47
-rw-r--r--devel/pysvn/distinfo3
-rw-r--r--devel/pysvn/pkg-descr14
3 files changed, 64 insertions, 0 deletions
diff --git a/devel/pysvn/Makefile b/devel/pysvn/Makefile
new file mode 100644
index 000000000000..4bff6ed152d2
--- /dev/null
+++ b/devel/pysvn/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: pysvn
+# Date created: 22 April 2008
+# Whom: bra@fsn.hu
+#
+# $FreeBSD$
+#
+
+PORTNAME= pysvn
+PORTVERSION= 1.5.3
+CATEGORIES= devel
+MASTER_SITES= http://pysvn.barrys-emacs.org/source_kits/
+
+MAINTAINER= bra@fsn.hu
+COMMENT= Python binding for Subversion
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/CXX/__init__.py:${PORTSDIR}/devel/py-cxx
+LIB_DEPENDS= svn_client-1:${PORTSDIR}/devel/subversion \
+ apr-1.2:${PORTSDIR}/devel/apr \
+ neon.26:${PORTSDIR}/www/neon
+
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS=yes
+PYDISTUTILS_NOEGGINFO=yes
+PYDISTUTILS_PKGNAME=${PORTNAME}
+PYDISTUTILS_CONFIGURE_TARGET=configure
+PYDISTUTILS_CONFIGUREARGS=--pycxx-dir=${PYTHON_INCLUDEDIR} \
+ --pycxx-src-dir=${LOCALBASE}/share/${PYTHON_VERSION}/CXX \
+ --apr-inc-dir=${LOCALBASE}/include/apr-1
+
+PLIST_SUB= PYTHONVER=${PYTHON_VERSION:S/./_/:S/python//}
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/${PORTNAME}/__init__.py \
+ %%PYTHON_SITELIBDIR%%/${PORTNAME}/_pysvn_%%PYTHONVER%%.so
+PLIST_DIRS= %%PYTHON_SITELIBDIR%%/${PORTNAME}
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/Source
+
+do-build:
+ cd ${WRKSRC} && ${MAKE}
+
+pre-install:
+ ${MKDIR} ${PYTHON_SITELIBDIR}
+ ${MKDIR} ${PYTHON_SITELIBDIR}/${PORTNAME}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}/* ${PYTHON_SITELIBDIR}/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/devel/pysvn/distinfo b/devel/pysvn/distinfo
new file mode 100644
index 000000000000..f4a9b9d20d2d
--- /dev/null
+++ b/devel/pysvn/distinfo
@@ -0,0 +1,3 @@
+MD5 (pysvn-1.5.3.tar.gz) = 68ee1b4cbeb4126c12896793d78a07fb
+SHA256 (pysvn-1.5.3.tar.gz) = ec068cbe3a0f6ee63192102c91d3f4829108587a4e4c6513c3d7af90a75f8566
+SIZE (pysvn-1.5.3.tar.gz) = 473567
diff --git a/devel/pysvn/pkg-descr b/devel/pysvn/pkg-descr
new file mode 100644
index 000000000000..0f74497b6373
--- /dev/null
+++ b/devel/pysvn/pkg-descr
@@ -0,0 +1,14 @@
+The pysvn module is a python interface to the Subversion version control
+system. This API exposes client interfaces for managing a working copy,
+querying a repository, and synchronizing the two.
+
+This API cannot create new repositories; it can only interact with existing
+repositories. If you need to create a repository, use the svnadmin command
+from Subversion.
+
+Using the API, you can check out a working copy, add, edit, and remove working
+files, and check in, compare, or discard your changes. Repository properties
+such as keyword expansion, end of line characters, and ignore lists can also
+be examined and manipulated.
+
+WWW: http://pysvn.tigris.org/