aboutsummaryrefslogtreecommitdiff
path: root/devel/qgit
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2009-04-25 22:10:01 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2009-04-25 22:10:01 +0000
commit8f1b3ad7fb1143324ddbb434de0c0bc1695dde1e (patch)
tree79146dc73794414fb82de8199d07595b121e9a93 /devel/qgit
parent8ab5ae898d8454cd3f76ccfacbf951826e28e0a7 (diff)
downloadports-8f1b3ad7fb1143324ddbb434de0c0bc1695dde1e.tar.gz
ports-8f1b3ad7fb1143324ddbb434de0c0bc1695dde1e.zip
Notes
Diffstat (limited to 'devel/qgit')
-rw-r--r--devel/qgit/Makefile34
-rw-r--r--devel/qgit/distinfo3
-rw-r--r--devel/qgit/pkg-descr17
3 files changed, 54 insertions, 0 deletions
diff --git a/devel/qgit/Makefile b/devel/qgit/Makefile
new file mode 100644
index 000000000000..b133ab7dac04
--- /dev/null
+++ b/devel/qgit/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: qgit
+# Date created: 2009-04-19
+# Whom: Ion-Mihai "IOnut" Tetcu <itetcu@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= qgit
+PORTVERSION= 2.2
+CATEGORIES= devel
+MASTER_SITES= SF
+PKGNAMESUFFIX= -qt4
+
+MAINTAINER= itetcu@FreeBSD.org
+COMMENT= A graphical interface to git repositories
+
+USE_BZIP2= yes
+USE_QT_VER= 4
+QT_COMPONENTS= corelib gui moc qmake rcc uic
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME}
+
+post-patch:
+ @${REINPLACE_CMD} 's,target.path = ~/bin,target.path = ${PREFIX}/bin,' \
+ ${WRKSRC}/src/src.pro
+
+do-configure:
+ @cd ${WRKSRC} && ${QMAKE} ${PORTNAME}.pro
+
+#do-install:
+# ${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/devel/qgit/distinfo b/devel/qgit/distinfo
new file mode 100644
index 000000000000..03017ed8960d
--- /dev/null
+++ b/devel/qgit/distinfo
@@ -0,0 +1,3 @@
+MD5 (qgit-2.2.tar.bz2) = f863efa000aa1549f803c6ad743decd6
+SHA256 (qgit-2.2.tar.bz2) = 82adcc59b2a9d3a3e54eef9e6a76ac6583e459b6f5c97050d26b0593d11c3d32
+SIZE (qgit-2.2.tar.bz2) = 159928
diff --git a/devel/qgit/pkg-descr b/devel/qgit/pkg-descr
new file mode 100644
index 000000000000..b7fdb6c30da5
--- /dev/null
+++ b/devel/qgit/pkg-descr
@@ -0,0 +1,17 @@
+QGit is a git GUI viewer built on Qt/C++.
+With qgit you will be able to browse revisions history, view patch content and
+changed files, graphically following different development branches.
+
+Features :
+- View revisions, diffs, files history, files annotation, archive tree.
+- Commit changes visually cherry picking modified files.
+- Apply or format patch series from selected commits, drag and drop commits
+between two instances of qgit.
+- Associate commands sequences, scripts and anything else executable to a
+custom action. Actions can be run from menu and corresponding output is grabbed
+by a terminal window. qgit implements a GUI for the most common StGIT commands
+like push/pop and apply/format patches. You can also create new patches or
+refresh current top one using the same semantics of git commit,
+i.e. cherry picking single modified files.
+
+WWW: https://sourceforge.net/projects/qgit