aboutsummaryrefslogtreecommitdiff
path: root/devel/qmake/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-05-13 04:09:45 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-05-13 04:09:45 +0000
commit75dafdac7af36889bb86071b4aaf6de1d4c7557c (patch)
treeda10215bbe82e670198b010d56be0ceab6e6c006 /devel/qmake/Makefile
parent4537fee41a34e58911c0f017668cc1cc36908c7e (diff)
downloadports-75dafdac7af36889bb86071b4aaf6de1d4c7557c.tar.gz
ports-75dafdac7af36889bb86071b4aaf6de1d4c7557c.zip
Notes
Diffstat (limited to 'devel/qmake/Makefile')
-rw-r--r--devel/qmake/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/devel/qmake/Makefile b/devel/qmake/Makefile
index fca85c13fca6..ac17af8f473c 100644
--- a/devel/qmake/Makefile
+++ b/devel/qmake/Makefile
@@ -42,6 +42,12 @@ post-install:
${CP} -Rp '${WRKSRC:H}/doc/html' '${DOCSDIR}'
.endif
+.include <bsd.port.pre.mk>
+
+.if ${ARCH}=="alpha"
+CXXFLAGS+= -mieee
+.endif
+
post-patch:
@${RM} -fr ${WRKSRC}/examples ${WRKSRC}/tutorial
@${REINPLACE_CMD} -e 's,-O2,${CXXFLAGS},' \
@@ -63,4 +69,4 @@ do-configure:
${LN} ${WRKSRC}/qconfig.h ${WRKSRC}/qmodules.h
${LN} -s . ${WRKDIR}/${DISTNAME}/src/tools/private
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>