aboutsummaryrefslogtreecommitdiff
path: root/devel/qsa
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-09-02 16:16:58 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-09-02 16:16:58 +0000
commita7323a548fafc1f19a67fdd42870665481c0217c (patch)
treeac9ca78740e3758ec8110c33d53e9df40a9611a7 /devel/qsa
parent2cdc9fb6dce638a69ee731eacf5c2f4d3935ba5e (diff)
downloadports-a7323a548fafc1f19a67fdd42870665481c0217c.tar.gz
ports-a7323a548fafc1f19a67fdd42870665481c0217c.zip
Notes
Diffstat (limited to 'devel/qsa')
-rw-r--r--devel/qsa/Makefile73
-rw-r--r--devel/qsa/distinfo2
-rw-r--r--devel/qsa/files/extrapatch-src_engine_qsoperations.cpp16
-rw-r--r--devel/qsa/pkg-descr5
-rw-r--r--devel/qsa/pkg-message10
-rw-r--r--devel/qsa/pkg-plist224
6 files changed, 330 insertions, 0 deletions
diff --git a/devel/qsa/Makefile b/devel/qsa/Makefile
new file mode 100644
index 000000000000..f5c372ca8ffa
--- /dev/null
+++ b/devel/qsa/Makefile
@@ -0,0 +1,73 @@
+# New ports collection makefile for: qsa
+# Date created: Thu 02 Sep 2004 18:00:00 CEST
+# Whom: Michael Nottebrock <lofi@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qsa
+PORTVERSION= 1.1.1
+CATEGORIES= devel lang
+MASTER_SITES= ftp://ftp.iasi.roedu.net/mirrors/ftp.trolltech.com/qsa/source/ \
+ ftp://ftp.trolltech.com/qsa/source/
+DISTNAME= ${PORTNAME}-x11-free-${PORTVERSION}
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@freebsd.org
+COMMENT= Cross-platform scripting toolkit for Qt applications
+
+BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
+
+USE_QT_VER= 3
+QT_NONSTANDARD= yes
+HAS_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+NO_FILTER_SHLIBS=yes
+
+CONFIGURE_ARGS=-prefix ${PREFIX}
+CONFIGURE_ENV?= QTDIR=${X11BASE} QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++ PATH=${WRKSRC}/bin:$$PATH
+MAKE_ENV?= QTDIR=${X11BASE} \
+ QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++ \
+ LD_LIBRARY_PATH=${WRKSRC}/qsa \
+ PATH=${WRKSRC}/bin:$$PATH
+ALL_TARGET= sub-src
+USE_REINPLACE= yes
+
+PKGMESSAGE= ${WRKDIR}/message
+
+OPTIONS= IDE "Enable the QSA Workbench (embedded scripting IDE)" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_IDE)
+CONFIGURE_ARGS+=-no-ide
+.endif
+
+.if ${OSVERSION} < 502124
+EXTRA_PATCHES= ${PATCHDIR}/extrapatch-src_engine_qsoperations.cpp
+.endif
+
+pre-configure:
+# Adjust installation directories for the documentation and the qmake feature extension
+ @${REINPLACE_CMD} -e 's|$$$$QSA_INSTALL_PREFIX/doc/html|$$$$QSA_INSTALL_PREFIX/share/doc/qsa/html|g' \
+ -e 's|$$$$QSA_INSTALL_PREFIX/mkspec/features|$$$$QSA_INSTALL_PREFIX/share/qt/mkspecs/features|g' \
+ ${WRKSRC}/src/qsa/qsa.pro
+# Yank the docs-installation from the configure script, qt does not handle
+# global removal of docs from assistant.
+ @${REINPLACE_CMD} -e 's|installDocs();||g' ${WRKSRC}/configure2/main.cpp
+
+# Disconnect a broken example from the build
+ @${REINPLACE_CMD} -e 's|enums||g' ${WRKSRC}/examples/examples.pro
+
+post-build:
+ @${CAT} ${PKGDIR}/pkg-message \
+ | ${SED} -e 's,%%PREFIX%%,${PREFIX},g' > ${PKGMESSAGE}
+
+do-install:
+ @(cd ${INSTALL_WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} \
+ Makefile.qsa ${INSTALL_TARGET})
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/devel/qsa/distinfo b/devel/qsa/distinfo
new file mode 100644
index 000000000000..a428b8aec99a
--- /dev/null
+++ b/devel/qsa/distinfo
@@ -0,0 +1,2 @@
+MD5 (KDE/qsa-x11-free-1.1.1.tar.gz) = 25a50ba29ee4a1dc528adc5011c29c2b
+SIZE (KDE/qsa-x11-free-1.1.1.tar.gz) = 1715187
diff --git a/devel/qsa/files/extrapatch-src_engine_qsoperations.cpp b/devel/qsa/files/extrapatch-src_engine_qsoperations.cpp
new file mode 100644
index 000000000000..26e08bba551c
--- /dev/null
+++ b/devel/qsa/files/extrapatch-src_engine_qsoperations.cpp
@@ -0,0 +1,16 @@
+--- src/engine/qsoperations.cpp.orig Mon Jul 12 15:04:29 2004
++++ src/engine/qsoperations.cpp Mon Jul 12 15:23:49 2004
+@@ -61,6 +61,13 @@
+ }
+ #endif
+
++#ifdef __FreeBSD__
++extern "C" {
++ int isnan( double );
++ int isinf( double );
++}
++#endif
++
+ using namespace QS;
+
+ bool QS::isNaN( double d )
diff --git a/devel/qsa/pkg-descr b/devel/qsa/pkg-descr
new file mode 100644
index 000000000000..737e0b90efc8
--- /dev/null
+++ b/devel/qsa/pkg-descr
@@ -0,0 +1,5 @@
+Qt Script for Applications is a cross-platform toolkit that allows developers
+to make their C++ applications scriptable using an interpreted scripting
+language, Qt Script (based on ECMAScript/JavaScript).
+
+WWW: http://www.trolltech.com/products/qsa/
diff --git a/devel/qsa/pkg-message b/devel/qsa/pkg-message
new file mode 100644
index 000000000000..aeb3f36a9d31
--- /dev/null
+++ b/devel/qsa/pkg-message
@@ -0,0 +1,10 @@
+
+To add the QSA documentation to your QT-Assistant's profile, execute
+
+assistant -addContentfile %%PREFIX%%/share/doc/qsa/html/*.xml to add the docs
+
+and
+
+assistant -removeContentfile %%PREFIX%%/share/doc/qsa/html/*.xml to remove them
+
+
diff --git a/devel/qsa/pkg-plist b/devel/qsa/pkg-plist
new file mode 100644
index 000000000000..9235bce5f0df
--- /dev/null
+++ b/devel/qsa/pkg-plist
@@ -0,0 +1,224 @@
+include/qsaglobal.h
+include/qsargument.h
+include/qsconfig.h
+include/qseditor.h
+include/qsinputdialogfactory.h
+include/qsinterpreter.h
+include/qsobjectfactory.h
+include/qsproject.h
+include/qsscript.h
+include/qswrapperfactory.h
+lib/libqsa.so
+lib/libqsa.so.1
+lib/libqsa.so.1.1
+lib/libqsa.so.1.1.1
+share/doc/qsa/html/addfunction.png
+share/doc/qsa/html/articles.html
+share/doc/qsa/html/classes.html
+share/doc/qsa/html/console.html
+share/doc/qsa/html/credits.html
+share/doc/qsa/html/dialog1.png
+share/doc/qsa/html/editmenu.png
+share/doc/qsa/html/example-scriptbutton.html
+share/doc/qsa/html/example-spreadsheet.html
+share/doc/qsa/html/example-textedit.html
+share/doc/qsa/html/examples.html
+share/doc/qsa/html/exportscriptdialog.png
+share/doc/qsa/html/extensions-1.html
+share/doc/qsa/html/extensions-2.html
+share/doc/qsa/html/extensions.dcf
+share/doc/qsa/html/extensions.html
+share/doc/qsa/html/extensions.xml
+share/doc/qsa/html/filedialog.png
+share/doc/qsa/html/filemenu.png
+share/doc/qsa/html/filter.html
+share/doc/qsa/html/filter_1.png
+share/doc/qsa/html/filter_2.png
+share/doc/qsa/html/functions.html
+share/doc/qsa/html/game.html
+share/doc/qsa/html/headerfilesynonyms
+share/doc/qsa/html/headers.html
+share/doc/qsa/html/helpmenu.png
+share/doc/qsa/html/importscriptdialog.png
+share/doc/qsa/html/index
+share/doc/qsa/html/index.html
+share/doc/qsa/html/inputitem.png
+share/doc/qsa/html/inputtext.png
+share/doc/qsa/html/language-1.html
+share/doc/qsa/html/language-2-1.html
+share/doc/qsa/html/language-2-2-1.html
+share/doc/qsa/html/language-2-2.html
+share/doc/qsa/html/language-2-3.html
+share/doc/qsa/html/language-2.html
+share/doc/qsa/html/language-3-1-1.html
+share/doc/qsa/html/language-3-1-10.html
+share/doc/qsa/html/language-3-1-11.html
+share/doc/qsa/html/language-3-1-12.html
+share/doc/qsa/html/language-3-1-13.html
+share/doc/qsa/html/language-3-1-14.html
+share/doc/qsa/html/language-3-1-15.html
+share/doc/qsa/html/language-3-1-16.html
+share/doc/qsa/html/language-3-1-17.html
+share/doc/qsa/html/language-3-1-2.html
+share/doc/qsa/html/language-3-1-3.html
+share/doc/qsa/html/language-3-1-4.html
+share/doc/qsa/html/language-3-1-5.html
+share/doc/qsa/html/language-3-1-6.html
+share/doc/qsa/html/language-3-1-7.html
+share/doc/qsa/html/language-3-1-8.html
+share/doc/qsa/html/language-3-1-9.html
+share/doc/qsa/html/language-3-1.html
+share/doc/qsa/html/language-3-2-1.html
+share/doc/qsa/html/language-3-2-2.html
+share/doc/qsa/html/language-3-2.html
+share/doc/qsa/html/language-3.html
+share/doc/qsa/html/language-4-1-1.html
+share/doc/qsa/html/language-4-1.html
+share/doc/qsa/html/language-4-2-1.html
+share/doc/qsa/html/language-4-2-2.html
+share/doc/qsa/html/language-4-2-3.html
+share/doc/qsa/html/language-4-2.html
+share/doc/qsa/html/language-4.html
+share/doc/qsa/html/language-5-1-1.html
+share/doc/qsa/html/language-5-1-10.html
+share/doc/qsa/html/language-5-1-2.html
+share/doc/qsa/html/language-5-1-3.html
+share/doc/qsa/html/language-5-1-4.html
+share/doc/qsa/html/language-5-1-5.html
+share/doc/qsa/html/language-5-1-6.html
+share/doc/qsa/html/language-5-1-7.html
+share/doc/qsa/html/language-5-1-8.html
+share/doc/qsa/html/language-5-1-9.html
+share/doc/qsa/html/language-5-1.html
+share/doc/qsa/html/language-5-2-1.html
+share/doc/qsa/html/language-5-2-2.html
+share/doc/qsa/html/language-5-2-3.html
+share/doc/qsa/html/language-5-2-4.html
+share/doc/qsa/html/language-5-2-5.html
+share/doc/qsa/html/language-5-2-6.html
+share/doc/qsa/html/language-5-2-7.html
+share/doc/qsa/html/language-5-2.html
+share/doc/qsa/html/language-5-3-1.html
+share/doc/qsa/html/language-5-3-2.html
+share/doc/qsa/html/language-5-3-3.html
+share/doc/qsa/html/language-5-3-4.html
+share/doc/qsa/html/language-5-3.html
+share/doc/qsa/html/language-5.html
+share/doc/qsa/html/language-6-1.html
+share/doc/qsa/html/language-6-10.html
+share/doc/qsa/html/language-6-11.html
+share/doc/qsa/html/language-6-12.html
+share/doc/qsa/html/language-6-13.html
+share/doc/qsa/html/language-6-14.html
+share/doc/qsa/html/language-6-15.html
+share/doc/qsa/html/language-6-16.html
+share/doc/qsa/html/language-6-17.html
+share/doc/qsa/html/language-6-2.html
+share/doc/qsa/html/language-6-3.html
+share/doc/qsa/html/language-6-4.html
+share/doc/qsa/html/language-6-5.html
+share/doc/qsa/html/language-6-6.html
+share/doc/qsa/html/language-6-7.html
+share/doc/qsa/html/language-6-8.html
+share/doc/qsa/html/language-6-9.html
+share/doc/qsa/html/language-6.html
+share/doc/qsa/html/language.dcf
+share/doc/qsa/html/language.html
+share/doc/qsa/html/language.xml
+share/doc/qsa/html/messageb1.png
+share/doc/qsa/html/newscript.png
+share/doc/qsa/html/plot.html
+share/doc/qsa/html/plot.png
+share/doc/qsa/html/projectmenu.png
+share/doc/qsa/html/propertydocs
+share/doc/qsa/html/propertyindex
+share/doc/qsa/html/qchkbox-w.png
+share/doc/qsa/html/qcombo1-w.png
+share/doc/qsa/html/qgrpbox-w.png
+share/doc/qsa/html/qlined-w.png
+share/doc/qsa/html/qradiobt-w.png
+share/doc/qsa/html/qsa-1.html
+share/doc/qsa/html/qsa-2.html
+share/doc/qsa/html/qsa-3.html
+share/doc/qsa/html/qsa-4.html
+share/doc/qsa/html/qsa-5.html
+share/doc/qsa/html/qsa.dcf
+share/doc/qsa/html/qsa.html
+share/doc/qsa/html/qsa.xml
+share/doc/qsa/html/qsad_callfunction.png
+share/doc/qsa/html/qsad_edittoolbar.png
+share/doc/qsa/html/qsad_filetoolbar.png
+share/doc/qsa/html/qsad_findtextdialog.png
+share/doc/qsa/html/qsad_gotolinedialog.png
+share/doc/qsa/html/qsad_newscriptdialog.png
+share/doc/qsa/html/qsad_nonobjectscript.png
+share/doc/qsa/html/qsad_objectscript.png
+share/doc/qsa/html/qsad_outputwindow.png
+share/doc/qsa/html/qsad_preferencesdialog.png
+share/doc/qsa/html/qsad_projecttoolbar.png
+share/doc/qsa/html/qsad_projectwindow.png
+share/doc/qsa/html/qsad_replacetextdialog.png
+share/doc/qsa/html/qsargument-h.html
+share/doc/qsa/html/qsargument-members.html
+share/doc/qsa/html/qsargument.html
+share/doc/qsa/html/qsargumentlist-members.html
+share/doc/qsa/html/qsargumentlist.html
+share/doc/qsa/html/qsaworkbench.png
+share/doc/qsa/html/qsdateed.png
+share/doc/qsa/html/qseditor-h.html
+share/doc/qsa/html/qseditor-members.html
+share/doc/qsa/html/qseditor.html
+share/doc/qsa/html/qsinputdialogfactory-h.html
+share/doc/qsa/html/qsinputdialogfactory-members.html
+share/doc/qsa/html/qsinputdialogfactory.html
+share/doc/qsa/html/qsinterpreter-h.html
+share/doc/qsa/html/qsinterpreter-members.html
+share/doc/qsa/html/qsinterpreter.html
+share/doc/qsa/html/qsobjectfactory-h.html
+share/doc/qsa/html/qsobjectfactory-members.html
+share/doc/qsa/html/qsobjectfactory.html
+share/doc/qsa/html/qspinbox-w.png
+share/doc/qsa/html/qsproject-h.html
+share/doc/qsa/html/qsproject-members.html
+share/doc/qsa/html/qsproject.html
+share/doc/qsa/html/qsscript-h.html
+share/doc/qsa/html/qsscript-members.html
+share/doc/qsa/html/qsscript.html
+share/doc/qsa/html/qsstackframe-members.html
+share/doc/qsa/html/qsstackframe.html
+share/doc/qsa/html/qsstacktrace-members.html
+share/doc/qsa/html/qsstacktrace.html
+share/doc/qsa/html/qstimeed.png
+share/doc/qsa/html/qsutilfactory-h.html
+share/doc/qsa/html/qsutilfactory-members.html
+share/doc/qsa/html/qsutilfactory.html
+share/doc/qsa/html/qsworkbench-h.html
+share/doc/qsa/html/qsworkbench-members.html
+share/doc/qsa/html/qsworkbench.html
+share/doc/qsa/html/qswrapperfactory-h.html
+share/doc/qsa/html/qswrapperfactory-members.html
+share/doc/qsa/html/qswrapperfactory.html
+share/doc/qsa/html/qt-script-for-applications.dcf
+share/doc/qsa/html/qt-script-for-applications.xml
+share/doc/qsa/html/qtscripter-1.html
+share/doc/qsa/html/qtscripter-2.html
+share/doc/qsa/html/qtscripter-3.html
+share/doc/qsa/html/qtscripter-4.html
+share/doc/qsa/html/qtscripter-5.html
+share/doc/qsa/html/qtscripter-6.html
+share/doc/qsa/html/qtscripter.dcf
+share/doc/qsa/html/qtscripter.html
+share/doc/qsa/html/qtscripter.xml
+share/doc/qsa/html/scribblescripter.html
+share/doc/qsa/html/searchmenu.png
+share/doc/qsa/html/titleindex
+share/doc/qsa/html/whatsthis
+share/doc/qsa/html/windowmenu1.png
+share/doc/qsa/html/windowmenu2.png
+share/doc/qsa/html/wrappers.html
+share/qt/mkspecs/features/qsa.prf
+@dirrm share/qt/mkspecs/features
+@dirrm share/qt/mkspecs
+@dirrm share/qt
+@dirrm share/doc/qsa/html
+@dirrm share/doc/qsa