aboutsummaryrefslogtreecommitdiff
path: root/devel/qscintilla2
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-27 09:41:06 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-27 09:41:06 +0000
commitb1b3f70c686a2f3f80cb780e8ef6681205c1e8ce (patch)
tree76e611f1719b157752d829a56eec70b4322eb11e /devel/qscintilla2
parent5e49acf5e0d1fee44d87c505961f08686b7c33ac (diff)
downloadports-b1b3f70c686a2f3f80cb780e8ef6681205c1e8ce.tar.gz
ports-b1b3f70c686a2f3f80cb780e8ef6681205c1e8ce.zip
Notes
Diffstat (limited to 'devel/qscintilla2')
-rw-r--r--devel/qscintilla2/Makefile91
-rw-r--r--devel/qscintilla2/distinfo3
-rw-r--r--devel/qscintilla2/pkg-descr3
-rw-r--r--devel/qscintilla2/pkg-plist218
4 files changed, 315 insertions, 0 deletions
diff --git a/devel/qscintilla2/Makefile b/devel/qscintilla2/Makefile
new file mode 100644
index 000000000000..d649696d8c31
--- /dev/null
+++ b/devel/qscintilla2/Makefile
@@ -0,0 +1,91 @@
+# New ports collection makefile for: qscintilla2
+# Date created: 2007-02-08
+# Whom: Danny Pansters <danny@ricin.com>
+#
+# $FreeBSD$
+
+PORTNAME= qscintilla2
+PORTVERSION= 20070318
+CATEGORIES= devel
+MASTER_SITES= http://www.riverbankcomputing.com/Downloads/Snapshots/QScintilla2/ \
+ http://freebsd.ricin.com/ports/distfiles/
+DISTNAME= QScintilla-1.72-gpl-2-snapshot-${PORTVERSION}
+
+MAINTAINER= danny@ricin.com
+COMMENT= Qt4 port of the Scintilla C++ editor class
+
+USE_QT_VER= 4
+QT_COMPONENTS= qmake moc gui
+USE_LDCONFIG= yes
+HAS_CONFIGURE= yes
+NO_FILTER_SHLIBS= yes
+
+OPTIONS= DOCS "Install documentation" on \
+ EXAMPLES "Install example" on \
+ HEADERS "Install Qsci headers" on \
+ TRANSLATIONS "Install translations (de, fr, pt_br, ru)" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(NOPORTDOCS) || defined(WITHOUT_DOCS)
+PLIST_SUB+= DOCS="@comment "
+.else
+PLIST_SUB+= DOCS=""
+.endif
+.if defined(NOPORTDOCS) || defined(WITHOUT_EXAMPLES)
+PLIST_SUB+= EXAMPLES="@comment "
+.else
+PLIST_SUB+= EXAMPLES=""
+.endif
+.if defined(WITHOUT_HEADERS)
+PLIST_SUB+= HEADERS="@comment "
+.else
+PLIST_SUB+= HEADERS=""
+.endif
+.if defined(WITH_TRANSLATIONS)
+PLIST_SUB+= TRANSLATIONS=""
+.else
+PLIST_SUB+= TRANSLATIONS="@comment "
+.endif
+
+post-patch:
+ ( cd ${WRKSRC}/Qt4 && ${REINPLACE_CMD} -e \
+ 's|$$$$\[QT_INSTALL_LIBS\]|${WRKSRC}/lib|' qscintilla.pro )
+.if defined(WITHOUT_HEADERS)
+ ( cd ${WRKSRC}/Qt4 && ${REINPLACE_CMD} -e \
+ 's|header trans qsci|trans qsci|' qscintilla.pro )
+.endif
+.if !defined(WITH_TRANSLATIONS)
+ ( cd ${WRKSRC}/Qt4 && ${REINPLACE_CMD} -e \
+ 's|trans qsci|qsci|' qscintilla.pro )
+.endif
+
+do-configure:
+ ( cd ${WRKSRC}/Qt4 && ${SETENV} ${CONFIGURE_ENV} \
+ ${QMAKE} -unix PREFIX=${PREFIX} qscintilla.pro )
+
+do-build:
+ ( cd ${WRKSRC}/Qt4 && ${MAKE} )
+
+do-install:
+ ( cd ${WRKSRC}/Qt4 && ${MAKE} install )
+ ( cd ${WRKSRC}/lib && \
+ ${MV} libqscintilla2.so.1.0.0 libqscintilla2.so.1 && \
+ ${INSTALL_DATA} libqscintilla2.so.1 ${PREFIX}/lib && \
+ cd ${PREFIX}/lib && \
+ ${LN} -sf libqscintilla2.so.1 libqscintilla2.so )
+.if !defined(NOPORTDOCS) && !defined(WITHOUT_DOCS)
+ ( cd ${WRKSRC} && \
+ ${MKDIR} -m 0755 ${DOCSDIR}/html ${DOCSDIR}/Scintilla && \
+ ${INSTALL_DATA} ChangeLog NEWS README ${DOCSDIR} && \
+ ${INSTALL_DATA} doc/html-Qt4/* ${DOCSDIR}/html && \
+ ${INSTALL_DATA} doc/Scintilla/* ${DOCSDIR}/Scintilla )
+.endif
+.if !defined(NOPORTDOCS) && !defined(WITHOUT_EXAMPLES)
+ ( cd ${WRKSRC}/example-Qt4 && \
+ ${MKDIR} -m 0755 ${EXAMPLESDIR}/images && \
+ ${INSTALL_DATA} *.* ${EXAMPLESDIR} && \
+ ${INSTALL_DATA} images/* ${EXAMPLESDIR}/images )
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/qscintilla2/distinfo b/devel/qscintilla2/distinfo
new file mode 100644
index 000000000000..50c7260dd6e2
--- /dev/null
+++ b/devel/qscintilla2/distinfo
@@ -0,0 +1,3 @@
+MD5 (QScintilla-1.72-gpl-2-snapshot-20070318.tar.gz) = 406bc1f4837b5b6bb67bbfb26d1dab9f
+SHA256 (QScintilla-1.72-gpl-2-snapshot-20070318.tar.gz) = fae15d16faa1016344f45eb2481660a9de0f9a7724aad0733d104409f6d1ffde
+SIZE (QScintilla-1.72-gpl-2-snapshot-20070318.tar.gz) = 1660332
diff --git a/devel/qscintilla2/pkg-descr b/devel/qscintilla2/pkg-descr
new file mode 100644
index 000000000000..4594c6db0176
--- /dev/null
+++ b/devel/qscintilla2/pkg-descr
@@ -0,0 +1,3 @@
+QScintilla2 is a port to Qt4 of Neil Hodgson's Scintilla C++ editor class.
+
+WWW: http://www.riverbankcomputing.co.uk/qscintilla/
diff --git a/devel/qscintilla2/pkg-plist b/devel/qscintilla2/pkg-plist
new file mode 100644
index 000000000000..5ebe132da802
--- /dev/null
+++ b/devel/qscintilla2/pkg-plist
@@ -0,0 +1,218 @@
+lib/libqscintilla2.so
+lib/libqscintilla2.so.1
+share/qt4/qsci/api/python/Python-2.4.api
+share/qt4/qsci/api/python/Python-2.5.api
+%%DOCS%%%%DOCSDIR%%/ChangeLog
+%%DOCS%%%%DOCSDIR%%/NEWS
+%%DOCS%%%%DOCSDIR%%/README
+%%DOCS%%%%DOCSDIR%%/Scintilla/Design.html
+%%DOCS%%%%DOCSDIR%%/Scintilla/Icons.html
+%%DOCS%%%%DOCSDIR%%/Scintilla/Lexer.txt
+%%DOCS%%%%DOCSDIR%%/Scintilla/SciBreak.jpg
+%%DOCS%%%%DOCSDIR%%/Scintilla/SciCoding.html
+%%DOCS%%%%DOCSDIR%%/Scintilla/SciRest.jpg
+%%DOCS%%%%DOCSDIR%%/Scintilla/SciTEIco.png
+%%DOCS%%%%DOCSDIR%%/Scintilla/SciWord.jpg
+%%DOCS%%%%DOCSDIR%%/Scintilla/ScintillaDoc.html
+%%DOCS%%%%DOCSDIR%%/Scintilla/ScintillaDownload.html
+%%DOCS%%%%DOCSDIR%%/Scintilla/ScintillaHistory.html
+%%DOCS%%%%DOCSDIR%%/Scintilla/ScintillaRelated.html
+%%DOCS%%%%DOCSDIR%%/Scintilla/ScintillaToDo.html
+%%DOCS%%%%DOCSDIR%%/Scintilla/ScintillaUsage.html
+%%DOCS%%%%DOCSDIR%%/Scintilla/Steps.html
+%%DOCS%%%%DOCSDIR%%/Scintilla/index.html
+%%DOCS%%%%DOCSDIR%%/html/annotated.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciAPIs-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciAPIs.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciCommand-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciCommand.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciCommandSet-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciCommandSet.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciDocument-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciDocument.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexer-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexer.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerBash-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerBash.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerBatch-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerBatch.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerCPP-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerCPP.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerCSS-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerCSS.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerCSharp-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerCSharp.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerDiff-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerDiff.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerHTML-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerHTML.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerIDL-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerIDL.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerJava-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerJava.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerJavaScript-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerJavaScript.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerLua-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerLua.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerMakefile-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerMakefile.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerPOV-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerPOV.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerPerl-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerPerl.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerProperties-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerProperties.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerPython-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerPython.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerRuby-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerRuby.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerSQL-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerSQL.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerTeX-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciLexerTeX.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciMacro-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciMacro.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciPrinter-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciPrinter.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciScintilla-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciScintilla.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciScintillaBase-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQsciScintillaBase.html
+%%DOCS%%%%DOCSDIR%%/html/dir_b5bf78a35e8d093335c78f35e76af406.html
+%%DOCS%%%%DOCSDIR%%/html/dir_c998c31d8b2389e3c98da8b1324de8f7.html
+%%DOCS%%%%DOCSDIR%%/html/dirs.html
+%%DOCS%%%%DOCSDIR%%/html/doxygen.css
+%%DOCS%%%%DOCSDIR%%/html/doxygen.png
+%%DOCS%%%%DOCSDIR%%/html/functions.html
+%%DOCS%%%%DOCSDIR%%/html/functions_0x62.html
+%%DOCS%%%%DOCSDIR%%/html/functions_0x63.html
+%%DOCS%%%%DOCSDIR%%/html/functions_0x64.html
+%%DOCS%%%%DOCSDIR%%/html/functions_0x65.html
+%%DOCS%%%%DOCSDIR%%/html/functions_0x66.html
+%%DOCS%%%%DOCSDIR%%/html/functions_0x67.html
+%%DOCS%%%%DOCSDIR%%/html/functions_0x68.html
+%%DOCS%%%%DOCSDIR%%/html/functions_0x69.html
+%%DOCS%%%%DOCSDIR%%/html/functions_0x6a.html
+%%DOCS%%%%DOCSDIR%%/html/functions_0x6b.html
+%%DOCS%%%%DOCSDIR%%/html/functions_0x6c.html
+%%DOCS%%%%DOCSDIR%%/html/functions_0x6d.html
+%%DOCS%%%%DOCSDIR%%/html/functions_0x6e.html
+%%DOCS%%%%DOCSDIR%%/html/functions_0x6f.html
+%%DOCS%%%%DOCSDIR%%/html/functions_0x70.html
+%%DOCS%%%%DOCSDIR%%/html/functions_0x71.html
+%%DOCS%%%%DOCSDIR%%/html/functions_0x72.html
+%%DOCS%%%%DOCSDIR%%/html/functions_0x73.html
+%%DOCS%%%%DOCSDIR%%/html/functions_0x74.html
+%%DOCS%%%%DOCSDIR%%/html/functions_0x75.html
+%%DOCS%%%%DOCSDIR%%/html/functions_0x76.html
+%%DOCS%%%%DOCSDIR%%/html/functions_0x77.html
+%%DOCS%%%%DOCSDIR%%/html/functions_0x78.html
+%%DOCS%%%%DOCSDIR%%/html/functions_0x7a.html
+%%DOCS%%%%DOCSDIR%%/html/functions_0x7e.html
+%%DOCS%%%%DOCSDIR%%/html/functions_enum.html
+%%DOCS%%%%DOCSDIR%%/html/functions_eval.html
+%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x62.html
+%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x63.html
+%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x64.html
+%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x65.html
+%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x66.html
+%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x67.html
+%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x68.html
+%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x69.html
+%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x6a.html
+%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x6b.html
+%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x6c.html
+%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x6d.html
+%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x6e.html
+%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x6f.html
+%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x70.html
+%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x71.html
+%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x72.html
+%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x73.html
+%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x74.html
+%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x75.html
+%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x76.html
+%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x77.html
+%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x78.html
+%%DOCS%%%%DOCSDIR%%/html/functions_func.html
+%%DOCS%%%%DOCSDIR%%/html/functions_func_0x62.html
+%%DOCS%%%%DOCSDIR%%/html/functions_func_0x63.html
+%%DOCS%%%%DOCSDIR%%/html/functions_func_0x64.html
+%%DOCS%%%%DOCSDIR%%/html/functions_func_0x65.html
+%%DOCS%%%%DOCSDIR%%/html/functions_func_0x66.html
+%%DOCS%%%%DOCSDIR%%/html/functions_func_0x67.html
+%%DOCS%%%%DOCSDIR%%/html/functions_func_0x68.html
+%%DOCS%%%%DOCSDIR%%/html/functions_func_0x69.html
+%%DOCS%%%%DOCSDIR%%/html/functions_func_0x6b.html
+%%DOCS%%%%DOCSDIR%%/html/functions_func_0x6c.html
+%%DOCS%%%%DOCSDIR%%/html/functions_func_0x6d.html
+%%DOCS%%%%DOCSDIR%%/html/functions_func_0x70.html
+%%DOCS%%%%DOCSDIR%%/html/functions_func_0x71.html
+%%DOCS%%%%DOCSDIR%%/html/functions_func_0x72.html
+%%DOCS%%%%DOCSDIR%%/html/functions_func_0x73.html
+%%DOCS%%%%DOCSDIR%%/html/functions_func_0x74.html
+%%DOCS%%%%DOCSDIR%%/html/functions_func_0x75.html
+%%DOCS%%%%DOCSDIR%%/html/functions_func_0x76.html
+%%DOCS%%%%DOCSDIR%%/html/functions_func_0x77.html
+%%DOCS%%%%DOCSDIR%%/html/functions_func_0x7a.html
+%%DOCS%%%%DOCSDIR%%/html/functions_func_0x7e.html
+%%DOCS%%%%DOCSDIR%%/html/hierarchy.html
+%%DOCS%%%%DOCSDIR%%/html/index.html
+%%DOCS%%%%DOCSDIR%%/html/tab_b.gif
+%%DOCS%%%%DOCSDIR%%/html/tab_l.gif
+%%DOCS%%%%DOCSDIR%%/html/tab_r.gif
+%%DOCS%%%%DOCSDIR%%/html/tabs.css
+%%HEADERS%%include/Qsci/qsciapis.h
+%%HEADERS%%include/Qsci/qscicommand.h
+%%HEADERS%%include/Qsci/qscicommandset.h
+%%HEADERS%%include/Qsci/qscidocument.h
+%%HEADERS%%include/Qsci/qsciglobal.h
+%%HEADERS%%include/Qsci/qscilexer.h
+%%HEADERS%%include/Qsci/qscilexerbash.h
+%%HEADERS%%include/Qsci/qscilexerbatch.h
+%%HEADERS%%include/Qsci/qscilexercpp.h
+%%HEADERS%%include/Qsci/qscilexercsharp.h
+%%HEADERS%%include/Qsci/qscilexercss.h
+%%HEADERS%%include/Qsci/qscilexerdiff.h
+%%HEADERS%%include/Qsci/qscilexerhtml.h
+%%HEADERS%%include/Qsci/qscilexeridl.h
+%%HEADERS%%include/Qsci/qscilexerjava.h
+%%HEADERS%%include/Qsci/qscilexerjavascript.h
+%%HEADERS%%include/Qsci/qscilexerlua.h
+%%HEADERS%%include/Qsci/qscilexermakefile.h
+%%HEADERS%%include/Qsci/qscilexerperl.h
+%%HEADERS%%include/Qsci/qscilexerpov.h
+%%HEADERS%%include/Qsci/qscilexerproperties.h
+%%HEADERS%%include/Qsci/qscilexerpython.h
+%%HEADERS%%include/Qsci/qscilexerruby.h
+%%HEADERS%%include/Qsci/qscilexersql.h
+%%HEADERS%%include/Qsci/qscilexertex.h
+%%HEADERS%%include/Qsci/qscimacro.h
+%%HEADERS%%include/Qsci/qsciprinter.h
+%%HEADERS%%include/Qsci/qsciscintilla.h
+%%HEADERS%%include/Qsci/qsciscintillabase.h
+%%EXAMPLES%%%%EXAMPLESDIR%%/images/copy.png
+%%EXAMPLES%%%%EXAMPLESDIR%%/images/cut.png
+%%EXAMPLES%%%%EXAMPLESDIR%%/images/new.png
+%%EXAMPLES%%%%EXAMPLESDIR%%/images/open.png
+%%EXAMPLES%%%%EXAMPLESDIR%%/images/paste.png
+%%EXAMPLES%%%%EXAMPLESDIR%%/images/save.png
+%%EXAMPLES%%%%EXAMPLESDIR%%/application.pro
+%%EXAMPLES%%%%EXAMPLESDIR%%/application.qrc
+%%EXAMPLES%%%%EXAMPLESDIR%%/main.cpp
+%%EXAMPLES%%%%EXAMPLESDIR%%/mainwindow.cpp
+%%EXAMPLES%%%%EXAMPLESDIR%%/mainwindow.h
+%%TRANSLATIONS%%share/qt4/translations/qscintilla_de.qm
+%%TRANSLATIONS%%share/qt4/translations/qscintilla_fr.qm
+%%TRANSLATIONS%%share/qt4/translations/qscintilla_pt_br.qm
+%%TRANSLATIONS%%share/qt4/translations/qscintilla_ru.qm
+@dirrmtry share/qt4/qsci/api/python
+@dirrmtry share/qt4/qsci/api
+@dirrmtry share/qt4/qsci
+%%DOCS%%@dirrm %%DOCSDIR%%/Scintilla
+%%DOCS%%@dirrm %%DOCSDIR%%/html
+%%DOCS%%@dirrm %%DOCSDIR%%
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/images
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%HEADERS%%@dirrm include/Qsci
+%%TRANSLATIONS%%@dirrmtry share/qt4/translations