aboutsummaryrefslogtreecommitdiff
path: root/devel/qt-designer
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-12-04 03:47:18 +0000
committerWill Andrews <will@FreeBSD.org>2001-12-04 03:47:18 +0000
commit1d206a3483e848f4589962473bdf169313ea740f (patch)
tree269caee3e56d61cd6318b44d85c3ff64b32d57b6 /devel/qt-designer
parentfb2c030e15fb4b426c06fee701c06b7f44c272ab (diff)
downloadports-1d206a3483e848f4589962473bdf169313ea740f.tar.gz
ports-1d206a3483e848f4589962473bdf169313ea740f.zip
Notes
Diffstat (limited to 'devel/qt-designer')
-rw-r--r--devel/qt-designer/Makefile12
-rw-r--r--devel/qt-designer/files/patch-Makefile16
-rw-r--r--devel/qt-designer/files/patch-aa52
-rw-r--r--devel/qt-designer/files/patch-ag13
-rw-r--r--devel/qt-designer/files/patch-ah14
-rw-r--r--devel/qt-designer/files/patch-ai15
-rw-r--r--devel/qt-designer/files/patch-aj32
-rw-r--r--devel/qt-designer/files/patch-designer::Makefile.in11
-rw-r--r--devel/qt-designer/files/patch-designer:Makefile.in17
-rw-r--r--devel/qt-designer/pkg-plist321
10 files changed, 171 insertions, 332 deletions
diff --git a/devel/qt-designer/Makefile b/devel/qt-designer/Makefile
index 0ca0b97b5d70..d862aa6c16ae 100644
--- a/devel/qt-designer/Makefile
+++ b/devel/qt-designer/Makefile
@@ -16,12 +16,22 @@ post-patch:
do-build:
(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
+qt-pre-configure:
+ ${PERL} -pi -e 's@DESTDIR = \$$\(QTDIR\)/bin@DESTDIR = ../../../bin@g' \
+ ${WRKSRC}/tools/designer/designer/Makefile.in
+ ${PERL} -pi -e 's@sub-tools: sub-src @sub-tools: @g' ${WRKSRC}/Makefile
+ ${PERL} -pi -e "s@\$$(MAKE) util@@g; s@\$$(MAKE) uic@@g; \
+ s@util \\\@designer@g; s@uic \\\@@g; \
+ s@\t\tdesigner@@g" ${WRKSRC}/tools/designer/Makefile.in
+ ${PERL} -pi -e "s@getenv\( \"QTDIR\" \)@QT_PREFIX@g; \
+ s@/tools/designer/templates@/share/qt2/designer/templates@g" \
+ ${WRKSRC}/tools/designer/designer/newformimpl.cpp
+
.include "${MASTERDIR}/Makefile"
LIB_DEPENDS+= qt2.4:${PORTSDIR}/x11-toolkits/qt23
WRKSRC= ${WRKDIR}/qt-${PORTVERSION}
-PATCHDIR= ${.CURDIR}/files
PATCH_WRKSRC= ${WRKSRC}
PKGDIR= ${.CURDIR}
MAKE_ENV= QTDIR=${PREFIX} LD_LIBRARY_PATH=${PREFIX}/lib PREFIX=${PREFIX}
diff --git a/devel/qt-designer/files/patch-Makefile b/devel/qt-designer/files/patch-Makefile
deleted file mode 100644
index 3d93c0866277..000000000000
--- a/devel/qt-designer/files/patch-Makefile
+++ /dev/null
@@ -1,16 +0,0 @@
---- Makefile Mon Aug 6 01:55:43 2001
-+++ Makefile.new Mon Aug 6 01:56:45 2001
-@@ -25,11 +25,11 @@
- -rm -f bin/moc
- cp src/moc/moc bin/moc
-
--sub-tools: sub-src FORCE
-+sub-tools: FORCE
- cd tools; $(MAKE)
-
- symlinks: .buildopts
-- @cd include; rm -f q*.h; for i in $(QTDIR)/src/*/q*.h $(QTDIR)/extensions/*/src/q*.h; do ln -s $$i .; done; rm -f q*_p.h
-+ @cd include; rm -f q*.h; for i in ../src/*/q*.h ../extensions/*/src/q*.h; do ln -s $$i .; done; rm -f q*_p.h
-
- sub-src: src-moc src-mt .buildopts FORCE
- cd src; $(MAKE)
diff --git a/devel/qt-designer/files/patch-aa b/devel/qt-designer/files/patch-aa
deleted file mode 100644
index a58966744e42..000000000000
--- a/devel/qt-designer/files/patch-aa
+++ /dev/null
@@ -1,52 +0,0 @@
---- configs/freebsd-g++-shared Sun Dec 24 02:41:35 2000
-+++ configs/freebsd-g++-shared.new Sun Dec 24 02:42:49 2000
-@@ -6,7 +6,7 @@
-
- # Compiling with support libraries
- SYSCONF_CXXFLAGS_X11 = -I/usr/X11R6/include
--SYSCONF_CXXFLAGS_QT = -I$(QTDIR)/include
-+SYSCONF_CXXFLAGS_QT= -I$(QTDIR)/include $(SYSCONF_CXXFLAGS_THREAD)
- SYSCONF_CXXFLAGS_OPENGL = -I/usr/X11R6/include
-
- # Compiling YACC output
-@@ -23,7 +23,7 @@
- SYSCONF_LIBS_X11 = -lXext -lX11 -lm
- # Qt, Qt+OpenGL
- SYSCONF_LFLAGS_QT = -L$(QTDIR)/lib
--SYSCONF_LIBS_QT = -lqt$(QT_THREAD_SUFFIX)
-+SYSCONF_LIBS_QT = -lqt2$(QT_THREAD_SUFFIX) $(SYSCONF_LFLAGS_THREAD)
- SYSCONF_LIBS_QT_OPENGL =
- # OpenGL
- SYSCONF_LFLAGS_OPENGL = -L/usr/X11R6/lib
-@@ -46,7 +46,7 @@
- SYSCONF_LIBS_THREAD =
-
- # Meta-object compiler
--SYSCONF_MOC = $(QTDIR)/bin/moc
-+SYSCONF_MOC = $(QTDIR)/bin/moc2
-
- # UI compiler
- SYSCONF_UIC = $(QTDIR)/bin/uic
-@@ -60,1 +60,1 @@
--SYSCONF_LINK_TARGET_SHARED = lib$(TARGET).so.$(VER_MAJ).$(VER_MIN).$(VER_PATCH)
-+SYSCONF_LINK_TARGET_SHARED = lib$(TARGET).so.$(VER_MAJ)
-@@ -65,6 +65,4 @@
- cd $(DESTDIR) && \
-- rm -f lib$(TARGET).so lib$(TARGET).so.$(VER_MAJ) lib$(TARGET).so.$(VER_MAJ).$(VER_MIN); \
-- ln -s $(SYSCONF_LINK_TARGET_SHARED) lib$(TARGET).so; \
-- ln -s $(SYSCONF_LINK_TARGET_SHARED) lib$(TARGET).so.$(VER_MAJ); \
-- ln -s $(SYSCONF_LINK_TARGET_SHARED) lib$(TARGET).so.$(VER_MAJ).$(VER_MIN)
-+ rm -f lib$(TARGET).so;\
-+ ln -s $(SYSCONF_LINK_TARGET_SHARED) lib$(TARGET).so
-
-@@ -77,8 +75,8 @@
- SYSCONF_LINK_LIB_STATIC = rm -f $(DESTDIR)$(SYSCONF_LINK_TARGET_STATIC) ; \
- $(SYSCONF_AR) $(DESTDIR)$(SYSCONF_LINK_TARGET_STATIC) $(OBJECTS) $(OBJMOC)
- # Compiling application source
--SYSCONF_CXXFLAGS = -pipe -fno-exceptions -O2
--SYSCONF_CFLAGS = -pipe -fno-exceptions -O2
-+SYSCONF_CXXFLAGS = -DQT_PREFIX=\"${PREFIX}\" -pipe -O -fno-exceptions
-+SYSCONF_CFLAGS = -DQT_PREFIX=\"${PREFIX}\" -pipe -O -fno-exceptions
- # Default link type (static linking is still be used where required)
- SYSCONF_LINK_LIB = $(SYSCONF_LINK_LIB_SHARED)
- SYSCONF_LINK_TARGET = $(SYSCONF_LINK_TARGET_SHARED)
diff --git a/devel/qt-designer/files/patch-ag b/devel/qt-designer/files/patch-ag
deleted file mode 100644
index 0347913d3a31..000000000000
--- a/devel/qt-designer/files/patch-ag
+++ /dev/null
@@ -1,13 +0,0 @@
---- tools/designer/designer/help.cpp 2000/11/18 17:43:54 1.1
-+++ tools/designer/designer/help.cpp 2000/11/18 17:46:09
-@@ -84,8 +84,8 @@
- browser = new TextBrowser( this );
- browser->mimeSourceFactory()->setFilePath( home );
- browser->setFrameStyle( QFrame::Panel | QFrame::Sunken );
-- browser->mimeSourceFactory()->addFilePath( QString( getenv( "QTDIR" ) ) + "/tools/designer/manual" );
-- browser->mimeSourceFactory()->addFilePath( QString( getenv( "QTDIR" ) ) + "/doc/html/designer" );
-+ browser->mimeSourceFactory()->addFilePath( QT_PREFIX "/share/qt2/designer/manual" );
-+ browser->mimeSourceFactory()->addFilePath( QT_PREFIX "/share/doc/qt2/html/designer" );
- browser->mimeSourceFactory()->addFilePath( parent->documentationPath() );
- connect( browser, SIGNAL( textChanged() ),
- this, SLOT( textChanged() ) );
diff --git a/devel/qt-designer/files/patch-ah b/devel/qt-designer/files/patch-ah
deleted file mode 100644
index 1bf90ba1c6f2..000000000000
--- a/devel/qt-designer/files/patch-ah
+++ /dev/null
@@ -1,14 +0,0 @@
---- tools/designer/designer/helpdialogimpl.cpp 2000/11/18 19:37:35 1.1
-+++ tools/designer/designer/helpdialogimpl.cpp 2000/11/18 19:38:57
-@@ -569,9 +569,9 @@
- delete lst;
-
-
-- QString manualdir = QString( getenv( "QTDIR" ) ) + "/tools/designer/manual/book1.html";
-+ QString manualdir = QT_PREFIX "/share/qt2/designer/manual/book1.html";
- if ( !QFile::exists( manualdir ) )
-- manualdir = QString( getenv( "QTDIR" ) ) + "/doc/html/designer/book1.html";
-+ manualdir = QT_PREFIX "/share/doc/qt2/html/designer/book1.html";
- QFile file( manualdir );
- if ( !file.open( IO_ReadOnly ) )
- return;
diff --git a/devel/qt-designer/files/patch-ai b/devel/qt-designer/files/patch-ai
deleted file mode 100644
index 8ba1cf2ee470..000000000000
--- a/devel/qt-designer/files/patch-ai
+++ /dev/null
@@ -1,15 +0,0 @@
---- tools/designer/designer/newformimpl.cpp 2000/11/18 17:43:54 1.1
-+++ tools/designer/designer/newformimpl.cpp 2000/11/18 17:48:49
-@@ -33,9 +33,9 @@
- {
- if ( QFileInfo( "../templates" ).exists() )
- return "../templates";
-- QString qtdir = getenv( "QTDIR" );
-- if ( QFileInfo( qtdir + "/tools/designer/templates" ).exists() )
-- return qtdir + "/tools/designer/templates";
-+ QString qtdir = QT_PREFIX;
-+ if ( QFileInfo( qtdir + "/share/qt2/designer/templates" ).exists() )
-+ return qtdir + "/share/qt2/designer/templates";
- return t;
- }
-
diff --git a/devel/qt-designer/files/patch-aj b/devel/qt-designer/files/patch-aj
deleted file mode 100644
index eddf54f011d9..000000000000
--- a/devel/qt-designer/files/patch-aj
+++ /dev/null
@@ -1,32 +0,0 @@
---- tools/designer/designer/mainwindow.cpp 2000/11/18 17:50:58 1.1
-+++ tools/designer/designer/mainwindow.cpp 2000/11/18 17:53:21
-@@ -125,7 +125,7 @@
- : QMainWindow( 0, "mainwindow", WType_TopLevel | WDestructiveClose ),
- #endif
- grd( 10, 10 ), sGrid( TRUE ), snGrid( TRUE ), restoreConfig( TRUE ), splashScreen( TRUE ),
-- docPath( "$QTDIR/doc/html" ), client( asClient )
-+ docPath( QT_PREFIX "/share/doc/qt2/html" ), client( asClient )
- {
- self = this;
- setIcon( PixmapChooser::loadPixmap( "logo" ) );
-@@ -3144,7 +3144,7 @@
- QMessageBox::information( this, tr( "Create Template" ), tr( "Couldn't create the template" ) );
- return;
- }
-- fn.prepend( QString( getenv( "QTDIR" ) ) + "/tools/designer/templates/" );
-+ fn.prepend( QT_PREFIX "/share/qt2/designer/templates/" );
- fn.append( ".ui" );
- QFile f( fn );
- if ( !f.open( IO_WriteOnly ) ) {
-@@ -3236,9 +3236,9 @@
-
- void MainWindow::openHelpForDialog( const QString &dia )
- {
-- QString manualdir = QString( getenv( "QTDIR" ) ) + "/tools/designer/manual/book1.html";
-+ QString manualdir = QT_PREFIX "/share/qt2/designer/manual/book1.html";
- if ( !QFile::exists( manualdir ) )
-- manualdir = QString( getenv( "QTDIR" ) ) + "/doc/html/designer/book1.html";
-+ manualdir = QT_PREFIX "/share/doc/qt2/html/designer/book1.html";
- QFile file( manualdir );
- if ( !file.open( IO_ReadOnly ) )
- return;
diff --git a/devel/qt-designer/files/patch-designer::Makefile.in b/devel/qt-designer/files/patch-designer::Makefile.in
deleted file mode 100644
index 52f3cca45258..000000000000
--- a/devel/qt-designer/files/patch-designer::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- tools/designer/designer/Makefile.in Wed Jan 31 21:29:50 2001
-+++ tools/designer/designer/Makefile.in.new Sat Feb 3 20:41:04 2001
-@@ -14,7 +14,7 @@
-
- ####### Target
-
--DESTDIR = $(QTDIR)/bin/
-+DESTDIR = ../../../bin/
- VER_MAJ = 1
- VER_MIN = 0
- VER_PATCH = 0
diff --git a/devel/qt-designer/files/patch-designer:Makefile.in b/devel/qt-designer/files/patch-designer:Makefile.in
deleted file mode 100644
index 498cff3955af..000000000000
--- a/devel/qt-designer/files/patch-designer:Makefile.in
+++ /dev/null
@@ -1,17 +0,0 @@
---- tools/designer/Makefile.in Wed Jan 31 21:29:47 2001
-+++ tools/designer/Makefile.in.new Sat Feb 3 20:04:32 2001
-@@ -5,13 +5,9 @@
- # Template: subdirs
- #############################################################################
-
--SUBDIRS = util \
-- uic \
-- designer
-+SUBDIRS = designer
-
- all:
-- $(MAKE) util
-- $(MAKE) uic
- $(MAKE) designer
-
-
diff --git a/devel/qt-designer/pkg-plist b/devel/qt-designer/pkg-plist
index 2e4183356173..c4612f2176b3 100644
--- a/devel/qt-designer/pkg-plist
+++ b/devel/qt-designer/pkg-plist
@@ -1,165 +1,164 @@
-bin/designer
-share/doc/qt2/html/designer/arrows/home.png
-share/doc/qt2/html/designer/arrows/left.png
-share/doc/qt2/html/designer/arrows/right.png
-share/doc/qt2/html/designer/arrows/up.png
-share/doc/qt2/html/designer/book1.html
-share/doc/qt2/html/designer/chap10_1.html
-share/doc/qt2/html/designer/chap1_1.html
-share/doc/qt2/html/designer/chap2_1.html
-share/doc/qt2/html/designer/chap2_2.html
-share/doc/qt2/html/designer/chap2_3.html
-share/doc/qt2/html/designer/chap2_4.html
-share/doc/qt2/html/designer/chap3_1.html
-share/doc/qt2/html/designer/chap3_2.html
-share/doc/qt2/html/designer/chap3_3.html
-share/doc/qt2/html/designer/chap3_4.html
-share/doc/qt2/html/designer/chap4_1.html
-share/doc/qt2/html/designer/chap4_2.html
-share/doc/qt2/html/designer/chap5_1.html
-share/doc/qt2/html/designer/chap5_2.html
-share/doc/qt2/html/designer/chap5_3.html
-share/doc/qt2/html/designer/chap5_4.html
-share/doc/qt2/html/designer/chap5_5.html
-share/doc/qt2/html/designer/chap5_6.html
-share/doc/qt2/html/designer/chap6_1.html
-share/doc/qt2/html/designer/chap6_2.html
-share/doc/qt2/html/designer/chap6_3.html
-share/doc/qt2/html/designer/chap6_4.html
-share/doc/qt2/html/designer/chap6_5.html
-share/doc/qt2/html/designer/chap6_6.html
-share/doc/qt2/html/designer/chap6_7.html
-share/doc/qt2/html/designer/chap7_1.html
-share/doc/qt2/html/designer/chap7_10.html
-share/doc/qt2/html/designer/chap7_11.html
-share/doc/qt2/html/designer/chap7_12.html
-share/doc/qt2/html/designer/chap7_13.html
-share/doc/qt2/html/designer/chap7_14.html
-share/doc/qt2/html/designer/chap7_15.html
-share/doc/qt2/html/designer/chap7_16.html
-share/doc/qt2/html/designer/chap7_2.html
-share/doc/qt2/html/designer/chap7_3.html
-share/doc/qt2/html/designer/chap7_4.html
-share/doc/qt2/html/designer/chap7_5.html
-share/doc/qt2/html/designer/chap7_6.html
-share/doc/qt2/html/designer/chap7_7.html
-share/doc/qt2/html/designer/chap7_8.html
-share/doc/qt2/html/designer/chap7_9.html
-share/doc/qt2/html/designer/chap8_1.html
-share/doc/qt2/html/designer/chap9_1.html
-share/doc/qt2/html/designer/chap9_2.html
-share/doc/qt2/html/designer/chap9_3.html
-share/doc/qt2/html/designer/chap9_4.html
-share/doc/qt2/html/designer/chap9_5.html
-share/doc/qt2/html/designer/chap9_6.html
-share/doc/qt2/html/designer/colophon.html
-share/doc/qt2/html/designer/feedback.html
-share/doc/qt2/html/designer/figures/aboutdialog.png
-share/doc/qt2/html/designer/figures/adjustsize.png
-share/doc/qt2/html/designer/figures/breaklayout.png
-share/doc/qt2/html/designer/figures/buttongroup.png
-share/doc/qt2/html/designer/figures/buttongroupovercheckboxes.png
-share/doc/qt2/html/designer/figures/checkbox.png
-share/doc/qt2/html/designer/figures/combobox.png
-share/doc/qt2/html/designer/figures/connectionedit.png
-share/doc/qt2/html/designer/figures/connections.png
-share/doc/qt2/html/designer/figures/connectionviewer.png
-share/doc/qt2/html/designer/figures/connecttool.png
-share/doc/qt2/html/designer/figures/customwidget.png
-share/doc/qt2/html/designer/figures/customwidgets.png
-share/doc/qt2/html/designer/figures/editcopy.png
-share/doc/qt2/html/designer/figures/editcustomwidgets.png
-share/doc/qt2/html/designer/figures/editcut.png
-share/doc/qt2/html/designer/figures/editdelete.png
-share/doc/qt2/html/designer/figures/editgrid.png
-share/doc/qt2/html/designer/figures/edithlayout.png
-share/doc/qt2/html/designer/figures/editiconview.png
-share/doc/qt2/html/designer/figures/editlistbox.png
-share/doc/qt2/html/designer/figures/editlistview.png
-share/doc/qt2/html/designer/figures/editlower.png
-share/doc/qt2/html/designer/figures/editmultiline.png
-share/doc/qt2/html/designer/figures/editpaste.png
-share/doc/qt2/html/designer/figures/editraise.png
-share/doc/qt2/html/designer/figures/editslots.png
-share/doc/qt2/html/designer/figures/emptydialog.png
-share/doc/qt2/html/designer/figures/f001.png
-share/doc/qt2/html/designer/figures/filenew.png
-share/doc/qt2/html/designer/figures/filesave.png
-share/doc/qt2/html/designer/figures/firstdialog.png
-share/doc/qt2/html/designer/figures/form.png
-share/doc/qt2/html/designer/figures/formsettings.png
-share/doc/qt2/html/designer/figures/fourcheckboxes.png
-share/doc/qt2/html/designer/figures/frame.png
-share/doc/qt2/html/designer/figures/groupbox.png
-share/doc/qt2/html/designer/figures/help.png
-share/doc/qt2/html/designer/figures/helpdialog.png
-share/doc/qt2/html/designer/figures/home.png
-share/doc/qt2/html/designer/figures/iconview.png
-share/doc/qt2/html/designer/figures/image.png
-share/doc/qt2/html/designer/figures/label.png
-share/doc/qt2/html/designer/figures/layout.png
-share/doc/qt2/html/designer/figures/layouttutstep1.png
-share/doc/qt2/html/designer/figures/layouttutstep10.png
-share/doc/qt2/html/designer/figures/layouttutstep11.png
-share/doc/qt2/html/designer/figures/layouttutstep2.png
-share/doc/qt2/html/designer/figures/layouttutstep3.png
-share/doc/qt2/html/designer/figures/layouttutstep4.png
-share/doc/qt2/html/designer/figures/layouttutstep5.png
-share/doc/qt2/html/designer/figures/layouttutstep6.png
-share/doc/qt2/html/designer/figures/layouttutstep7.png
-share/doc/qt2/html/designer/figures/layouttutstep9.png
-share/doc/qt2/html/designer/figures/lcdnumber.png
-share/doc/qt2/html/designer/figures/left.png
-share/doc/qt2/html/designer/figures/line.png
-share/doc/qt2/html/designer/figures/lineedit.png
-share/doc/qt2/html/designer/figures/listbox.png
-share/doc/qt2/html/designer/figures/listview.png
-share/doc/qt2/html/designer/figures/load.png
-share/doc/qt2/html/designer/figures/multilineedit.png
-share/doc/qt2/html/designer/figures/newform.png
-share/doc/qt2/html/designer/figures/newformdialog.png
-share/doc/qt2/html/designer/figures/objecthierarchy.png
-share/doc/qt2/html/designer/figures/onecheckbox.png
-share/doc/qt2/html/designer/figures/ordertool.png
-share/doc/qt2/html/designer/figures/paletteeditor.png
-share/doc/qt2/html/designer/figures/pixlabel.png
-share/doc/qt2/html/designer/figures/pizza1screenshot.png
-share/doc/qt2/html/designer/figures/pointer.png
-share/doc/qt2/html/designer/figures/preferences.png
-share/doc/qt2/html/designer/figures/print.png
-share/doc/qt2/html/designer/figures/progress.png
-share/doc/qt2/html/designer/figures/pushbutton.png
-share/doc/qt2/html/designer/figures/qtlogo.png
-share/doc/qt2/html/designer/figures/radiobutton.png
-share/doc/qt2/html/designer/figures/redo.png
-share/doc/qt2/html/designer/figures/right.png
-share/doc/qt2/html/designer/figures/slider.png
-share/doc/qt2/html/designer/figures/slots.png
-share/doc/qt2/html/designer/figures/spacer.png
-share/doc/qt2/html/designer/figures/spinbox.png
-share/doc/qt2/html/designer/figures/startup.png
-share/doc/qt2/html/designer/figures/taborderform.png
-share/doc/qt2/html/designer/figures/tabwidget.png
-share/doc/qt2/html/designer/figures/testmode.png
-share/doc/qt2/html/designer/figures/textbrowser.png
-share/doc/qt2/html/designer/figures/textview.png
-share/doc/qt2/html/designer/figures/title.png
-share/doc/qt2/html/designer/figures/toolbutton.png
-share/doc/qt2/html/designer/figures/topicchooser.png
-share/doc/qt2/html/designer/figures/undo.png
-share/doc/qt2/html/designer/figures/vlayout.png
-share/doc/qt2/html/designer/figures/whatsthis.png
-share/doc/qt2/html/designer/part1index.html
-share/doc/qt2/html/designer/part2index.html
-share/doc/qt2/html/designer/preface.html
-share/qt2/designer/templates/Configuration_Dialog.ui
-share/qt2/designer/templates/Dialog_with_Buttons_(Bottom).ui
-share/qt2/designer/templates/Dialog_with_Buttons_(Right).ui
share/qt2/designer/templates/Tab-Dialog.ui
+share/qt2/designer/templates/Dialog_with_Buttons_(Right).ui
+share/qt2/designer/templates/Dialog_with_Buttons_(Bottom).ui
+share/qt2/designer/templates/Configuration_Dialog.ui
+share/doc/qt2/html/designer/preface.html
+share/doc/qt2/html/designer/part2index.html
+share/doc/qt2/html/designer/part1index.html
+share/doc/qt2/html/designer/figures/whatsthis.png
+share/doc/qt2/html/designer/figures/vlayout.png
+share/doc/qt2/html/designer/figures/undo.png
+share/doc/qt2/html/designer/figures/topicchooser.png
+share/doc/qt2/html/designer/figures/toolbutton.png
+share/doc/qt2/html/designer/figures/title.png
+share/doc/qt2/html/designer/figures/textview.png
+share/doc/qt2/html/designer/figures/textbrowser.png
+share/doc/qt2/html/designer/figures/testmode.png
+share/doc/qt2/html/designer/figures/tabwidget.png
+share/doc/qt2/html/designer/figures/taborderform.png
+share/doc/qt2/html/designer/figures/startup.png
+share/doc/qt2/html/designer/figures/spinbox.png
+share/doc/qt2/html/designer/figures/spacer.png
+share/doc/qt2/html/designer/figures/slots.png
+share/doc/qt2/html/designer/figures/slider.png
+share/doc/qt2/html/designer/figures/right.png
+share/doc/qt2/html/designer/figures/redo.png
+share/doc/qt2/html/designer/figures/radiobutton.png
+share/doc/qt2/html/designer/figures/qtlogo.png
+share/doc/qt2/html/designer/figures/pushbutton.png
+share/doc/qt2/html/designer/figures/progress.png
+share/doc/qt2/html/designer/figures/print.png
+share/doc/qt2/html/designer/figures/preferences.png
+share/doc/qt2/html/designer/figures/pointer.png
+share/doc/qt2/html/designer/figures/pizza1screenshot.png
+share/doc/qt2/html/designer/figures/pixlabel.png
+share/doc/qt2/html/designer/figures/paletteeditor.png
+share/doc/qt2/html/designer/figures/ordertool.png
+share/doc/qt2/html/designer/figures/onecheckbox.png
+share/doc/qt2/html/designer/figures/objecthierarchy.png
+share/doc/qt2/html/designer/figures/newformdialog.png
+share/doc/qt2/html/designer/figures/newform.png
+share/doc/qt2/html/designer/figures/multilineedit.png
+share/doc/qt2/html/designer/figures/load.png
+share/doc/qt2/html/designer/figures/listview.png
+share/doc/qt2/html/designer/figures/listbox.png
+share/doc/qt2/html/designer/figures/lineedit.png
+share/doc/qt2/html/designer/figures/line.png
+share/doc/qt2/html/designer/figures/left.png
+share/doc/qt2/html/designer/figures/lcdnumber.png
+share/doc/qt2/html/designer/figures/layouttutstep9.png
+share/doc/qt2/html/designer/figures/layouttutstep7.png
+share/doc/qt2/html/designer/figures/layouttutstep6.png
+share/doc/qt2/html/designer/figures/layouttutstep5.png
+share/doc/qt2/html/designer/figures/layouttutstep4.png
+share/doc/qt2/html/designer/figures/layouttutstep3.png
+share/doc/qt2/html/designer/figures/layouttutstep2.png
+share/doc/qt2/html/designer/figures/layouttutstep11.png
+share/doc/qt2/html/designer/figures/layouttutstep10.png
+share/doc/qt2/html/designer/figures/layouttutstep1.png
+share/doc/qt2/html/designer/figures/layout.png
+share/doc/qt2/html/designer/figures/label.png
+share/doc/qt2/html/designer/figures/image.png
+share/doc/qt2/html/designer/figures/iconview.png
+share/doc/qt2/html/designer/figures/home.png
+share/doc/qt2/html/designer/figures/helpdialog.png
+share/doc/qt2/html/designer/figures/help.png
+share/doc/qt2/html/designer/figures/groupbox.png
+share/doc/qt2/html/designer/figures/frame.png
+share/doc/qt2/html/designer/figures/fourcheckboxes.png
+share/doc/qt2/html/designer/figures/formsettings.png
+share/doc/qt2/html/designer/figures/form.png
+share/doc/qt2/html/designer/figures/firstdialog.png
+share/doc/qt2/html/designer/figures/filesave.png
+share/doc/qt2/html/designer/figures/filenew.png
+share/doc/qt2/html/designer/figures/f001.png
+share/doc/qt2/html/designer/figures/emptydialog.png
+share/doc/qt2/html/designer/figures/editslots.png
+share/doc/qt2/html/designer/figures/editraise.png
+share/doc/qt2/html/designer/figures/editpaste.png
+share/doc/qt2/html/designer/figures/editmultiline.png
+share/doc/qt2/html/designer/figures/editlower.png
+share/doc/qt2/html/designer/figures/editlistview.png
+share/doc/qt2/html/designer/figures/editlistbox.png
+share/doc/qt2/html/designer/figures/editiconview.png
+share/doc/qt2/html/designer/figures/edithlayout.png
+share/doc/qt2/html/designer/figures/editgrid.png
+share/doc/qt2/html/designer/figures/editdelete.png
+share/doc/qt2/html/designer/figures/editcut.png
+share/doc/qt2/html/designer/figures/editcustomwidgets.png
+share/doc/qt2/html/designer/figures/editcopy.png
+share/doc/qt2/html/designer/figures/customwidgets.png
+share/doc/qt2/html/designer/figures/customwidget.png
+share/doc/qt2/html/designer/figures/connecttool.png
+share/doc/qt2/html/designer/figures/connectionviewer.png
+share/doc/qt2/html/designer/figures/connections.png
+share/doc/qt2/html/designer/figures/connectionedit.png
+share/doc/qt2/html/designer/figures/combobox.png
+share/doc/qt2/html/designer/figures/checkbox.png
+share/doc/qt2/html/designer/figures/buttongroupovercheckboxes.png
+share/doc/qt2/html/designer/figures/buttongroup.png
+share/doc/qt2/html/designer/figures/breaklayout.png
+share/doc/qt2/html/designer/figures/adjustsize.png
+share/doc/qt2/html/designer/figures/aboutdialog.png
+share/doc/qt2/html/designer/feedback.html
+share/doc/qt2/html/designer/colophon.html
+share/doc/qt2/html/designer/chap9_6.html
+share/doc/qt2/html/designer/chap9_5.html
+share/doc/qt2/html/designer/chap9_4.html
+share/doc/qt2/html/designer/chap9_3.html
+share/doc/qt2/html/designer/chap9_2.html
+share/doc/qt2/html/designer/chap9_1.html
+share/doc/qt2/html/designer/chap8_1.html
+share/doc/qt2/html/designer/chap7_9.html
+share/doc/qt2/html/designer/chap7_8.html
+share/doc/qt2/html/designer/chap7_7.html
+share/doc/qt2/html/designer/chap7_6.html
+share/doc/qt2/html/designer/chap7_5.html
+share/doc/qt2/html/designer/chap7_4.html
+share/doc/qt2/html/designer/chap7_3.html
+share/doc/qt2/html/designer/chap7_2.html
+share/doc/qt2/html/designer/chap7_16.html
+share/doc/qt2/html/designer/chap7_15.html
+share/doc/qt2/html/designer/chap7_14.html
+share/doc/qt2/html/designer/chap7_13.html
+share/doc/qt2/html/designer/chap7_12.html
+share/doc/qt2/html/designer/chap7_11.html
+share/doc/qt2/html/designer/chap7_10.html
+share/doc/qt2/html/designer/chap7_1.html
+share/doc/qt2/html/designer/chap6_7.html
+share/doc/qt2/html/designer/chap6_6.html
+share/doc/qt2/html/designer/chap6_5.html
+share/doc/qt2/html/designer/chap6_4.html
+share/doc/qt2/html/designer/chap6_3.html
+share/doc/qt2/html/designer/chap6_2.html
+share/doc/qt2/html/designer/chap6_1.html
+share/doc/qt2/html/designer/chap5_6.html
+share/doc/qt2/html/designer/chap5_5.html
+share/doc/qt2/html/designer/chap5_4.html
+share/doc/qt2/html/designer/chap5_3.html
+share/doc/qt2/html/designer/chap5_2.html
+share/doc/qt2/html/designer/chap5_1.html
+share/doc/qt2/html/designer/chap4_2.html
+share/doc/qt2/html/designer/chap4_1.html
+share/doc/qt2/html/designer/chap3_4.html
+share/doc/qt2/html/designer/chap3_3.html
+share/doc/qt2/html/designer/chap3_2.html
+share/doc/qt2/html/designer/chap3_1.html
+share/doc/qt2/html/designer/chap2_4.html
+share/doc/qt2/html/designer/chap2_3.html
+share/doc/qt2/html/designer/chap2_2.html
+share/doc/qt2/html/designer/chap2_1.html
+share/doc/qt2/html/designer/chap1_1.html
+share/doc/qt2/html/designer/chap10_1.html
+share/doc/qt2/html/designer/book1.html
+share/doc/qt2/html/designer/arrows/up.png
+share/doc/qt2/html/designer/arrows/right.png
+share/doc/qt2/html/designer/arrows/left.png
+share/doc/qt2/html/designer/arrows/home.png
+bin/designer
+@dirrm share/qt2/designer/templates
+@dirrm share/qt2/designer
+@dirrm share/qt2
@dirrm share/doc/qt2/html/designer/figures
@dirrm share/doc/qt2/html/designer/arrows
@dirrm share/doc/qt2/html/designer
-@dirrm share/qt2/designer/templates
-@dirrm share/qt2/designer
-@unexec /sbin/rm -rf %D/share/doc/qt2/html 2>/dev/null || true
-@unexec /sbin/rm -rf %D/share/doc/qt2 2>/dev/null || true