aboutsummaryrefslogtreecommitdiff
path: root/devel/qt4-assistant-adp
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-04 23:30:38 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-04 23:30:38 +0000
commitd56984b0567867dd57ecb27fe0c508025c2426c5 (patch)
treeeb02dac4e0d7e5129ffac4c76b935a76a7e66676 /devel/qt4-assistant-adp
parent98813eadd27b8cd8500044af2a49b6d861809815 (diff)
- Update to qt 4.4.1
Note: With this update several ports specific problems have been fixed. Qt4 headers and libraries have been moved to include/qt4 and lib/qt4. bsd.qt.mk defines QT_INCDIR and QT_LIBDIR now, which could be used in qt4-dependent ports if required. Thanks to: Max Brazhnikov Danny Pansters
Notes
Notes: svn path=/head/; revision=218043
Diffstat (limited to 'devel/qt4-assistant-adp')
-rw-r--r--devel/qt4-assistant-adp/Makefile55
-rw-r--r--devel/qt4-assistant-adp/distinfo3
-rw-r--r--devel/qt4-assistant-adp/pkg-descr12
-rw-r--r--devel/qt4-assistant-adp/pkg-plist2
4 files changed, 72 insertions, 0 deletions
diff --git a/devel/qt4-assistant-adp/Makefile b/devel/qt4-assistant-adp/Makefile
new file mode 100644
index 000000000000..4ce95474d375
--- /dev/null
+++ b/devel/qt4-assistant-adp/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: qt40
+# Date created: Wed Jun 29 11:49:42 CEST 2005
+# Whom: lofi@freebsd.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= assistant
+PORTVERSION= ${QT4_VERSION}
+CATEGORIES?= devel
+MASTER_SITES= ${MASTER_SITE_QT}
+PKGNAMEPREFIX= qt4-
+PKGNAMESUFFIX= -adp
+DISTNAME= qt-x11-opensource-src-${PORTVERSION}
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt documentation browser, adp compat version
+
+USE_QT_VER= 4
+QT_COMPONENTS= qmake_build moc_build rcc_build uic_build corelib \
+ gui network xml doc dbus
+QT_NONSTANDARD= yes
+QT_DIST= yes
+
+HAS_CONFIGURE= yes
+
+ALL_TARGET= first
+CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
+MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib \
+ PATH=${WRKSRC}/bin:$$PATH
+
+DO_NOT_EXTRACT= demos doc examples mkspecs qmake translations \
+ src/opengl src/phonon \
+ src/qt3support src/script src/sql src/svg src/testlib \
+ src/tools src/xmlpatterns src/3rdparty/clucene \
+ src/3rdparty/kdebase src/3rdparty/kdelibs src/3rdparty/webkit
+EXTRACT_AFTER_ARGS= | ${TAR} -xf -
+.for dne in ${DO_NOT_EXTRACT}
+EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
+.endfor
+
+WRKSRC=${WRKDIR}/${DISTNAME}/tools/${PORTNAME}/compat
+CONFIGURE_WRKSRC=${WRKSRC}/../../../
+PATCH_WRKSRC=${CONFIGURE_WRKSRC}
+
+pre-configure:
+ ${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
+ ${MKDIR} ${WRKSRC}/../../../mkspecs
+ ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../../bin/qmake
+ ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/../../../bin/moc
+ ${LN} -sf ${LOCALBASE}/bin/uic-qt4 ${WRKSRC}/../../../bin/uic
+ ${LN} -sf ${LOCALBASE}/bin/rcc ${WRKSRC}/../../../bin/rcc
+
+.include <bsd.port.mk>
diff --git a/devel/qt4-assistant-adp/distinfo b/devel/qt4-assistant-adp/distinfo
new file mode 100644
index 000000000000..0c630f09baf6
--- /dev/null
+++ b/devel/qt4-assistant-adp/distinfo
@@ -0,0 +1,3 @@
+MD5 (KDE/qt-x11-opensource-src-4.4.1.tar.gz) = b09decad252b5181f300135e3122481d
+SHA256 (KDE/qt-x11-opensource-src-4.4.1.tar.gz) = 5aca7b784fc4de3db292666490ade84cfd1810f189c089c5c2810a710993f386
+SIZE (KDE/qt-x11-opensource-src-4.4.1.tar.gz) = 108774120
diff --git a/devel/qt4-assistant-adp/pkg-descr b/devel/qt4-assistant-adp/pkg-descr
new file mode 100644
index 000000000000..efc79b9aaf24
--- /dev/null
+++ b/devel/qt4-assistant-adp/pkg-descr
@@ -0,0 +1,12 @@
+Qt is a C++ toolkit for application development. It lets application
+developers target all major operating systems with a single application
+source code.
+
+Qt provides a platform-independent API to all central platform functionality:
+GUI, database access, networking, file handling, etc. The Qt library
+encapsulates the different APIs of different operating systems, providing
+the application programmer with a single, common API for all operating systems.
+The native C APIs are encapsulated in a set of well-designed, fully
+object-oriented C++ classes.
+
+WWW: http://www.trolltech.com/products/qt/index.html
diff --git a/devel/qt4-assistant-adp/pkg-plist b/devel/qt4-assistant-adp/pkg-plist
new file mode 100644
index 000000000000..8d78e0a63206
--- /dev/null
+++ b/devel/qt4-assistant-adp/pkg-plist
@@ -0,0 +1,2 @@
+bin/assistant_adp
+%%DEBUG%%bin/assistant_adp.debug