aboutsummaryrefslogtreecommitdiff
path: root/devel/qt4-assistant/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-12-02 19:47:17 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-12-02 19:47:17 +0000
commit43a46c6993b270c965c21db4fac822d938ec1475 (patch)
treeaf45a12b238a5ed25cadc0e0fb5a4984cacebafc /devel/qt4-assistant/Makefile
parentde0eaeceeccc6bcf986371e4c3367b326eac64a6 (diff)
downloadports-43a46c6993b270c965c21db4fac822d938ec1475.tar.gz
ports-43a46c6993b270c965c21db4fac822d938ec1475.zip
Notes
Diffstat (limited to 'devel/qt4-assistant/Makefile')
-rw-r--r--devel/qt4-assistant/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/devel/qt4-assistant/Makefile b/devel/qt4-assistant/Makefile
index df89e51b46b3..b4f6bc23e404 100644
--- a/devel/qt4-assistant/Makefile
+++ b/devel/qt4-assistant/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= assistant
-PORTVERSION= ${QT4_VERSION}
+DISTVERSION= ${QT4_VERSION}
CATEGORIES?= devel
PKGNAMEPREFIX= qt4-
@@ -32,7 +32,7 @@ DO_NOT_EXTRACT= demos doc examples mkspecs qmake translations \
src/activeqt src/dbus src/multimedia src/opengl src/openvg \
src/phonon src/qt3support src/s60installs src/s60main \
src/script src/scripttools src/svg src/testlib src/tools \
- src/winmain src/xml src/xmlpatterns src/3rdparty/clucene \
+ src/winmain src/xmlpatterns src/3rdparty/clucene \
src/3rdparty/freetype src/3rdparty/libjpeg src/3rdparty/libmng \
src/3rdparty/libpng src/3rdparty/libtiff src/3rdparty/phonon
EXTRACT_AFTER_ARGS= | ${TAR} -xf -
@@ -49,7 +49,7 @@ pre-configure:
${REINPLACE_CMD} \
-e 's|^TARGET.*|TARGET=assistant-qt4|g' \
${BUILD_WRKSRC}/${PORTNAME}.pro
- ${MKDIR} ${WRKSRC}/mkspecs
+ ${MKDIR} ${WRKSRC}/mkspecs/modules
${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/bin/qmake
${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/bin/moc
${LN} -sf ${LOCALBASE}/bin/uic-qt4 ${WRKSRC}/bin/uic