aboutsummaryrefslogtreecommitdiff
path: root/devel/qt4-corelib
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2007-02-05 20:56:24 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2007-02-05 20:56:24 +0000
commit74cb0fb1e88e05ac2dc49f1aa7274c98a470a7c8 (patch)
tree5a2cd52714027788ca840d18e6087ab373c335b4 /devel/qt4-corelib
parent9650cc958392c895ef613d1abea30ed3510adffd (diff)
downloadports-74cb0fb1e88e05ac2dc49f1aa7274c98a470a7c8.tar.gz
ports-74cb0fb1e88e05ac2dc49f1aa7274c98a470a7c8.zip
Notes
Diffstat (limited to 'devel/qt4-corelib')
-rw-r--r--devel/qt4-corelib/Makefile87
-rw-r--r--devel/qt4-corelib/distinfo3
-rw-r--r--devel/qt4-corelib/pkg-descr12
-rw-r--r--devel/qt4-corelib/pkg-plist415
4 files changed, 517 insertions, 0 deletions
diff --git a/devel/qt4-corelib/Makefile b/devel/qt4-corelib/Makefile
new file mode 100644
index 000000000000..8933c729a5d5
--- /dev/null
+++ b/devel/qt4-corelib/Makefile
@@ -0,0 +1,87 @@
+# -*-mode: makefile-*-
+# New ports collection makefile for: qt40
+# Date created: Wed Jun 29 11:49:42 CEST 2005
+# Whom: lofi@freebsd.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= corelib
+PORTVERSION= 4.2.2
+CATEGORIES?= devel
+MASTER_SITES= ${MASTER_SITE_QT}
+PKGNAMEPREFIX= qt4-
+DISTNAME= qt-x11-opensource-src-${PORTVERSION}
+DIST_SUBDIR= KDE
+
+MAINTAINER?= kde@FreeBSD.org
+COMMENT?= Qt core library
+
+BUILD_DEPENDS= moc4:${PORTSDIR}/devel/qt4-moc \
+ qmake-qt4:${PORTSDIR}/devel/qmake4
+LIB_DEPENDS= glib-2.0:${PORTSDIR}/devel/glib20
+
+CONFLICTS= linguist-0.* qt-2.* qt-3.0.* \
+ qt-3.1.* qt-3.2.* qt-designer-2.* xfmail-1.5.[0-5] \
+ xfmail-1.5.5_[1-2]
+
+HAS_CONFIGURE= yes
+USE_LDCONFIG= yes
+NO_FILTER_SHLIBS=yes
+
+CONFIGURE_ARGS= -fast -no-exceptions \
+ -platform ${LOCALBASE}/share/qt4/mkspecs/freebsd-g++ \
+ -qt-gif -release -system-libjpeg -system-libpng \
+ -system-zlib -no-nas-sound -confirm-license \
+ -prefix ${PREFIX} \
+ -docdir ${PREFIX}/share/doc/qt4 \
+ -headerdir ${PREFIX}/include \
+ -plugindir ${PREFIX}/lib/plugins \
+ -datadir ${PREFIX}/share/qt4 \
+ -libdir ${PREFIX}/lib \
+ -translationdir ${PREFIX}/share/qt4/translations \
+ -sysconfdir ${PREFIX}/local/etc/xdg \
+ -examplesdir ${PREFIX}/share/qt4/examples \
+ -demosdir ${PREFIX}/share/qt4/demos \
+ -bindir ${PREFIX}/bin
+
+ALL_TARGET= first
+CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
+MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib \
+ PATH=${WRKSRC}/bin:$$PATH
+EXTRACT_AFTER_ARGS=| ${TAR} -xf - \
+ --exclude '${DISTNAME}/mkspecs' --exclude '${DISTNAME}/qmake' \
+ --exclude '${DISTNAME}/demos' --exclude '${DISTNAME}/examples' \
+ --exclude '${DISTNAME}/src/gui' --exclude '${DISTNAME}/src/network' \
+ --exclude '${DISTNAME}/src/opengl' --exclude '${DISTNAME}/src/qt3support' \
+ --exclude '${DISTNAME}/src/sql' --exclude '${DISTNAME}/src/xml' \
+ --exclude '${DISTNAME}/src/tools/moc' --exclude '${DISTNAME}/src/tools/rcc' \
+ --exclude '${DISTNAME}/src/tools/uic' --exclude '${DISTNAME}/src/tools/uic3' \
+ --exclude '${DISTNAME}/tools/assistant' --exclude '${DISTNAME}/tools/designer' \
+ --exclude '${DISTNAME}/tools/linguist' --exclude '${DISTNAME}/tools/porting' \
+ --exclude '${DISTNAME}/tools/qtconfig' --exclude '${DISTNAME}/tools/qvfb'
+WRKSRC= ${WRKDIR}/${DISTNAME}/src/${PORTNAME}
+CONFIGURE_WRKSRC=${WRKSRC}/../../
+
+.include <bsd.port.pre.mk>
+
+pre-configure:
+ ${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
+ ${REINPLACE_CMD} -e 's|target.path.*|target.path=${PREFIX}/lib|g' \
+ -e 's|flat_headers.path.*|flat_headers.path=${PREFIX}/include/Qt|g' \
+ -e 's|targ_headers.path.*|targ_headers.path=${PREFIX}/include/$$$$TARGET|g' \
+ ${WRKSRC}/${PORTNAME}.pro ${WRKSRC}/../qt_install.pri
+ ${MKDIR} ${WRKSRC}/../../mkspecs
+ ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../bin/qmake
+ ${LN} -sf ${LOCALBASE}/bin/moc4 ${WRKSRC}/../../bin/moc
+post-configure:
+ ${REINPLACE_CMD} -e 's|local/lib/QtCore.pc|local/libdata/QtCore.pc|g' \
+ ${WRKSRC}/Makefile
+
+.if !defined(PKGNAMESUFFIX)
+post-install:
+ ${MKDIR} ${PREFIX}/lib/plugins
+ touch ${PREFIX}/lib/plugins/.keep_me
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/qt4-corelib/distinfo b/devel/qt4-corelib/distinfo
new file mode 100644
index 000000000000..5f51cf7b1256
--- /dev/null
+++ b/devel/qt4-corelib/distinfo
@@ -0,0 +1,3 @@
+MD5 (KDE/qt-x11-opensource-src-4.2.2.tar.gz) = 19f6374fe7924e33775cb87ee02669cb
+SHA256 (KDE/qt-x11-opensource-src-4.2.2.tar.gz) = e790d227fa7958f2b0c0b0facd8ca880190121ed2b9c99ca70643baf7a0cd24c
+SIZE (KDE/qt-x11-opensource-src-4.2.2.tar.gz) = 37636491
diff --git a/devel/qt4-corelib/pkg-descr b/devel/qt4-corelib/pkg-descr
new file mode 100644
index 000000000000..efc79b9aaf24
--- /dev/null
+++ b/devel/qt4-corelib/pkg-descr
@@ -0,0 +1,12 @@
+Qt is a C++ toolkit for application development. It lets application
+developers target all major operating systems with a single application
+source code.
+
+Qt provides a platform-independent API to all central platform functionality:
+GUI, database access, networking, file handling, etc. The Qt library
+encapsulates the different APIs of different operating systems, providing
+the application programmer with a single, common API for all operating systems.
+The native C APIs are encapsulated in a set of well-designed, fully
+object-oriented C++ classes.
+
+WWW: http://www.trolltech.com/products/qt/index.html
diff --git a/devel/qt4-corelib/pkg-plist b/devel/qt4-corelib/pkg-plist
new file mode 100644
index 000000000000..ca1d9e65ca7f
--- /dev/null
+++ b/devel/qt4-corelib/pkg-plist
@@ -0,0 +1,415 @@
+include/Qt/QtCore
+include/Qt/qabstracteventdispatcher.h
+include/Qt/qabstractfileengine.h
+include/Qt/qabstractitemmodel.h
+include/Qt/qalgorithms.h
+include/Qt/qatomic.h
+include/Qt/qatomic_alpha.h
+include/Qt/qatomic_arch.h
+include/Qt/qatomic_arm.h
+include/Qt/qatomic_boundschecker.h
+include/Qt/qatomic_generic.h
+include/Qt/qatomic_i386.h
+include/Qt/qatomic_ia64.h
+include/Qt/qatomic_mips.h
+include/Qt/qatomic_parisc.h
+include/Qt/qatomic_powerpc.h
+include/Qt/qatomic_s390.h
+include/Qt/qatomic_sparc.h
+include/Qt/qatomic_x86_64.h
+include/Qt/qbasictimer.h
+include/Qt/qbitarray.h
+include/Qt/qbuffer.h
+include/Qt/qbytearray.h
+include/Qt/qbytearraymatcher.h
+include/Qt/qcache.h
+include/Qt/qchar.h
+include/Qt/qconfig-dist.h
+include/Qt/qconfig-large.h
+include/Qt/qconfig-medium.h
+include/Qt/qconfig-minimal.h
+include/Qt/qconfig-small.h
+include/Qt/qconfig.h
+include/Qt/qcontainerfwd.h
+include/Qt/qcoreapplication.h
+include/Qt/qcoreevent.h
+include/Qt/qdatastream.h
+include/Qt/qdatetime.h
+include/Qt/qdebug.h
+include/Qt/qdir.h
+include/Qt/qendian.h
+include/Qt/qeventloop.h
+include/Qt/qfactoryinterface.h
+include/Qt/qfeatures.h
+include/Qt/qfile.h
+include/Qt/qfileinfo.h
+include/Qt/qfilesystemwatcher.h
+include/Qt/qfsfileengine.h
+include/Qt/qglobal.h
+include/Qt/qhash.h
+include/Qt/qiodevice.h
+include/Qt/qiterator.h
+include/Qt/qlibrary.h
+include/Qt/qlibraryinfo.h
+include/Qt/qline.h
+include/Qt/qlinkedlist.h
+include/Qt/qlist.h
+include/Qt/qlocale.h
+include/Qt/qmap.h
+include/Qt/qmetaobject.h
+include/Qt/qmetatype.h
+include/Qt/qmimedata.h
+include/Qt/qmutex.h
+include/Qt/qnamespace.h
+include/Qt/qobject.h
+include/Qt/qobjectcleanuphandler.h
+include/Qt/qobjectdefs.h
+include/Qt/qpair.h
+include/Qt/qplugin.h
+include/Qt/qpluginloader.h
+include/Qt/qpoint.h
+include/Qt/qpointer.h
+include/Qt/qprocess.h
+include/Qt/qqueue.h
+include/Qt/qreadwritelock.h
+include/Qt/qrect.h
+include/Qt/qregexp.h
+include/Qt/qresource.h
+include/Qt/qsemaphore.h
+include/Qt/qset.h
+include/Qt/qsettings.h
+include/Qt/qshareddata.h
+include/Qt/qsignalmapper.h
+include/Qt/qsize.h
+include/Qt/qsocketnotifier.h
+include/Qt/qstack.h
+include/Qt/qstring.h
+include/Qt/qstringlist.h
+include/Qt/qstringmatcher.h
+include/Qt/qtemporaryfile.h
+include/Qt/qtextcodec.h
+include/Qt/qtextcodecplugin.h
+include/Qt/qtextstream.h
+include/Qt/qthread.h
+include/Qt/qthreadstorage.h
+include/Qt/qtimeline.h
+include/Qt/qtimer.h
+include/Qt/qtranslator.h
+include/Qt/qurl.h
+include/Qt/quuid.h
+include/Qt/qvariant.h
+include/Qt/qvarlengtharray.h
+include/Qt/qvector.h
+include/Qt/qwaitcondition.h
+include/QtCore/QAbstractEventDispatcher
+include/QtCore/QAbstractFileEngine
+include/QtCore/QAbstractFileEngineHandler
+include/QtCore/QAbstractItemModel
+include/QtCore/QAbstractListModel
+include/QtCore/QAbstractTableModel
+include/QtCore/QArgument
+include/QtCore/QAtomic
+include/QtCore/QAtomicPointer
+include/QtCore/QBasicAtomic
+include/QtCore/QBasicAtomicPointer
+include/QtCore/QBasicTimer
+include/QtCore/QBitArray
+include/QtCore/QBitRef
+include/QtCore/QBool
+include/QtCore/QBuffer
+include/QtCore/QByteArray
+include/QtCore/QByteArrayMatcher
+include/QtCore/QByteRef
+include/QtCore/QCOORD
+include/QtCore/QCache
+include/QtCore/QChar
+include/QtCore/QCharRef
+include/QtCore/QChildEvent
+include/QtCore/QConstString
+include/QtCore/QCoreApplication
+include/QtCore/QCustomEvent
+include/QtCore/QDataStream
+include/QtCore/QDate
+include/QtCore/QDateTime
+include/QtCore/QDebug
+include/QtCore/QDir
+include/QtCore/QDynamicPropertyChangeEvent
+include/QtCore/QEvent
+include/QtCore/QEventLoop
+include/QtCore/QFSFileEngine
+include/QtCore/QFactoryInterface
+include/QtCore/QFile
+include/QtCore/QFileInfo
+include/QtCore/QFileInfoList
+include/QtCore/QFileInfoListIterator
+include/QtCore/QFileSystemWatcher
+include/QtCore/QFlag
+include/QtCore/QFlags
+include/QtCore/QForeachContainer
+include/QtCore/QForeachContainerBase
+include/QtCore/QGenericArgument
+include/QtCore/QGenericReturnArgument
+include/QtCore/QGlobalStatic
+include/QtCore/QHash
+include/QtCore/QHashData
+include/QtCore/QHashDummyNode
+include/QtCore/QHashDummyValue
+include/QtCore/QHashIterator
+include/QtCore/QHashNode
+include/QtCore/QIODevice
+include/QtCore/QIntForSize
+include/QtCore/QIntForType
+include/QtCore/QInternal
+include/QtCore/QLatin1Char
+include/QtCore/QLatin1String
+include/QtCore/QLibrary
+include/QtCore/QLibraryInfo
+include/QtCore/QLine
+include/QtCore/QLineF
+include/QtCore/QLinkedList
+include/QtCore/QLinkedListData
+include/QtCore/QLinkedListIterator
+include/QtCore/QLinkedListNode
+include/QtCore/QList
+include/QtCore/QListData
+include/QtCore/QListIterator
+include/QtCore/QLocale
+include/QtCore/QMap
+include/QtCore/QMapData
+include/QtCore/QMapIterator
+include/QtCore/QMetaClassInfo
+include/QtCore/QMetaEnum
+include/QtCore/QMetaMethod
+include/QtCore/QMetaObject
+include/QtCore/QMetaProperty
+include/QtCore/QMetaType
+include/QtCore/QMetaTypeId
+include/QtCore/QMetaTypeId2
+include/QtCore/QMimeData
+include/QtCore/QModelIndex
+include/QtCore/QModelIndexList
+include/QtCore/QMultiHash
+include/QtCore/QMultiMap
+include/QtCore/QMutableHashIterator
+include/QtCore/QMutableLinkedListIterator
+include/QtCore/QMutableListIterator
+include/QtCore/QMutableMapIterator
+include/QtCore/QMutableSetIterator
+include/QtCore/QMutableStringListIterator
+include/QtCore/QMutableVectorIterator
+include/QtCore/QMutex
+include/QtCore/QMutexLocker
+include/QtCore/QNoDebug
+include/QtCore/QNoImplicitBoolCast
+include/QtCore/QObject
+include/QtCore/QObjectCleanupHandler
+include/QtCore/QObjectData
+include/QtCore/QObjectList
+include/QtCore/QObjectUserData
+include/QtCore/QPair
+include/QtCore/QPersistentModelIndex
+include/QtCore/QPluginLoader
+include/QtCore/QPoint
+include/QtCore/QPointF
+include/QtCore/QPointer
+include/QtCore/QProcess
+include/QtCore/QQueue
+include/QtCore/QReadLocker
+include/QtCore/QReadWriteLock
+include/QtCore/QRect
+include/QtCore/QRectF
+include/QtCore/QRegExp
+include/QtCore/QResource
+include/QtCore/QReturnArgument
+include/QtCore/QSemaphore
+include/QtCore/QSet
+include/QtCore/QSetIterator
+include/QtCore/QSettings
+include/QtCore/QSharedData
+include/QtCore/QSharedDataPointer
+include/QtCore/QSignalMapper
+include/QtCore/QSize
+include/QtCore/QSizeF
+include/QtCore/QSocketNotifier
+include/QtCore/QStack
+include/QtCore/QStdWString
+include/QtCore/QString
+include/QtCore/QStringList
+include/QtCore/QStringListIterator
+include/QtCore/QStringMatcher
+include/QtCore/QSysInfo
+include/QtCore/QSystemLocale
+include/QtCore/QTS
+include/QtCore/QTemporaryFile
+include/QtCore/QTextCodec
+include/QtCore/QTextCodecFactoryInterface
+include/QtCore/QTextCodecPlugin
+include/QtCore/QTextDecoder
+include/QtCore/QTextEncoder
+include/QtCore/QTextIStream
+include/QtCore/QTextOStream
+include/QtCore/QTextStream
+include/QtCore/QTextStreamFunction
+include/QtCore/QTextStreamManipulator
+include/QtCore/QThread
+include/QtCore/QThreadStorage
+include/QtCore/QThreadStorageData
+include/QtCore/QTime
+include/QtCore/QTimeLine
+include/QtCore/QTimer
+include/QtCore/QTimerEvent
+include/QtCore/QTranslator
+include/QtCore/QTypeInfo
+include/QtCore/QUintForSize
+include/QtCore/QUintForType
+include/QtCore/QUrl
+include/QtCore/QUuid
+include/QtCore/QVarLengthArray
+include/QtCore/QVariant
+include/QtCore/QVariantComparisonHelper
+include/QtCore/QVariantList
+include/QtCore/QVariantMap
+include/QtCore/QVector
+include/QtCore/QVectorData
+include/QtCore/QVectorIterator
+include/QtCore/QVectorTypedData
+include/QtCore/QWaitCondition
+include/QtCore/QWriteLocker
+include/QtCore/Q_INT16
+include/QtCore/Q_INT32
+include/QtCore/Q_INT64
+include/QtCore/Q_INT8
+include/QtCore/Q_LLONG
+include/QtCore/Q_LONG
+include/QtCore/Q_PID
+include/QtCore/Q_UINT16
+include/QtCore/Q_UINT32
+include/QtCore/Q_UINT64
+include/QtCore/Q_UINT8
+include/QtCore/Q_ULLONG
+include/QtCore/Q_ULONG
+include/QtCore/Qt
+include/QtCore/QtAlgorithms
+include/QtCore/QtCleanUpFunction
+include/QtCore/QtContainerFwd
+include/QtCore/QtCore
+include/QtCore/QtDebug
+include/QtCore/QtEndian
+include/QtCore/QtGlobal
+include/QtCore/QtMsgHandler
+include/QtCore/QtPlugin
+include/QtCore/QtPluginInstanceFunction
+include/QtCore/qabstracteventdispatcher.h
+include/QtCore/qabstractfileengine.h
+include/QtCore/qabstractitemmodel.h
+include/QtCore/qalgorithms.h
+include/QtCore/qatomic.h
+include/QtCore/qatomic_alpha.h
+include/QtCore/qatomic_arch.h
+include/QtCore/qatomic_arm.h
+include/QtCore/qatomic_boundschecker.h
+include/QtCore/qatomic_generic.h
+include/QtCore/qatomic_i386.h
+include/QtCore/qatomic_ia64.h
+include/QtCore/qatomic_mips.h
+include/QtCore/qatomic_parisc.h
+include/QtCore/qatomic_powerpc.h
+include/QtCore/qatomic_s390.h
+include/QtCore/qatomic_sparc.h
+include/QtCore/qatomic_x86_64.h
+include/QtCore/qbasictimer.h
+include/QtCore/qbitarray.h
+include/QtCore/qbuffer.h
+include/QtCore/qbytearray.h
+include/QtCore/qbytearraymatcher.h
+include/QtCore/qcache.h
+include/QtCore/qchar.h
+include/QtCore/qconfig-dist.h
+include/QtCore/qconfig-large.h
+include/QtCore/qconfig-medium.h
+include/QtCore/qconfig-minimal.h
+include/QtCore/qconfig-small.h
+include/QtCore/qconfig.h
+include/QtCore/qcontainerfwd.h
+include/QtCore/qcoreapplication.h
+include/QtCore/qcoreevent.h
+include/QtCore/qdatastream.h
+include/QtCore/qdatetime.h
+include/QtCore/qdebug.h
+include/QtCore/qdir.h
+include/QtCore/qendian.h
+include/QtCore/qeventloop.h
+include/QtCore/qfactoryinterface.h
+include/QtCore/qfeatures.h
+include/QtCore/qfile.h
+include/QtCore/qfileinfo.h
+include/QtCore/qfilesystemwatcher.h
+include/QtCore/qfsfileengine.h
+include/QtCore/qglobal.h
+include/QtCore/qhash.h
+include/QtCore/qiodevice.h
+include/QtCore/qiterator.h
+include/QtCore/qlibrary.h
+include/QtCore/qlibraryinfo.h
+include/QtCore/qline.h
+include/QtCore/qlinkedlist.h
+include/QtCore/qlist.h
+include/QtCore/qlocale.h
+include/QtCore/qmap.h
+include/QtCore/qmetaobject.h
+include/QtCore/qmetatype.h
+include/QtCore/qmimedata.h
+include/QtCore/qmutex.h
+include/QtCore/qnamespace.h
+include/QtCore/qobject.h
+include/QtCore/qobjectcleanuphandler.h
+include/QtCore/qobjectdefs.h
+include/QtCore/qpair.h
+include/QtCore/qplugin.h
+include/QtCore/qpluginloader.h
+include/QtCore/qpoint.h
+include/QtCore/qpointer.h
+include/QtCore/qprocess.h
+include/QtCore/qqueue.h
+include/QtCore/qreadwritelock.h
+include/QtCore/qrect.h
+include/QtCore/qregexp.h
+include/QtCore/qresource.h
+include/QtCore/qsemaphore.h
+include/QtCore/qset.h
+include/QtCore/qsettings.h
+include/QtCore/qshareddata.h
+include/QtCore/qsignalmapper.h
+include/QtCore/qsize.h
+include/QtCore/qsocketnotifier.h
+include/QtCore/qstack.h
+include/QtCore/qstring.h
+include/QtCore/qstringlist.h
+include/QtCore/qstringmatcher.h
+include/QtCore/qtemporaryfile.h
+include/QtCore/qtextcodec.h
+include/QtCore/qtextcodecplugin.h
+include/QtCore/qtextstream.h
+include/QtCore/qthread.h
+include/QtCore/qthreadstorage.h
+include/QtCore/qtimeline.h
+include/QtCore/qtimer.h
+include/QtCore/qtranslator.h
+include/QtCore/qurl.h
+include/QtCore/quuid.h
+include/QtCore/qvariant.h
+include/QtCore/qvarlengtharray.h
+include/QtCore/qvector.h
+include/QtCore/qwaitcondition.h
+lib/libQtCore.la
+lib/libQtCore.prl
+lib/libQtCore.so
+lib/libQtCore.so.4
+lib/libQtCore.so.4.2
+lib/libQtCore.so.4.2.2
+lib/libQtCore.so.4.2.2.debug
+lib/plugins/.keep_me
+libdata/QtCore.pc
+@dirrm lib/plugins
+@dirrm include/QtCore
+@dirrm include/Qt