aboutsummaryrefslogtreecommitdiff
path: root/devel/qt4-corelib
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2007-07-16 10:12:15 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2007-07-16 10:12:15 +0000
commit8bd00266dc1b89a8a7a9d6170d1d895ef285c905 (patch)
tree78e6b0d3b242b999541f0e267c681933f7c9bc9d /devel/qt4-corelib
parentd35a45eeb49c097657f16ba58ccbdf86bc3a59b4 (diff)
downloadports-8bd00266dc1b89a8a7a9d6170d1d895ef285c905.tar.gz
ports-8bd00266dc1b89a8a7a9d6170d1d895ef285c905.zip
Notes
Diffstat (limited to 'devel/qt4-corelib')
-rw-r--r--devel/qt4-corelib/Makefile43
-rw-r--r--devel/qt4-corelib/distinfo6
-rw-r--r--devel/qt4-corelib/files/patch-qlocale_workaround_patch.txt11
-rw-r--r--devel/qt4-corelib/files/patch-utf8-bug-qt4132
-rw-r--r--devel/qt4-corelib/pkg-plist17
5 files changed, 30 insertions, 179 deletions
diff --git a/devel/qt4-corelib/Makefile b/devel/qt4-corelib/Makefile
index 769cd8c31740..598a7b9581b7 100644
--- a/devel/qt4-corelib/Makefile
+++ b/devel/qt4-corelib/Makefile
@@ -7,44 +7,27 @@
#
PORTNAME= corelib
-PORTVERSION= 4.2.3
-PORTREVISION= 3
+PORTVERSION= ${QT4_VERSION}
+PORTREVISION=0
CATEGORIES?= devel
MASTER_SITES= ${MASTER_SITE_QT}
PKGNAMEPREFIX= qt4-
DISTNAME= qt-x11-opensource-src-${PORTVERSION}
DIST_SUBDIR= KDE
-MAINTAINER?= kde@FreeBSD.org
-COMMENT?= Qt core library
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt core library
-BUILD_DEPENDS= moc-qt4:${PORTSDIR}/devel/qt4-moc \
- qmake-qt4:${PORTSDIR}/devel/qmake4
LIB_DEPENDS= glib-2.0:${PORTSDIR}/devel/glib20
-CONFLICTS= linguist-0.* qt-2.* qt-3.0.* \
- qt-3.1.* qt-3.2.* qt-designer-2.* xfmail-1.5.[0-5] \
- xfmail-1.5.5_[1-2]
+USE_QT_VER= 4
+QT_COMPONENTS= qmake moc
+QT_NONSTANDARD= yes
+QT_DIST= yes
HAS_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFIGURE_ARGS= -fast -no-exceptions \
- -platform ${LOCALBASE}/share/qt4/mkspecs/freebsd-g++ \
- -qt-gif -release -system-libjpeg -system-libpng \
- -system-zlib -no-nas-sound -confirm-license \
- -prefix ${PREFIX} \
- -docdir ${PREFIX}/share/doc/qt4 \
- -headerdir ${PREFIX}/include \
- -plugindir ${PREFIX}/lib/plugins \
- -datadir ${PREFIX}/share/qt4 \
- -libdir ${PREFIX}/lib \
- -translationdir ${PREFIX}/share/qt4/translations \
- -sysconfdir ${PREFIX}/local/etc/xdg \
- -examplesdir ${PREFIX}/share/qt4/examples \
- -demosdir ${PREFIX}/share/qt4/demos \
- -bindir ${PREFIX}/bin
-
ALL_TARGET= first
CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib \
@@ -67,7 +50,7 @@ PATCH_WRKSRC=${WRKSRC}/../../
.include <bsd.port.pre.mk>
pre-configure:
- ${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
+ ${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
${REINPLACE_CMD} -e 's|target.path.*|target.path=${PREFIX}/lib|g' \
-e 's|flat_headers.path.*|flat_headers.path=${PREFIX}/include/Qt|g' \
-e 's|targ_headers.path.*|targ_headers.path=${PREFIX}/include/$$$$TARGET|g' \
@@ -76,17 +59,17 @@ pre-configure:
${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../bin/qmake
${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/../../bin/moc
post-configure:
- ${REINPLACE_CMD} -e 's|${PREFIX}/lib/QtCore.pc|${PREFIX}/libdata/pkgconfig/QtCore.pc|g' \
- ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|${PREFIX}/lib/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
+ -e 's|.*$$(QMAKE).*||g' -e 's|(test -z.*||g' ${WRKSRC}/Makefile
${REINPLACE_CMD} -E -e 's|-L.[^[:space:]]*qt-x11-opensource.[^[:space:]]*lib||g' \
-E -e 's|(.*location=).*moc|\1${PREFIX}/bin/moc-qt4|g' \
-E -e 's|(.*location=).*uic|\1${PREFIX}/bin/uic-qt4|g' \
- ${WRKSRC}/../../lib/*Qt*
+ ${WRKSRC}/../../lib/pkgconfig/*Qt*
.if !defined(PKGNAMESUFFIX)
post-install:
${MKDIR} ${PREFIX}/lib/plugins
- touch ${PREFIX}/lib/plugins/.keep_me
+ ${TOUCH} ${PREFIX}/lib/plugins/.keep_me
.endif
.include <bsd.port.post.mk>
diff --git a/devel/qt4-corelib/distinfo b/devel/qt4-corelib/distinfo
index 48b91bd5d5e3..8fb631a2787d 100644
--- a/devel/qt4-corelib/distinfo
+++ b/devel/qt4-corelib/distinfo
@@ -1,3 +1,3 @@
-MD5 (KDE/qt-x11-opensource-src-4.2.3.tar.gz) = 13f12bf58a32ebf15837fcd605cb3c99
-SHA256 (KDE/qt-x11-opensource-src-4.2.3.tar.gz) = c163e72cb002435d1d261a47acdcb23e59c10e4263f983a5f2c2d2ca40ede75b
-SIZE (KDE/qt-x11-opensource-src-4.2.3.tar.gz) = 37635710
+MD5 (KDE/qt-x11-opensource-src-4.3.0.tar.gz) = 8012acea71b35c18247bd92c4721589d
+SHA256 (KDE/qt-x11-opensource-src-4.3.0.tar.gz) = abc37774d327a9b1d1d35e223f014c7e92168cd6c7baf66156badca68f8f1440
+SIZE (KDE/qt-x11-opensource-src-4.3.0.tar.gz) = 41955515
diff --git a/devel/qt4-corelib/files/patch-qlocale_workaround_patch.txt b/devel/qt4-corelib/files/patch-qlocale_workaround_patch.txt
deleted file mode 100644
index 2f93298794c9..000000000000
--- a/devel/qt4-corelib/files/patch-qlocale_workaround_patch.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/corelib/tools/qlocale.cpp
-+++ src/corelib/tools/qlocale.cpp
-@@ -44,7 +44,7 @@
-
- #if !defined(QT_QLOCALE_NEEDS_VOLATILE)
- # if defined(Q_CC_GNU)
--# if __GNUC__ == 4 && __GNUC_MINOR__ == 0
-+# if __GNUC__ == 4
- # define QT_QLOCALE_NEEDS_VOLATILE
- # elif defined(Q_OS_WIN)
- # define QT_QLOCALE_NEEDS_VOLATILE
diff --git a/devel/qt4-corelib/files/patch-utf8-bug-qt4 b/devel/qt4-corelib/files/patch-utf8-bug-qt4
deleted file mode 100644
index 4b7ee9c81401..000000000000
--- a/devel/qt4-corelib/files/patch-utf8-bug-qt4
+++ /dev/null
@@ -1,132 +0,0 @@
---- src/corelib/tools/qstring.cpp
-+++ src/corelib/tools/qstring.cpp
-@@ -3342,6 +3342,7 @@ QString QString::fromUtf8(const char *st
- result.resize(size); // worst case
- ushort *qch = result.d->data;
- uint uc = 0;
-+ uint min_uc = 0;
- int need = 0;
- int error = -1;
- uchar ch;
-@@ -3359,6 +3360,12 @@ QString QString::fromUtf8(const char *st
- ushort low = uc%0x400 + 0xdc00;
- *qch++ = high;
- *qch++ = low;
-+ } else if ((uc < min_uc) || (uc >= 0xd800 && uc <= 0xdfff) || (uc >= 0xfffe)) {
-+ // overlong seqence, UTF16 surrogate or BOM
-+ i = error;
-+ qch = addOne(qch, result);
-+ *qch++ = 0xdbff;
-+ *qch++ = 0xde00 + ((uchar)str[i]);
- } else {
- *qch++ = uc;
- }
-@@ -3381,14 +3388,17 @@ QString QString::fromUtf8(const char *st
- uc = ch & 0x1f;
- need = 1;
- error = i;
-+ min_uc = 0x80;
- } else if ((ch & 0xf0) == 0xe0) {
- uc = ch & 0x0f;
- need = 2;
- error = i;
-+ min_uc = 0x800;
- } else if ((ch&0xf8) == 0xf0) {
- uc = ch & 0x07;
- need = 3;
- error = i;
-+ min_uc = 0x10000;
- } else {
- // Error
- qch = addOne(qch, result);
---- src/corelib/codecs/qutfcodec.cpp
-+++ src/corelib/codecs/qutfcodec.cpp
-@@ -117,15 +117,19 @@ QString QUtf8Codec::convertToUnicode(con
- bool headerdone = false;
- QChar replacement = QChar::ReplacementCharacter;
- int need = 0;
-+ int error = -1;
- uint uc = 0;
-+ uint min_uc = 0;
- if (state) {
- if (state->flags & IgnoreHeader)
- headerdone = true;
- if (state->flags & ConvertInvalidToNull)
- replacement = QChar::Null;
- need = state->remainingChars;
-- if (need)
-+ if (need) {
- uc = state->state_data[0];
-+ min_uc = state->state_data[1];
-+ }
- }
- if (!headerdone && len > 3
- && (uchar)chars[0] == 0xef && (uchar)chars[1] == 0xbb && (uchar)chars[2] == 0xbf) {
-@@ -142,7 +146,7 @@ QString QUtf8Codec::convertToUnicode(con
- int invalid = 0;
-
- for (int i=0; i<len; i++) {
-- ch = *chars++;
-+ ch = chars[i];
- if (need) {
- if ((ch&0xc0) == 0x80) {
- uc = (uc << 6) | (ch & 0x3f);
-@@ -153,14 +157,27 @@ QString QUtf8Codec::convertToUnicode(con
- uc -= 0x10000;
- unsigned short high = uc/0x400 + 0xd800;
- unsigned short low = uc%0x400 + 0xdc00;
-+
-+ // resize if necessary
-+ long where = qch - result.unicode();
-+ if (where + 2 >= result.size()) {
-+ result.resize(where + 2);
-+ qch = result.data() + where;
-+ }
-+
- *qch++ = QChar(high);
- *qch++ = QChar(low);
-+ } else if ((uc < min_uc) || (uc >= 0xd800 && uc <= 0xdfff) || (uc >= 0xfffe)) {
-+ // error
-+ *qch++ = QChar::ReplacementCharacter;
-+ ++invalid;
- } else {
- *qch++ = uc;
- }
- }
- } else {
- // error
-+ i = error;
- *qch++ = QChar::ReplacementCharacter;
- ++invalid;
- need = 0;
-@@ -171,12 +188,22 @@ QString QUtf8Codec::convertToUnicode(con
- } else if ((ch & 0xe0) == 0xc0) {
- uc = ch & 0x1f;
- need = 1;
-+ error = i;
-+ min_uc = 0x80;
- } else if ((ch & 0xf0) == 0xe0) {
- uc = ch & 0x0f;
- need = 2;
-+ error = i;
-+ min_uc = 0x800;
- } else if ((ch&0xf8) == 0xf0) {
- uc = ch & 0x07;
- need = 3;
-+ error = i;
-+ min_uc = 0x10000;
-+ } else {
-+ // error
-+ *qch++ = QChar::ReplacementCharacter;
-+ ++invalid;
- }
- }
- }
-@@ -187,6 +214,7 @@ QString QUtf8Codec::convertToUnicode(con
- if (headerdone)
- state->flags |= IgnoreHeader;
- state->state_data[0] = need ? uc : 0;
-+ state->state_data[1] = need ? min_uc : 0;
- }
- return result;
- }
diff --git a/devel/qt4-corelib/pkg-plist b/devel/qt4-corelib/pkg-plist
index 10346fb33f9e..d3d9433865ce 100644
--- a/devel/qt4-corelib/pkg-plist
+++ b/devel/qt4-corelib/pkg-plist
@@ -33,10 +33,12 @@ include/Qt/qconfig.h
include/Qt/qcontainerfwd.h
include/Qt/qcoreapplication.h
include/Qt/qcoreevent.h
+include/Qt/qcryptographichash.h
include/Qt/qdatastream.h
include/Qt/qdatetime.h
include/Qt/qdebug.h
include/Qt/qdir.h
+include/Qt/qdiriterator.h
include/Qt/qendian.h
include/Qt/qeventloop.h
include/Qt/qfactoryinterface.h
@@ -61,6 +63,7 @@ include/Qt/qmetatype.h
include/Qt/qmimedata.h
include/Qt/qmutex.h
include/Qt/qnamespace.h
+include/Qt/qnumeric.h
include/Qt/qobject.h
include/Qt/qobjectcleanuphandler.h
include/Qt/qobjectdefs.h
@@ -104,6 +107,7 @@ include/Qt/qwaitcondition.h
include/QtCore/QAbstractEventDispatcher
include/QtCore/QAbstractFileEngine
include/QtCore/QAbstractFileEngineHandler
+include/QtCore/QAbstractFileEngineIterator
include/QtCore/QAbstractItemModel
include/QtCore/QAbstractListModel
include/QtCore/QAbstractTableModel
@@ -127,15 +131,18 @@ include/QtCore/QCharRef
include/QtCore/QChildEvent
include/QtCore/QConstString
include/QtCore/QCoreApplication
+include/QtCore/QCryptographicHash
include/QtCore/QCustomEvent
include/QtCore/QDataStream
include/QtCore/QDate
include/QtCore/QDateTime
include/QtCore/QDebug
include/QtCore/QDir
+include/QtCore/QDirIterator
include/QtCore/QDynamicPropertyChangeEvent
include/QtCore/QEvent
include/QtCore/QEventLoop
+include/QtCore/QExplicitlySharedDataPointer
include/QtCore/QFSFileEngine
include/QtCore/QFactoryInterface
include/QtCore/QFile
@@ -150,6 +157,7 @@ include/QtCore/QForeachContainerBase
include/QtCore/QGenericArgument
include/QtCore/QGenericReturnArgument
include/QtCore/QGlobalStatic
+include/QtCore/QGlobalStaticDeleter
include/QtCore/QHash
include/QtCore/QHashData
include/QtCore/QHashDummyNode
@@ -237,6 +245,7 @@ include/QtCore/QString
include/QtCore/QStringList
include/QtCore/QStringListIterator
include/QtCore/QStringMatcher
+include/QtCore/QStringRef
include/QtCore/QSysInfo
include/QtCore/QSystemLocale
include/QtCore/QTS
@@ -333,10 +342,12 @@ include/QtCore/qconfig.h
include/QtCore/qcontainerfwd.h
include/QtCore/qcoreapplication.h
include/QtCore/qcoreevent.h
+include/QtCore/qcryptographichash.h
include/QtCore/qdatastream.h
include/QtCore/qdatetime.h
include/QtCore/qdebug.h
include/QtCore/qdir.h
+include/QtCore/qdiriterator.h
include/QtCore/qendian.h
include/QtCore/qeventloop.h
include/QtCore/qfactoryinterface.h
@@ -361,6 +372,7 @@ include/QtCore/qmetatype.h
include/QtCore/qmimedata.h
include/QtCore/qmutex.h
include/QtCore/qnamespace.h
+include/QtCore/qnumeric.h
include/QtCore/qobject.h
include/QtCore/qobjectcleanuphandler.h
include/QtCore/qobjectdefs.h
@@ -405,9 +417,8 @@ lib/libQtCore.la
lib/libQtCore.prl
lib/libQtCore.so
lib/libQtCore.so.4
-lib/libQtCore.so.4.2
-lib/libQtCore.so.4.2.3
-lib/libQtCore.so.4.2.3.debug
+lib/libQtCore.so.4.3
+lib/libQtCore.so.4.3.0
lib/plugins/.keep_me
libdata/pkgconfig/QtCore.pc
@dirrmtry share/qt4