aboutsummaryrefslogtreecommitdiff
path: root/devel/qt4-help
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-04 23:30:38 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-04 23:30:38 +0000
commitd56984b0567867dd57ecb27fe0c508025c2426c5 (patch)
treeeb02dac4e0d7e5129ffac4c76b935a76a7e66676 /devel/qt4-help
parent98813eadd27b8cd8500044af2a49b6d861809815 (diff)
downloadports-d56984b0567867dd57ecb27fe0c508025c2426c5.tar.gz
ports-d56984b0567867dd57ecb27fe0c508025c2426c5.zip
Notes
Diffstat (limited to 'devel/qt4-help')
-rw-r--r--devel/qt4-help/Makefile64
-rw-r--r--devel/qt4-help/distinfo3
-rw-r--r--devel/qt4-help/pkg-descr12
-rw-r--r--devel/qt4-help/pkg-plist40
4 files changed, 119 insertions, 0 deletions
diff --git a/devel/qt4-help/Makefile b/devel/qt4-help/Makefile
new file mode 100644
index 000000000000..82fa4e3eee76
--- /dev/null
+++ b/devel/qt4-help/Makefile
@@ -0,0 +1,64 @@
+# New ports collection makefile for: qt4-help
+# Date created: Sun May 11 14:43:54 CEST 2008
+# Whom: danny@ricin.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= help
+PORTVERSION= ${QT4_VERSION}
+CATEGORIES?= devel
+MASTER_SITES= ${MASTER_SITE_QT}
+PKGNAMEPREFIX= qt4-
+DISTNAME= qt-x11-opensource-src-${PORTVERSION}
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= QtHelp module provides QHelpEngine API and is used by Assistant
+
+USE_QT_VER= 4
+QT_COMPONENTS= qmake_build moc_build rcc_build corelib clucene gui sql xml
+QT_NONSTANDARD= yes
+QT_DIST= yes
+
+RUN_DEPENDS= ${LOCALBASE}/lib/qt4/plugins/sqldrivers/libqsqlite.so:${PORTSDIR}/databases/qt4-sqlite3-plugin
+
+HAS_CONFIGURE= yes
+USE_LDCONFIG= ${PREFIX}/lib/qt4
+
+ALL_TARGET= first
+CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
+MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib \
+ PATH=${WRKSRC}/bin:$$PATH
+
+DO_NOT_EXTRACT= demos doc examples mkspecs qmake translations \
+ src/dbus src/network src/opengl src/phonon \
+ src/qt3support src/script src/svg src/testlib \
+ src/tools src/xmlpatterns src/3rdparty/clucene \
+ src/3rdparty/kdebase src/3rdparty/kdelibs src/3rdparty/webkit
+EXTRACT_AFTER_ARGS= | ${TAR} -xf -
+.for dne in ${DO_NOT_EXTRACT}
+EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
+.endfor
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/tools/assistant/lib
+CONFIGURE_WRKSRC=${WRKSRC}/../../../
+
+pre-configure:
+ ${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
+ ${MKDIR} ${WRKSRC}/../../../mkspecs
+ ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../../bin/qmake
+ ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/../../../bin/moc
+ ${LN} -sf ${LOCALBASE}/bin/rcc ${WRKSRC}/../../../bin/rcc
+
+post-configure:
+ ${REINPLACE_CMD} \
+ -e 's|${PREFIX}/lib/qt4/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
+ -e 's|.*$$(QMAKE).*||g' \
+ ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -E -e 's|-L.[^[:space:]]*qt-x11-opensource.[^[:space:]]*lib||g' \
+ -E -e 's|(.*location=).*moc|\1${PREFIX}/bin/moc-qt4|g' \
+ -E -e 's|(.*location=).*rcc|\1${PREFIX}/bin/rcc|g' \
+ ${WRKSRC}/../../../lib/pkgconfig/QtHelp.pc
+
+.include <bsd.port.mk>
diff --git a/devel/qt4-help/distinfo b/devel/qt4-help/distinfo
new file mode 100644
index 000000000000..0c630f09baf6
--- /dev/null
+++ b/devel/qt4-help/distinfo
@@ -0,0 +1,3 @@
+MD5 (KDE/qt-x11-opensource-src-4.4.1.tar.gz) = b09decad252b5181f300135e3122481d
+SHA256 (KDE/qt-x11-opensource-src-4.4.1.tar.gz) = 5aca7b784fc4de3db292666490ade84cfd1810f189c089c5c2810a710993f386
+SIZE (KDE/qt-x11-opensource-src-4.4.1.tar.gz) = 108774120
diff --git a/devel/qt4-help/pkg-descr b/devel/qt4-help/pkg-descr
new file mode 100644
index 000000000000..efc79b9aaf24
--- /dev/null
+++ b/devel/qt4-help/pkg-descr
@@ -0,0 +1,12 @@
+Qt is a C++ toolkit for application development. It lets application
+developers target all major operating systems with a single application
+source code.
+
+Qt provides a platform-independent API to all central platform functionality:
+GUI, database access, networking, file handling, etc. The Qt library
+encapsulates the different APIs of different operating systems, providing
+the application programmer with a single, common API for all operating systems.
+The native C APIs are encapsulated in a set of well-designed, fully
+object-oriented C++ classes.
+
+WWW: http://www.trolltech.com/products/qt/index.html
diff --git a/devel/qt4-help/pkg-plist b/devel/qt4-help/pkg-plist
new file mode 100644
index 000000000000..a4ac2d3881e6
--- /dev/null
+++ b/devel/qt4-help/pkg-plist
@@ -0,0 +1,40 @@
+include/qt4/Qt/QtHelp
+include/qt4/Qt/qhelp_global.h
+include/qt4/Qt/qhelpcontentwidget.h
+include/qt4/Qt/qhelpengine.h
+include/qt4/Qt/qhelpenginecore.h
+include/qt4/Qt/qhelpindexwidget.h
+include/qt4/Qt/qhelpsearchengine.h
+include/qt4/Qt/qhelpsearchquerywidget.h
+include/qt4/Qt/qhelpsearchresultwidget.h
+include/qt4/QtHelp/QHelpContentItem
+include/qt4/QtHelp/QHelpContentModel
+include/qt4/QtHelp/QHelpContentWidget
+include/qt4/QtHelp/QHelpEngine
+include/qt4/QtHelp/QHelpEngineCore
+include/qt4/QtHelp/QHelpIndexModel
+include/qt4/QtHelp/QHelpIndexWidget
+include/qt4/QtHelp/QHelpSearchEngine
+include/qt4/QtHelp/QHelpSearchQuery
+include/qt4/QtHelp/QHelpSearchQueryWidget
+include/qt4/QtHelp/QHelpSearchResultWidget
+include/qt4/QtHelp/QtHelp
+include/qt4/QtHelp/qhelp_global.h
+include/qt4/QtHelp/qhelpcontentwidget.h
+include/qt4/QtHelp/qhelpengine.h
+include/qt4/QtHelp/qhelpenginecore.h
+include/qt4/QtHelp/qhelpindexwidget.h
+include/qt4/QtHelp/qhelpsearchengine.h
+include/qt4/QtHelp/qhelpsearchquerywidget.h
+include/qt4/QtHelp/qhelpsearchresultwidget.h
+lib/qt4/libQtHelp.la
+lib/qt4/libQtHelp.prl
+lib/qt4/libQtHelp.so
+lib/qt4/libQtHelp.so.4
+lib/qt4/libQtHelp.so.4.4
+lib/qt4/libQtHelp.so.4.4.1
+%%DEBUG%%lib/qt4/libQtHelp.so.4.4.1.debug
+libdata/pkgconfig/QtHelp.pc
+@dirrm include/qt4/QtHelp
+@dirrmtry include/qt4/Qt
+@dirrmtry include/qt4