aboutsummaryrefslogtreecommitdiff
path: root/devel/qt4-porting
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-01-21 21:13:21 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-01-21 21:13:21 +0000
commit43902f6ecc0189b88ec79a03b8b0b39425aa18dd (patch)
tree5b488e99af499ef5ed89d0b90cc3f0f14b1f1ad4 /devel/qt4-porting
parent5534788943950923c05e59a02337cde792233450 (diff)
The FreeBSD KDE team is pleased to announce Qt-4.6.1 for FreeBSD.
Notes
Notes: svn path=/head/; revision=248306
Diffstat (limited to 'devel/qt4-porting')
-rw-r--r--devel/qt4-porting/Makefile26
-rw-r--r--devel/qt4-porting/pkg-descr2
-rw-r--r--devel/qt4-porting/pkg-plist1
3 files changed, 17 insertions, 12 deletions
diff --git a/devel/qt4-porting/Makefile b/devel/qt4-porting/Makefile
index 8f36ce038f36..b0946ac660d8 100644
--- a/devel/qt4-porting/Makefile
+++ b/devel/qt4-porting/Makefile
@@ -28,23 +28,27 @@ MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib \
PATH=${WRKSRC}/bin:$$PATH
DO_NOT_EXTRACT= demos doc examples mkspecs qmake translations \
- src/dbus src/gui src/network src/opengl src/phonon \
- src/qt3support src/script src/sql src/svg src/testlib \
- src/tools src/xmlpatterns src/3rdparty/clucene \
- src/3rdparty/kdebase src/3rdparty/kdelibs src/3rdparty/webkit
+ src/activeqt src/dbus src/gui src/multimedia src/network \
+ src/opengl src/openvg src/phonon src/qt3support \
+ src/s60installs src/s60main src/script src/scripttools src/sql \
+ src/svg src/testlib src/tools src/winmain src/xmlpatterns \
+ src/3rdparty/clucene src/3rdparty/freetype \
+ src/3rdparty/libjpeg src/3rdparty/libmng src/3rdparty/libpng \
+ src/3rdparty/libtiff src/3rdparty/phonon src/3rdparty/webkit
EXTRACT_AFTER_ARGS= | ${TAR} -xf -
.for dne in ${DO_NOT_EXTRACT}
EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
.endfor
-WRKSRC= ${WRKDIR}/${DISTNAME}/tools/${PORTNAME}
-CONFIGURE_WRKSRC=${WRKSRC}/../../
+BUILD_WRKSRC= ${WRKSRC}/tools/${PORTNAME}
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+EXTRA_PATCHES= ${.CURDIR}/../../devel/qt4/files/patch-configure
pre-configure:
- ${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
- ${MKDIR} ${WRKSRC}/../../mkspecs
- ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../bin/qmake
- ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/../../bin/moc
- ${LN} -sf ${LOCALBASE}/bin/rcc ${WRKSRC}/../../bin/rcc
+ ${MKDIR} ${WRKSRC}/mkspecs
+ ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/bin/qmake
+ ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/bin/moc
+ ${LN} -sf ${LOCALBASE}/bin/rcc ${WRKSRC}/bin/rcc
.include <bsd.port.mk>
diff --git a/devel/qt4-porting/pkg-descr b/devel/qt4-porting/pkg-descr
index efc79b9aaf24..36bc69717e98 100644
--- a/devel/qt4-porting/pkg-descr
+++ b/devel/qt4-porting/pkg-descr
@@ -9,4 +9,4 @@ the application programmer with a single, common API for all operating systems.
The native C APIs are encapsulated in a set of well-designed, fully
object-oriented C++ classes.
-WWW: http://www.trolltech.com/products/qt/index.html
+WWW: http://qt.nokia.com/products/qt/index.html
diff --git a/devel/qt4-porting/pkg-plist b/devel/qt4-porting/pkg-plist
index be89f2cc9eb9..34aee4a5f797 100644
--- a/devel/qt4-porting/pkg-plist
+++ b/devel/qt4-porting/pkg-plist
@@ -1,3 +1,4 @@
bin/qt3to4
%%DEBUG%%bin/qt3to4.debug
share/qt4/q3porting.xml
+@dirrmtry share/qt4