aboutsummaryrefslogtreecommitdiff
path: root/devel/qt5/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2014-03-03 16:50:32 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2014-03-03 16:50:32 +0000
commit4cd1e8830ecdea3996915303a7cdb1aaaec56ca8 (patch)
tree0facf8a13da71e87170cdfcf5902ed77d09cb72f /devel/qt5/Makefile
parent9110d8d5d340cf5fa7e7a59070603dd554e3959c (diff)
downloadports-4cd1e8830ecdea3996915303a7cdb1aaaec56ca8.tar.gz
ports-4cd1e8830ecdea3996915303a7cdb1aaaec56ca8.zip
Notes
Diffstat (limited to 'devel/qt5/Makefile')
-rw-r--r--devel/qt5/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/devel/qt5/Makefile b/devel/qt5/Makefile
new file mode 100644
index 000000000000..f52394ea576a
--- /dev/null
+++ b/devel/qt5/Makefile
@@ -0,0 +1,44 @@
+# $FreeBSD$
+
+PORTNAME= qt5
+DISTVERSION= ${QT5_VERSION}
+CATEGORIES= devel
+MASTER_SITES= # empty
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Cross-platform application and UI framework (metaport)
+
+USE_QT5= clucene concurrent core dbus declarative designer \
+ graphicaleffects gui help imageformats multimedia \
+ network opengl printsupport qml quick script \
+ scripttools sql svg testlib webkit widgets xml \
+ xmlpatterns
+
+NO_BUILD= yes
+NO_MTREE= yes
+
+OPTIONS_DEFINE= SQL_PLUGINS TOOLS
+OPTIONS_DEFAULT=${OPTIONS_DEFINE}
+
+SQL_PLUGINS_DESC= Install database plugins for QtSql
+SQL_PLUGINS_USE=sql-ibase sql-mysql sql-odbc sql-pgsql sql-sqlite2 \
+ sql-sqlite3
+
+TOOLS_DESC= Install Qt tools (qmake, moc, etc.)
+TOOLS_USE= assistant buildtools linguist linguisttools \
+ pixeltool qdbus qdbusviewer qev qmake
+
+.for opt in ${OPTIONS_DEFINE}
+${opt}_USE:= ${${opt}_USE:S/^/QT5=/}
+.endfor
+
+.include <bsd.port.options.mk>
+
+USE_QT5:= ${USE_QT5:S/$/_run/}
+
+do-install:
+ @${DO_NADA}
+
+.include <bsd.port.mk>