aboutsummaryrefslogtreecommitdiff
path: root/devel/qt5/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2015-02-24 21:40:33 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2015-02-24 21:40:33 +0000
commit6fe40ec7055cc4bcf66aaa32afc9d3f397361d17 (patch)
tree375fb1a5f237be39d64e3be64871a7b4ce94778c /devel/qt5/Makefile
parent9d2e718f3c3e32b1c2553527b4ac488547d06144 (diff)
Notes
Diffstat (limited to 'devel/qt5/Makefile')
-rw-r--r--devel/qt5/Makefile13
1 files changed, 4 insertions, 9 deletions
diff --git a/devel/qt5/Makefile b/devel/qt5/Makefile
index fd951dd66739..7acebc48ec71 100644
--- a/devel/qt5/Makefile
+++ b/devel/qt5/Makefile
@@ -2,7 +2,7 @@
PORTNAME= qt5
DISTVERSION= ${QT5_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= # empty
DISTFILES= # empty
@@ -16,8 +16,10 @@ USE_QT5= clucene concurrent core dbus declarative designer \
network opengl paths printsupport qml quick quickcontrols \
script scripttools serialport sql svg testlib webkit widgets \
x11extras xml xmlpatterns
+USE_QT5:= ${USE_QT5:S/$/_run/}
NO_BUILD= yes
+NO_INSTALL= yes
NO_MTREE= yes
OPTIONS_DEFINE= SQL_PLUGINS TOOLS
@@ -32,14 +34,7 @@ TOOLS_USE= assistant buildtools linguist linguisttools \
pixeltool qdbus qdbusviewer qdoc qev qmake
.for opt in ${OPTIONS_DEFINE}
-${opt}_USE:= ${${opt}_USE:S/^/QT5=/}
+${opt}_USE:= ${${opt}_USE:S/^/QT5=/:S/$/_run/}
.endfor
-.include <bsd.port.options.mk>
-
-USE_QT5:= ${USE_QT5:S/$/_run/}
-
-do-install:
- @${DO_NADA}
-
.include <bsd.port.mk>