aboutsummaryrefslogtreecommitdiff
path: root/devel/quilt/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-29 22:27:05 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-29 22:27:05 +0000
commit9ff06b3cbf038359059e40e0db31ba0cbe996d0f (patch)
tree8583dfe71adaea6ce266633e1799cd602516b801 /devel/quilt/Makefile
parent25c4307da135103ea810d65f96f2f1c21e0547b4 (diff)
downloadports-9ff06b3cbf038359059e40e0db31ba0cbe996d0f.tar.gz
ports-9ff06b3cbf038359059e40e0db31ba0cbe996d0f.zip
Notes
Diffstat (limited to 'devel/quilt/Makefile')
-rw-r--r--devel/quilt/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/devel/quilt/Makefile b/devel/quilt/Makefile
index 40d9d91e245d..862d1350a34b 100644
--- a/devel/quilt/Makefile
+++ b/devel/quilt/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: quilt
-# Date created: 20 Oct 2006
-# Whom: Dirk Jagdmann <doj@cubic.org>
-#
+# Created by: Dirk Jagdmann <doj@cubic.org>
# $FreeBSD$
-#
PORTNAME= quilt
PORTVERSION= 0.60
@@ -28,7 +24,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS} \
USE_GMAKE= yes
USE_PERL5= yes
-OPTIONS= RPMBUILD "rpmbuild support" off
+OPTIONS_DEFINE= RPMBUILD DOCS NLS
+RPMBUILD_DESC= rpmbuild support
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-sed=${LOCALBASE}/bin/gsed \
@@ -40,7 +37,7 @@ PORTDOCS= README README.MAIL quilt.pdf
.include <bsd.port.options.mk>
-.if defined(WITH_RPMBUILD)
+.if ${PORT_OPTIONS:MRPMBUILD}
BUILD_DEPENDS+= rpm:${PORTSDIR}/archivers/rpm
RUN_DEPENDS+= rpm:${PORTSDIR}/archivers/rpm
PLIST_SUB+= RPMBUILD=""
@@ -49,7 +46,7 @@ CONFIGURE_ARGS+=--without-rpmbuild
PLIST_SUB+= RPMBUILD="@comment "
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
PLIST_SUB+= NLS=""
USES+= gettext
.else
@@ -63,7 +60,7 @@ PLIST_SUB+= SENDMAIL=""
PLIST_SUB+= SENDMAIL="@comment "
.endif
-.if defined(NOPORTDOCS)
+.if ! ${PORT_OPTIONS:MDOCS}
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-Makefile.in
.endif