aboutsummaryrefslogtreecommitdiff
path: root/devel/ragel
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2006-03-30 02:10:03 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2006-03-30 02:10:03 +0000
commitd2aad610d525c975008c54da0f6445bb697b6109 (patch)
treed6890c533a60803d52e3c28bb8c428ae7eaa4dea /devel/ragel
parent5141fa0ed28bb81efd46acbf9dc91486d808ed15 (diff)
downloadports-d2aad610d525c975008c54da0f6445bb697b6109.tar.gz
ports-d2aad610d525c975008c54da0f6445bb697b6109.zip
Notes
Diffstat (limited to 'devel/ragel')
-rw-r--r--devel/ragel/Makefile4
-rw-r--r--devel/ragel/distinfo6
-rw-r--r--devel/ragel/files/patch-ragel__ragel.h10
-rw-r--r--devel/ragel/files/patch-rlcodegen__xmlparse.y118
-rw-r--r--devel/ragel/pkg-descr2
5 files changed, 6 insertions, 134 deletions
diff --git a/devel/ragel/Makefile b/devel/ragel/Makefile
index ab317c8e2401..a28d0e8a3320 100644
--- a/devel/ragel/Makefile
+++ b/devel/ragel/Makefile
@@ -7,9 +7,9 @@
#
PORTNAME= ragel
-PORTVERSION= 5.1
+PORTVERSION= 5.5
CATEGORIES= devel
-MASTER_SITES= http://www.elude.ca/ragel/
+MASTER_SITES= http://www.cs.queensu.ca/home/thurston/ragel/
MAINTAINER= ports@FreeBSD.org
COMMENT= Compile regular languages into executable C/C++ code
diff --git a/devel/ragel/distinfo b/devel/ragel/distinfo
index 897e728bff3c..f469e22404a4 100644
--- a/devel/ragel/distinfo
+++ b/devel/ragel/distinfo
@@ -1,3 +1,3 @@
-MD5 (ragel-5.1.tar.gz) = 2d2d8989914c735d775f19267af39ad2
-SHA256 (ragel-5.1.tar.gz) = 203258ed99b9816f5ff91c3ee612f74615ede5e957590f0b0c8c8580ccb95ef2
-SIZE (ragel-5.1.tar.gz) = 500674
+MD5 (ragel-5.5.tar.gz) = 5962ea8d6269c6a461b66e3e9fc98d55
+SHA256 (ragel-5.5.tar.gz) = f4ff4448bb0c593e96a6a08b1d1cb2edc3e214b54856c866a49eae2873bb4bbd
+SIZE (ragel-5.5.tar.gz) = 494489
diff --git a/devel/ragel/files/patch-ragel__ragel.h b/devel/ragel/files/patch-ragel__ragel.h
deleted file mode 100644
index e48ca53e29dd..000000000000
--- a/devel/ragel/files/patch-ragel__ragel.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- ragel/ragel.h.orig Sat Dec 17 12:50:57 2005
-+++ ragel/ragel.h Mon Dec 26 13:12:58 2005
-@@ -25,6 +25,7 @@
- #include <stdio.h>
- #include <iostream>
- #include <fstream>
-+#include <string>
- #include "config.h"
-
- #define PROGNAME "ragel"
diff --git a/devel/ragel/files/patch-rlcodegen__xmlparse.y b/devel/ragel/files/patch-rlcodegen__xmlparse.y
deleted file mode 100644
index c9f2e6821541..000000000000
--- a/devel/ragel/files/patch-rlcodegen__xmlparse.y
+++ /dev/null
@@ -1,118 +0,0 @@
---- rlcodegen/xmlparse.y.orig Thu Dec 22 16:04:14 2005
-+++ rlcodegen/xmlparse.y Mon Dec 26 13:20:03 2005
-@@ -175,7 +175,7 @@
- else
- sourceFileName = fileNameAttr->value;
- openOutput( sourceFileName );
-- }
-+ };
-
- AttributeList:
- AttributeList Attribute {
-@@ -190,7 +190,7 @@
- XML_Word '=' XML_Literal {
- attrKey = $1;
- attrValue = $3;
-- }
-+ };
-
- HostOrDefList:
- HostOrDefList HostOrDef |
-@@ -204,7 +204,7 @@
- '<' '/' TAG_host '>' {
- if ( outputFormat == OutCCode || outputFormat == OutDCode )
- *outStream << xmlData.data;
-- }
-+ };
-
- TagHostHead:
- '<' TAG_host AttributeList '>' {
-@@ -216,14 +216,14 @@
- if ( outputFormat == OutCCode || outputFormat == OutDCode )
- lineDirective( *outStream, sourceFileName, line );
- }
-- }
-+ };
-
- TagRagelDef:
- RagelDefHead
- RagelDefItemList
- '<' '/' TAG_ragel_def '>' {
- cgd->generate();
-- }
-+ };
-
- RagelDefHead:
- '<' TAG_ragel_def AttributeList '>' {
-@@ -303,7 +303,7 @@
- else {
- warning() << "unrecognized write option" << endl;
- }
-- }
-+ };
-
-
- TagAlphType:
-@@ -361,7 +361,7 @@
- '<' '/' TAG_start_state '>' {
- unsigned long startState = strtoul( xmlData.data, 0, 10 );
- cgd->setStartState( startState );
-- }
-+ };
-
- TagEntryPoints:
- '<' TAG_entry_points AttributeList '>'
-@@ -370,7 +370,7 @@
- Attribute *errorAttr = $3->find( "error" );
- if ( errorAttr != 0 )
- cgd->setForcedErrorState();
-- }
-+ };
-
- EntryPointList:
- EntryPointList TagEntry |
-@@ -462,7 +462,7 @@
- cgd->initTransList( curState, length );
- curTrans = 0;
- }
-- }
-+ };
-
- TransList:
- TransList TagTrans |
-@@ -531,7 +531,7 @@
- /* Nothing */ {
- /* Start with empty list. */
- $$ = new InlineList;
-- }
-+ };
-
- InlineItem:
- TagText |
-@@ -564,7 +564,7 @@
- '<' '/' TAG_text '>' {
- $$ = new InlineItem( InputLoc(), InlineItem::Text );
- $$->data = strdup(xmlData.data);
-- }
-+ };
-
- TagGoto:
- '<' TAG_goto '>'
-@@ -772,7 +772,7 @@
- cgd->initActionTableList( length );
- curActionTable = 0;
- }
-- }
-+ };
-
- ActionTableList:
- ActionTableList TagActionTable |
-@@ -806,7 +806,7 @@
- }
-
- curActionTable += 1;
-- }
-+ };
-
- %%
-
diff --git a/devel/ragel/pkg-descr b/devel/ragel/pkg-descr
index 7a48d39f9413..22a009f02306 100644
--- a/devel/ragel/pkg-descr
+++ b/devel/ragel/pkg-descr
@@ -10,4 +10,4 @@ precisely the way you describe to Ragel how to compile your finite state
machines. Ragel also understands operators that insert function calls into
machines and operators that control any non-determinism in machines.
-WWW: http://www.elude.ca/ragel/
+WWW: http://www.cs.queensu.ca/home/thurston/ragel/