aboutsummaryrefslogtreecommitdiff
path: root/devel/rapidsvn/Makefile
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2005-12-02 14:07:53 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2005-12-02 14:07:53 +0000
commite597f2dee3409d0be518784291e44fc07c90c9f5 (patch)
tree097564beaad0684cb784dfe962eb915e800d716e /devel/rapidsvn/Makefile
parentc256f1c65ffe670ce04690b85dba21b41cdaed5d (diff)
Notes
Diffstat (limited to 'devel/rapidsvn/Makefile')
-rw-r--r--devel/rapidsvn/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/devel/rapidsvn/Makefile b/devel/rapidsvn/Makefile
index 3ea4467a316a..7e0c9ec47eeb 100644
--- a/devel/rapidsvn/Makefile
+++ b/devel/rapidsvn/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= rapidsvn
-PORTVERSION= 0.8.0
+PORTVERSION= 0.9.0
CATEGORIES= devel
MASTER_SITES= http://www.rapidsvn.org/download/
@@ -16,13 +16,15 @@ COMMENT= Cross-platform GUI front-end for the Subversion revision system
BUILD_DEPENDS= apr-1-config:${PORTSDIR}/devel/apr-svn \
${WXCONFIG}:${PORTSDIR}/x11-toolkits/${WXPORT} \
neon-config:${PORTSDIR}/www/neon \
- ${SVNDEP}:${PORTSDIR}/devel/subversion
+ ${SVNDEP}:${PORTSDIR}/devel/subversion \
+ ${LOCALBASE}/share/xsl/docbook/VERSION:${PORTSDIR}/textproc/docbook-xsl
USE_X_PREFIX= yes
USE_AUTOTOOLS= autoconf:259 libtool:15
CONFIGURE_ARGS= --with-wx-config=${WXCONFIG} \
--with-apr-config=apr-1-config \
- --with-apu-config=apu-1-config
+ --with-apu-config=apu-1-config \
+ --with-docbook-xsl=${LOCALBASE}/share/xsl/docbook
CONFIGURE_ENV= LDFLAGS="-L${X11BASE}/lib ${PTHREAD_LIBS}"
INSTALLS_SHLIB= yes
MAN1= rapidsvn.1
@@ -30,6 +32,9 @@ MAN1= rapidsvn.1
.if exists(${X11BASE}/bin/wxgtk2-2.6-config)
WXPORT= wxgtk26
WXCONFIG= wxgtk2-2.6-config
+.elif exists(${X11BASE}/bin/wxgtk2u-2.6-config)
+WXPORT= wxgtk26-unicode
+WXCONFIG= wxgtk2u-2.6-config
.else
WXPORT= wxgtk24
WXCONFIG= wxgtk2-2.4-config