aboutsummaryrefslogtreecommitdiff
path: root/devel/rapidsvn/Makefile
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2005-01-09 02:38:52 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2005-01-09 02:38:52 +0000
commite558ef8918fa36a6ed9cc1767e49d343cda082ef (patch)
tree2f22daa5b85cadb895d8a624c8e0bc27ec932a70 /devel/rapidsvn/Makefile
parentec96c8ea9df5a547f85d87980e9baddfc79def89 (diff)
Notes
Diffstat (limited to 'devel/rapidsvn/Makefile')
-rw-r--r--devel/rapidsvn/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/devel/rapidsvn/Makefile b/devel/rapidsvn/Makefile
new file mode 100644
index 000000000000..f415341440e1
--- /dev/null
+++ b/devel/rapidsvn/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: rapidsvn
+# Date created: Jan 1, 2005
+# Whom: kuriyama@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= rapidsvn
+PORTVERSION= 0.7.0
+CATEGORIES= devel
+MASTER_SITES= http://www.rapidsvn.org/download/
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Cross-platform GUI front-end for the Subversion revision system
+
+BUILD_DEPENDS= apr-1-config:${PORTSDIR}/devel/apr-svn \
+ ${WXCONFIG}:${PORTSDIR}/x11-toolkits/${WXPORT} \
+ neon-config:${PORTSDIR}/www/neon \
+ ${SVNDEP}:${PORTSDIR}/devel/subversion
+
+USE_X_PREFIX= yes
+USE_LIBTOOL_VER= 15
+USE_AUTOCONF_VER= 259
+CONFIGURE_ARGS= --with-wx-config=${WXCONFIG} \
+ --with-apr-config=apr-1-config \
+ --with-apu-config=apu-1-config
+CONFIGURE_ENV= LDFLAGS="-L${X11BASE}/lib ${PTHREAD_LIBS}"
+INSTALLS_SHLIB= yes
+MAN1= rapidsvn.1
+
+.if exists(${X11BASE}/bin/wxgtk2-2.5-config)
+WXPORT= wxgtk2-devel
+WXCONFIG= wxgtk2-2.5-config
+.else
+WXPORT= wxgtk2
+WXCONFIG= wx-config
+.endif
+SVNDEP= ${LOCALBASE}/include/subversion-1/svn_types.h
+
+.include <bsd.port.mk>