aboutsummaryrefslogtreecommitdiff
path: root/devel/rapidsvn
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2005-01-09 02:38:52 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2005-01-09 02:38:52 +0000
commite558ef8918fa36a6ed9cc1767e49d343cda082ef (patch)
tree2f22daa5b85cadb895d8a624c8e0bc27ec932a70 /devel/rapidsvn
parentec96c8ea9df5a547f85d87980e9baddfc79def89 (diff)
downloadports-e558ef8918fa36a6ed9cc1767e49d343cda082ef.tar.gz
ports-e558ef8918fa36a6ed9cc1767e49d343cda082ef.zip
Notes
Diffstat (limited to 'devel/rapidsvn')
-rw-r--r--devel/rapidsvn/Makefile40
-rw-r--r--devel/rapidsvn/distinfo2
-rw-r--r--devel/rapidsvn/files/patch-path.cpp11
-rw-r--r--devel/rapidsvn/pkg-descr5
-rw-r--r--devel/rapidsvn/pkg-plist4
5 files changed, 62 insertions, 0 deletions
diff --git a/devel/rapidsvn/Makefile b/devel/rapidsvn/Makefile
new file mode 100644
index 000000000000..f415341440e1
--- /dev/null
+++ b/devel/rapidsvn/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: rapidsvn
+# Date created: Jan 1, 2005
+# Whom: kuriyama@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= rapidsvn
+PORTVERSION= 0.7.0
+CATEGORIES= devel
+MASTER_SITES= http://www.rapidsvn.org/download/
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Cross-platform GUI front-end for the Subversion revision system
+
+BUILD_DEPENDS= apr-1-config:${PORTSDIR}/devel/apr-svn \
+ ${WXCONFIG}:${PORTSDIR}/x11-toolkits/${WXPORT} \
+ neon-config:${PORTSDIR}/www/neon \
+ ${SVNDEP}:${PORTSDIR}/devel/subversion
+
+USE_X_PREFIX= yes
+USE_LIBTOOL_VER= 15
+USE_AUTOCONF_VER= 259
+CONFIGURE_ARGS= --with-wx-config=${WXCONFIG} \
+ --with-apr-config=apr-1-config \
+ --with-apu-config=apu-1-config
+CONFIGURE_ENV= LDFLAGS="-L${X11BASE}/lib ${PTHREAD_LIBS}"
+INSTALLS_SHLIB= yes
+MAN1= rapidsvn.1
+
+.if exists(${X11BASE}/bin/wxgtk2-2.5-config)
+WXPORT= wxgtk2-devel
+WXCONFIG= wxgtk2-2.5-config
+.else
+WXPORT= wxgtk2
+WXCONFIG= wx-config
+.endif
+SVNDEP= ${LOCALBASE}/include/subversion-1/svn_types.h
+
+.include <bsd.port.mk>
diff --git a/devel/rapidsvn/distinfo b/devel/rapidsvn/distinfo
new file mode 100644
index 000000000000..e9931abbcfdb
--- /dev/null
+++ b/devel/rapidsvn/distinfo
@@ -0,0 +1,2 @@
+MD5 (rapidsvn-0.7.0.tar.gz) = 81b6172dd3e270947e17430c4a28bb8b
+SIZE (rapidsvn-0.7.0.tar.gz) = 540092
diff --git a/devel/rapidsvn/files/patch-path.cpp b/devel/rapidsvn/files/patch-path.cpp
new file mode 100644
index 000000000000..90dc01f20860
--- /dev/null
+++ b/devel/rapidsvn/files/patch-path.cpp
@@ -0,0 +1,11 @@
+--- src/svncpp/path.cpp.orig Sat Jan 1 14:54:58 2005
++++ src/svncpp/path.cpp Sat Jan 1 14:55:24 2005
+@@ -259,7 +259,7 @@
+ Pool pool;
+
+ apr_status_t stat = apr_temp_dir_get (&tempdir, pool);
+- if (!APR_STATUS_IS_SUCCESS(stat))
++ if (APR_SUCCESS != stat)
+ {
+ tempdir = NULL;
+ }
diff --git a/devel/rapidsvn/pkg-descr b/devel/rapidsvn/pkg-descr
new file mode 100644
index 000000000000..eaf7215c4e33
--- /dev/null
+++ b/devel/rapidsvn/pkg-descr
@@ -0,0 +1,5 @@
+RapidSVN is a cross-platform GUI front-end for the Subversion revision
+system written in C++ using the wxWidgets framework. This project also
+includes a Subversion client C++ API.
+
+WWW: http://rapidsvn.tigris.org/
diff --git a/devel/rapidsvn/pkg-plist b/devel/rapidsvn/pkg-plist
new file mode 100644
index 000000000000..d68e4c958678
--- /dev/null
+++ b/devel/rapidsvn/pkg-plist
@@ -0,0 +1,4 @@
+bin/rapidsvn
+lib/libsvncpp.a
+lib/libsvncpp.so
+lib/libsvncpp.so.0