aboutsummaryrefslogtreecommitdiff
path: root/devel/regexxer/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-06-01 20:25:40 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-06-01 20:25:40 +0000
commit6202e78071f86426c04600b8df5f992fd25bc70e (patch)
treefd3e1679d9db79859b1d3eb62c0985ad756f5480 /devel/regexxer/Makefile
parent88434931c95536c18eee189ebba04dd1a1557a25 (diff)
downloadports-6202e78071f86426c04600b8df5f992fd25bc70e.tar.gz
ports-6202e78071f86426c04600b8df5f992fd25bc70e.zip
Notes
Diffstat (limited to 'devel/regexxer/Makefile')
-rw-r--r--devel/regexxer/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/devel/regexxer/Makefile b/devel/regexxer/Makefile
index 573144d90f67..3325d785ca9b 100644
--- a/devel/regexxer/Makefile
+++ b/devel/regexxer/Makefile
@@ -7,9 +7,10 @@
PORTNAME= regexxer
PORTVERSION= 0.4
+PORTREVISION= 1
CATEGORIES= devel textproc gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
- ${MASTER_SITE_SOURCEFORGE:S/$/:pcre/}
+ ${MASTER_SITE_SOURCEFORGE:S/$/:pcre/}
MASTER_SITE_SUBDIR= ${PORTNAME} \
${PCRE_NAME}/:pcre
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
@@ -23,17 +24,16 @@ LIB_DEPENDS= gtkmm-2.0:${PORTSDIR}/x11-toolkits/gtk--2
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack gnomeprefix
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GNOME= gnomehack gnomeprefix gnometarget
CONFIGURE_ARGS= PCRE_CONFIG="${PCRE_WRKDIR}/.install/bin/pcre-config"
PCRE_NAME= pcre
-PCRE_VERSION= 3.9
+PCRE_VERSION= 4.3
PCRE_WRKDIR= ${WRKDIR}/${PCRE_NAME}-${PCRE_VERSION}
pre-configure:
@(cd ${PCRE_WRKDIR} && \
- $(ECHO) "Configuring PCRE... " && \
+ $(ECHO_CMD) "Configuring PCRE... " && \
${SETENV} CC="${CC}" CXX="${CXX}" \
CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
INSTALL="/usr/bin/install -c -o ${BINOWN} -g ${BINGRP}" \