aboutsummaryrefslogtreecommitdiff
path: root/devel/rlog/Makefile
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2011-08-31 22:14:29 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2011-08-31 22:14:29 +0000
commit918f7e9095ceeec5904ab0d823c41216080e3534 (patch)
treec7e1abb4dd8c7fa45ca7980ed23072030da4f5aa /devel/rlog/Makefile
parent6fa9fb09834124181a9931ac160b1db97f3b5834 (diff)
Notes
Diffstat (limited to 'devel/rlog/Makefile')
-rw-r--r--devel/rlog/Makefile24
1 files changed, 17 insertions, 7 deletions
diff --git a/devel/rlog/Makefile b/devel/rlog/Makefile
index 944933226dbe..659e94993498 100644
--- a/devel/rlog/Makefile
+++ b/devel/rlog/Makefile
@@ -6,20 +6,30 @@
#
PORTNAME= rlog
-PORTVERSION= 1.3.7
+PORTVERSION= 1.4
CATEGORIES= devel
-MASTER_SITES= http://arg0.net/users/vgough/download/
-EXTRACT_SUFX= .tgz
+MASTER_SITES= GOOGLE_CODE
MAINTAINER= ports@FreeBSD.org
COMMENT= A flexible message logging facility for C++
-BROKEN= does not fetch
+LICENSE= LGPL21 LGPL3
+LICENSE_COMB= dual
-USE_AUTOTOOLS= libtool
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_GNOME= gnomehack
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ '/^SUBDIRS/s|docs||' ${WRKSRC}/Makefile.in
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}/html
+ @(cd ${WRKSRC}/docs/html && ${COPYTREE_SHARE} . ${DOCSDIR}/html)
+.endif
.include <bsd.port.mk>