aboutsummaryrefslogtreecommitdiff
path: root/devel/roboctl
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2009-03-09 17:15:43 +0000
committerStanislav Sedov <stas@FreeBSD.org>2009-03-09 17:15:43 +0000
commitf5d05ea54d1f80ecd08c5809a3ce5e1594e34eaa (patch)
tree343e91600b9cf81ffb94bf71017b43a88bfcbf45 /devel/roboctl
parente9e0ba8df0a817712eab81d4a962e79cae35dca1 (diff)
downloadports-f5d05ea54d1f80ecd08c5809a3ce5e1594e34eaa.tar.gz
ports-f5d05ea54d1f80ecd08c5809a3ce5e1594e34eaa.zip
Notes
Diffstat (limited to 'devel/roboctl')
-rw-r--r--devel/roboctl/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/devel/roboctl/Makefile b/devel/roboctl/Makefile
index cf65cc08653b..5cb3cfe947db 100644
--- a/devel/roboctl/Makefile
+++ b/devel/roboctl/Makefile
@@ -14,7 +14,6 @@ MASTER_SITES= http://personalpages.tds.net/~jwbacon/Ports/distfiles/ \
MAINTAINER= jwbacon@tds.net
COMMENT= API for communications with Lego and Vex robot controllers
-LIB_DEPENDS= usb-0.1:${PORTSDIR}/devel/libusb
BUILD_DEPENDS= ${LOCALBASE}/lib/libgamepad.a:${PORTSDIR}/devel/libgamepad
OPTIONS= CUTECOM "Install cutecom for Vex debugging" On
@@ -24,10 +23,20 @@ MAN3= roboctl.3
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb
+.endif
+
.if defined(WITH_CUTECOM)
RUN_DEPENDS+= cutecom:${PORTSDIR}/comms/cutecom
.endif
+post-patch:
+.if ${OSVERSION} >= 800069
+ @${REINPLACE_CMD} -E -e 's,/usr/local/include/usb.h,/usr/include/usb.h,g' \
+ ${WRKSRC}/Libs/C/Makefile.depend
+.endif
+
post-install:
(cd ${WRKSRC}/Commands/NXTRemote; ${MAKE})
${INSTALL_PROGRAM} ${WRKSRC}/Commands/NXTRemote/nxtremote ${PREFIX}/bin