aboutsummaryrefslogtreecommitdiff
path: root/devel/roboctl
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-07-26 07:59:05 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-07-26 07:59:05 +0000
commit80d6ab2168f36946e9c1b936d538a1b45fa31929 (patch)
treebdb26029daf997de5c6be8ac9fdb715dd8b96136 /devel/roboctl
parentee1b204170c8cbd9e6ff99bcbe17b2c060aee14e (diff)
downloadports-80d6ab2168f36946e9c1b936d538a1b45fa31929.tar.gz
ports-80d6ab2168f36946e9c1b936d538a1b45fa31929.zip
Notes
Diffstat (limited to 'devel/roboctl')
-rw-r--r--devel/roboctl/Makefile29
-rw-r--r--devel/roboctl/distinfo6
-rw-r--r--devel/roboctl/pkg-descr6
-rw-r--r--devel/roboctl/pkg-plist12
4 files changed, 36 insertions, 17 deletions
diff --git a/devel/roboctl/Makefile b/devel/roboctl/Makefile
index 901c569da9d3..78d2f8602b69 100644
--- a/devel/roboctl/Makefile
+++ b/devel/roboctl/Makefile
@@ -1,28 +1,31 @@
-# New ports collection makefile for: legoctl
+# New ports collection makefile for: roboctl
# Date created: 2007-05-03
# Whom: Jason Bacon <jwbacon@tds.net>
#
# $FreeBSD$
#
-PORTNAME= legoctl
-PORTVERSION= 0.2
+PORTNAME= roboctl
+PORTVERSION= 0.3.1
CATEGORIES= devel
MASTER_SITES= http://personalpages.tds.net/~jwbacon/Ports/distfiles/ \
- http://bacon.is-a-geek.org/~bacon/Ports/distfiles/
+ http://jbacon.dyndns.org/~bacon/Ports/distfiles/
MAINTAINER= jwbacon@tds.net
-COMMENT= Lego Mindstorms communication tool
+COMMENT= API for communications with Lego and Vex robot controllers
-LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
+LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb \
+ gamepad.1:${PORTSDIR}/devel/libgamepad
-MAN1= legoctl.1
+OPTIONS= CUTECOM "Install cutecom for Vex debugging" On
-PLIST_FILES= bin/legoctl lib/liblegoctl.a
+MAN1= legoctl.1 vexctl.1 nxtremote.1
+MAN3= roboctl.3
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/Commands/Legoctl/legoctl ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/Libs/C/liblegoctl.a ${PREFIX}/lib
- ${INSTALL_MAN} ${WRKSRC}/Commands/Legoctl/legoctl.1 ${PREFIX}/man/man1
+.include <bsd.port.pre.mk>
-.include <bsd.port.mk>
+.if defined(WITH_CUTECOM)
+RUN_DEPENDS+= cutecom:${PORTSDIR}/comms/cutecom-devel
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/roboctl/distinfo b/devel/roboctl/distinfo
index 0b48abb46510..4771e8663213 100644
--- a/devel/roboctl/distinfo
+++ b/devel/roboctl/distinfo
@@ -1,3 +1,3 @@
-MD5 (legoctl-0.2.tar.gz) = dcd405458eec542e0d7770ffe2b89f7d
-SHA256 (legoctl-0.2.tar.gz) = 5d3a775b3988cbcc1793cdcf22eb94afee7a55865e37bc9d9a086c78f674a5e0
-SIZE (legoctl-0.2.tar.gz) = 15678
+MD5 (roboctl-0.3.1.tar.gz) = 682ae51a852df09736ac2c980b4bd290
+SHA256 (roboctl-0.3.1.tar.gz) = 947b6cee290d787f49e84c54343c2fa38805f6270a698454615a631418e9a6f4
+SIZE (roboctl-0.3.1.tar.gz) = 183023
diff --git a/devel/roboctl/pkg-descr b/devel/roboctl/pkg-descr
index 3d5ed2ef0bf6..cca3234ad751 100644
--- a/devel/roboctl/pkg-descr
+++ b/devel/roboctl/pkg-descr
@@ -1,3 +1,7 @@
-Lego robot communication and control utility.
+Roboctl is a library and tool suite for communicating with Lego and
+Vex robots from Unix systems. It allows users to upload programs
+and other data to the controller, examine various robot states such
+as battery level, firmware version, etc., and control the robot
+remotely from a Unix workstation.
WWW: http://personalpages.tds.net/~jwbacon/Ports
diff --git a/devel/roboctl/pkg-plist b/devel/roboctl/pkg-plist
new file mode 100644
index 000000000000..1cdde1d6ef7b
--- /dev/null
+++ b/devel/roboctl/pkg-plist
@@ -0,0 +1,12 @@
+bin/legoctl
+bin/vexctl
+bin/nxtremote
+include/roboctl/rct_machdep.h
+include/roboctl/rct_nxt.h
+include/roboctl/rct_nxt_output.h
+include/roboctl/rct_protos.h
+include/roboctl/rct_rcx.h
+include/roboctl/roboctl.h
+include/roboctl/rct_pic.h
+lib/libroboctl.a
+@dirrm include/roboctl