aboutsummaryrefslogtreecommitdiff
path: root/devel/robodoc
diff options
context:
space:
mode:
authorChris D. Faulhaber <jedgar@FreeBSD.org>1999-12-23 14:15:35 +0000
committerChris D. Faulhaber <jedgar@FreeBSD.org>1999-12-23 14:15:35 +0000
commit22204e131f36344e0c02b953cae8fb30b55eacc4 (patch)
treefc4500278985329691adc1f29f548456f04223df /devel/robodoc
parenta2317bbaaa1a42788140f41496bcf2bf2b92e912 (diff)
downloadports-22204e131f36344e0c02b953cae8fb30b55eacc4.tar.gz
ports-22204e131f36344e0c02b953cae8fb30b55eacc4.zip
Notes
Diffstat (limited to 'devel/robodoc')
-rw-r--r--devel/robodoc/Makefile37
-rw-r--r--devel/robodoc/distinfo1
-rw-r--r--devel/robodoc/pkg-comment1
-rw-r--r--devel/robodoc/pkg-descr10
-rw-r--r--devel/robodoc/pkg-plist10
5 files changed, 59 insertions, 0 deletions
diff --git a/devel/robodoc/Makefile b/devel/robodoc/Makefile
new file mode 100644
index 000000000000..2f10fd184d6a
--- /dev/null
+++ b/devel/robodoc/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: robodoc
+# Version required: 3.1e
+# Date created: 15 Dec 1999
+# Whom: Will Andrews <andrews@technologist.com>
+#
+# $FreeBSD$
+#
+
+DISTNAME= robodoc
+PKGNAME= robodoc-3.1e
+CATEGORIES= devel
+MASTER_SITES= http://www.xs4all.nl/~rfsber/Robo/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= andrews@technologist.com
+
+FETCH_BEFORE_ARGS+= -b
+WRKSRC= ${WRKDIR}/Robodoc
+MAKEFILE= makefile
+USE_GMAKE= yes
+MAN1= robodoc.1
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/Source/robodoc ${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/Docs/robodoc.1 ${PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/robodoc
+.for DOC in example.c general.m4 main.css robodoc.html robodoc.m4 \
+ stoc.html stoc.m4 tocgen.m4
+ @${INSTALL_DATA} ${WRKSRC}/Docs/${DOC} ${PREFIX}/share/robodoc
+.endfor
+ @${ECHO}
+ @${ECHO} "Docs installed in ${PREFIX}/share/robodoc."
+ @${ECHO}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/robodoc/distinfo b/devel/robodoc/distinfo
new file mode 100644
index 000000000000..c3672d4bed4d
--- /dev/null
+++ b/devel/robodoc/distinfo
@@ -0,0 +1 @@
+MD5 (robodoc.tgz) = 8e89cb8112122bcb32a74b14942e5ce9
diff --git a/devel/robodoc/pkg-comment b/devel/robodoc/pkg-comment
new file mode 100644
index 000000000000..70e0348f9d92
--- /dev/null
+++ b/devel/robodoc/pkg-comment
@@ -0,0 +1 @@
+Code reference program similar to cxref that produces HTML.
diff --git a/devel/robodoc/pkg-descr b/devel/robodoc/pkg-descr
new file mode 100644
index 000000000000..b3655ae9e6b9
--- /dev/null
+++ b/devel/robodoc/pkg-descr
@@ -0,0 +1,10 @@
+A documentation tool for C, C++, Java, Assembler, Basic,
+Fortran, LaTeX, Postscript, Tcl/Tk, LISP, Forth, Perl,
+Shell Scripts, Occam, COBOL, and many other languages. It
+is similar to cxref in that it produces HTML output based
+on your code.
+
+WWW: http://www.xs4all.nl/~rfsber/Robo/robodoc.html
+Author: Frans Slothouber <fslothouber@acm.org>
+
+--Will <andrews@technologist.com>
diff --git a/devel/robodoc/pkg-plist b/devel/robodoc/pkg-plist
new file mode 100644
index 000000000000..ebfa7a44addf
--- /dev/null
+++ b/devel/robodoc/pkg-plist
@@ -0,0 +1,10 @@
+bin/robodoc
+share/robodoc/example.c
+share/robodoc/general.m4
+share/robodoc/main.css
+share/robodoc/robodoc.html
+share/robodoc/robodoc.m4
+share/robodoc/stoc.html
+share/robodoc/stoc.m4
+share/robodoc/tocgen.m4
+@dirrm share/robodoc