aboutsummaryrefslogtreecommitdiff
path: root/devel/root/files
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-08-12 12:54:54 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-08-12 12:54:54 +0000
commitd2e8e136d9fdad2d79fc3cf319a16f0acd134d2f (patch)
tree04df59425a50a0aebdfcbcecdd23d7d9ff2e7a43 /devel/root/files
parent3a7b17911b12b557fc9c450a975d5a86e1c8303e (diff)
downloadports-d2e8e136d9fdad2d79fc3cf319a16f0acd134d2f.tar.gz
ports-d2e8e136d9fdad2d79fc3cf319a16f0acd134d2f.zip
Notes
Diffstat (limited to 'devel/root/files')
-rw-r--r--devel/root/files/patch-config::Makefile.freebsd4137
-rw-r--r--devel/root/files/patch-config::Makefile.freebsd590
-rw-r--r--devel/root/files/patch-config::root-config.in28
-rw-r--r--devel/root/files/patch-configure46
-rw-r--r--devel/root/files/patch-gcc3451
-rw-r--r--devel/root/files/patch-test::Makefile.arch65
6 files changed, 326 insertions, 91 deletions
diff --git a/devel/root/files/patch-config::Makefile.freebsd4 b/devel/root/files/patch-config::Makefile.freebsd4
index ff8c7a896a1a..599d8c0993dd 100644
--- a/devel/root/files/patch-config::Makefile.freebsd4
+++ b/devel/root/files/patch-config::Makefile.freebsd4
@@ -1,55 +1,82 @@
---- config/Makefile.freebsd4.orig Mon Feb 16 11:12:43 2004
-+++ config/Makefile.freebsd4 Sat Apr 17 00:35:00 2004
-@@ -5,7 +5,7 @@
- PLATFORM = fbsd
-
- DEBUGFLAGS = -g
--OPTFLAGS = -O
-+#OPTFLAGS = -O
- ifeq (debug,$(findstring debug,$(ROOTBUILD)))
- OPT = $(DEBUGFLAGS)
- NOOPT =
-@@ -15,10 +15,10 @@
- endif
-
- # Compiler:
--CXX = g++
--CC = gcc
--CXXFLAGS = -pipe -W -Wall -fPIC -I/usr/X11R6/include $(EXTRA_CXXFLAGS)
--CFLAGS = -pipe -W -Wall -fPIC -I/usr/X11R6/include $(EXTRA_CFLAGS)
-+#CXX = g++
-+#CC = gcc
-+CXXFLAGS += -W -Wall -fPIC -I$(X11BASE)/include $(EXTRA_CXXFLAGS)
-+CFLAGS += -W -Wall -fPIC -I$(X11BASE)/include $(EXTRA_CFLAGS)
- CINTCXXFLAGS = -pipe -W -Wall -fPIC -DG__REGEXP $(EXTRA_CXXFLAGS) \
- -DG__UNIX -DG__SHAREDLIB -DG__ROOT -DG__REDIRECTIO -DG__OSFDLL
- CINTCFLAGS = -pipe -W -Wall -fPIC -DG__REGEXP -DG__UNIX -DG__SHAREDLIB \
-@@ -26,13 +26,13 @@
- COMPILER = gnu
-
- ifeq ($(ENABLETHREAD),yes)
--CXXFLAGS += -pthread
--CINTCXXFLAGS += -pthread
-+CXXFLAGS += $(PTHREAD_CFLAGS)
-+CINTCXXFLAGS += $(PTHREAD_CFLAGS)
- endif
-
- # Linker:
--LD = g++
--LDFLAGS = $(OPT) $(EXTRA_LDFLAGS)
-+LD = $(CXX)
-+LDFLAGS += $(OPT) $(EXTRA_LDFLAGS)
- SOFLAGS = -shared -Wl,-x -Wl,-soname,
- SOEXT = so
-
-@@ -43,8 +43,8 @@
- CRYPTLIBS = -lcrypt
-
- # Fortran:
--F77 = f77
--F77FLAGS = $(OPT)
-+#F77 = f77
-+F77FLAGS += $(OPT)
- F77LIBS = -lg2c
-
- # Extras
+*** config/Makefile.freebsd4.orig Mon Feb 16 11:12:43 2004
+--- config/Makefile.freebsd4 Wed Jun 16 15:23:15 2004
+***************
+*** 5,11 ****
+ PLATFORM = fbsd
+
+ DEBUGFLAGS = -g
+- OPTFLAGS = -O
+ ifeq (debug,$(findstring debug,$(ROOTBUILD)))
+ OPT = $(DEBUGFLAGS)
+ NOOPT =
+--- 5,10 ----
+***************
+*** 15,24 ****
+ endif
+
+ # Compiler:
+! CXX = g++
+! CC = gcc
+! CXXFLAGS = -pipe -W -Wall -fPIC -I/usr/X11R6/include $(EXTRA_CXXFLAGS)
+! CFLAGS = -pipe -W -Wall -fPIC -I/usr/X11R6/include $(EXTRA_CFLAGS)
+ CINTCXXFLAGS = -pipe -W -Wall -fPIC -DG__REGEXP $(EXTRA_CXXFLAGS) \
+ -DG__UNIX -DG__SHAREDLIB -DG__ROOT -DG__REDIRECTIO -DG__OSFDLL
+ CINTCFLAGS = -pipe -W -Wall -fPIC -DG__REGEXP -DG__UNIX -DG__SHAREDLIB \
+--- 14,23 ----
+ endif
+
+ # Compiler:
+! CXXFLAGS += -W -Wall -fPIC -I$(X11BASE)/include -I$(LOCALBASE)/include
+! CXXFLAGS += $(EXTRA_CXXFLAGS)
+! CFLAGS += -W -Wall -fPIC -I$(X11BASE)/include -I$(LOCALBASE)/include
+! CFLAGS += $(EXTRA_CFLAGS)
+ CINTCXXFLAGS = -pipe -W -Wall -fPIC -DG__REGEXP $(EXTRA_CXXFLAGS) \
+ -DG__UNIX -DG__SHAREDLIB -DG__ROOT -DG__REDIRECTIO -DG__OSFDLL
+ CINTCFLAGS = -pipe -W -Wall -fPIC -DG__REGEXP -DG__UNIX -DG__SHAREDLIB \
+***************
+*** 26,38 ****
+ COMPILER = gnu
+
+ ifeq ($(ENABLETHREAD),yes)
+! CXXFLAGS += -pthread
+! CINTCXXFLAGS += -pthread
+ endif
+
+ # Linker:
+! LD = g++
+! LDFLAGS = $(OPT) $(EXTRA_LDFLAGS)
+ SOFLAGS = -shared -Wl,-x -Wl,-soname,
+ SOEXT = so
+
+--- 25,37 ----
+ COMPILER = gnu
+
+ ifeq ($(ENABLETHREAD),yes)
+! CXXFLAGS += $(PTHREAD_CFLAGS)
+! CINTCXXFLAGS += $(PTHREAD_CFLAGS)
+ endif
+
+ # Linker:
+! LD = $(CXX)
+! LDFLAGS += $(OPT) $(EXTRA_LDFLAGS)
+ SOFLAGS = -shared -Wl,-x -Wl,-soname,
+ SOEXT = so
+
+***************
+*** 43,50 ****
+ CRYPTLIBS = -lcrypt
+
+ # Fortran:
+! F77 = f77
+! F77FLAGS = $(OPT)
+ F77LIBS = -lg2c
+
+ # Extras
+--- 42,48 ----
+ CRYPTLIBS = -lcrypt
+
+ # Fortran:
+! F77FLAGS += $(OPT)
+ F77LIBS = -lg2c
+
+ # Extras
diff --git a/devel/root/files/patch-config::Makefile.freebsd5 b/devel/root/files/patch-config::Makefile.freebsd5
new file mode 100644
index 000000000000..096523138d5f
--- /dev/null
+++ b/devel/root/files/patch-config::Makefile.freebsd5
@@ -0,0 +1,90 @@
+*** config/Makefile.freebsd5.orig Tue Jun 15 19:28:13 2004
+--- config/Makefile.freebsd5 Wed Jun 16 15:22:55 2004
+***************
+*** 1,11 ****
+ # -*- mode: makefile -*-
+ #
+! # Makefile of ROOT for FreeBSD 4.5
+
+ PLATFORM = fbsd
+
+ DEBUGFLAGS = -g
+- OPTFLAGS = -O
+ ifeq (debug,$(findstring debug,$(ROOTBUILD)))
+ OPT = $(DEBUGFLAGS)
+ NOOPT =
+--- 1,10 ----
+ # -*- mode: makefile -*-
+ #
+! # Makefile of ROOT for FreeBSD 5.x
+
+ PLATFORM = fbsd
+
+ DEBUGFLAGS = -g
+ ifeq (debug,$(findstring debug,$(ROOTBUILD)))
+ OPT = $(DEBUGFLAGS)
+ NOOPT =
+***************
+*** 15,33 ****
+ endif
+
+ # Compiler:
+! CXX = g++
+! CC = gcc
+! CXXFLAGS = -pipe -W -Wall -fPIC -I/usr/X11R6/include $(EXTRA_CXXFLAGS)
+! CFLAGS = -pipe -W -Wall -fPIC -I/usr/X11R6/include $(EXTRA_CFLAGS)
+ CINTCXXFLAGS = -pipe -W -Wall -fPIC -DG__REGEXP $(EXTRA_CXXFLAGS) \
+ -DG__UNIX -DG__SHAREDLIB -DG__ROOT -DG__REDIRECTIO -DG__OSFDLL
+ CINTCFLAGS = -pipe -W -Wall -fPIC -DG__REGEXP -DG__UNIX -DG__SHAREDLIB \
+ -DG__ROOT -DG__REDIRECTIO -DG__OSFDLL $(EXTRA_CFLAGS)
+ COMPILER = gnu
+
+ # Linker:
+! LD = g++
+! LDFLAGS = $(OPT) $(EXTRA_LDFLAGS)
+ SOFLAGS = -shared -Wl,-x -Wl,-soname,
+ SOEXT = so
+
+--- 14,37 ----
+ endif
+
+ # Compiler:
+! CXXFLAGS += -W -Wall -fPIC -I$(X11BASE)/include -I$(LOCALBASE)/include
+! CXXFLAGS += $(EXTRA_CXXFLAGS)
+! CFLAGS += -W -Wall -fPIC -I$(X11BASE)/include -I$(LOCALBASE)/include
+! CFLAGS += $(EXTRA_CFLAGS)
+ CINTCXXFLAGS = -pipe -W -Wall -fPIC -DG__REGEXP $(EXTRA_CXXFLAGS) \
+ -DG__UNIX -DG__SHAREDLIB -DG__ROOT -DG__REDIRECTIO -DG__OSFDLL
+ CINTCFLAGS = -pipe -W -Wall -fPIC -DG__REGEXP -DG__UNIX -DG__SHAREDLIB \
+ -DG__ROOT -DG__REDIRECTIO -DG__OSFDLL $(EXTRA_CFLAGS)
+ COMPILER = gnu
+
++ ifeq ($(ENABLETHREAD),yes)
++ CXXFLAGS += $(PTHREAD_CFLAGS)
++ CINTCXXFLAGS += $(PTHREAD_CFLAGS)
++ endif
++
+ # Linker:
+! LD = $(CXX)
+! LDFLAGS += $(OPT) $(EXTRA_LDFLAGS)
+ SOFLAGS = -shared -Wl,-x -Wl,-soname,
+ SOEXT = so
+
+***************
+*** 38,45 ****
+ CRYPTLIBS = -lcrypt
+
+ # Fortran:
+! F77 = f77
+! F77FLAGS = $(OPT)
+ F77LIBS = -lg2c
+
+ # Extras
+--- 42,48 ----
+ CRYPTLIBS = -lcrypt
+
+ # Fortran:
+! F77FLAGS += $(OPT)
+ F77LIBS = -lg2c
+
+ # Extras
diff --git a/devel/root/files/patch-config::root-config.in b/devel/root/files/patch-config::root-config.in
new file mode 100644
index 000000000000..ad70021bb492
--- /dev/null
+++ b/devel/root/files/patch-config::root-config.in
@@ -0,0 +1,28 @@
+*** config/root-config.in.orig Mon Jul 5 16:49:16 2004
+--- config/root-config.in Mon Jul 5 16:51:05 2004
+***************
+*** 245,253 ****
+ auxlibs="-lm -lg++"
+ ;;
+ freebsd4)
+! # FreeBSD with glibc
+ auxcflags=
+ auxlibs="-lm -lstdc++"
+ ;;
+ macosx)
+ # MacOS X with gcc (GNU cc v3.1) and possible fink (fink.sf.net)
+--- 245,258 ----
+ auxlibs="-lm -lg++"
+ ;;
+ freebsd4)
+! # FreeBSD 4.x with glibc
+ auxcflags=
+ auxlibs="-lm -lstdc++"
++ ;;
++ freebsd5)
++ # FreeBSD 5.x with glibc
++ auxcflags="PTHREAD-CFLAGS"
++ auxlibs="PTHREAD-LIBS -lm -lstdc++"
+ ;;
+ macosx)
+ # MacOS X with gcc (GNU cc v3.1) and possible fink (fink.sf.net)
diff --git a/devel/root/files/patch-configure b/devel/root/files/patch-configure
index f68b2459fbf3..59586f005ba1 100644
--- a/devel/root/files/patch-configure
+++ b/devel/root/files/patch-configure
@@ -1,11 +1,35 @@
---- configure.orig Thu Feb 19 01:11:18 2004
-+++ configure Sat Apr 17 13:54:24 2004
-@@ -901,7 +901,7 @@
- ;;
- freebsd*)
- if test "x$enable_thread" = "xyes"; then
-- threadlib="-pthread"
-+ threadlib="$PTHREAD_LIBS"
- threadlibdir=
- fi
- ;;
+*** configure.orig Tue Jun 15 19:44:02 2004
+--- configure Wed Jun 16 09:42:21 2004
+***************
+*** 905,918 ****
+ ;;
+ freebsd*)
+ if test "x$enable_thread" = "xyes"; then
+! threadlib="-pthread"
+ threadlibdir=
+ fi
+ ;;
+ esac
+ if test "x$enable_thread" = "xyes" && \
+ test ! "$platform" = "win32" && \
+! test ! "$platform" = "freebsd4" ; then
+ check_library "libpthread" "$enable_shared" "$threadlibdir" \
+ $THREAD $THREAD/lib /usr/lib /usr/local/lib /usr/lib/X11 \
+ /usr/local/lib/X11 /usr/X11R6/lib /usr/local/X11R6/lib \
+--- 905,920 ----
+ ;;
+ freebsd*)
+ if test "x$enable_thread" = "xyes"; then
+! threadlib="$PTHREAD_LIBS"
+ threadlibdir=
+ fi
+ ;;
+ esac
+ if test "x$enable_thread" = "xyes" && \
+ test ! "$platform" = "win32" && \
+! test ! "$platform" = "freebsd5" && \
+! test ! "$platform" = "freebsd4" && \
+! test ! "$platform" = "freebsd" ; then
+ check_library "libpthread" "$enable_shared" "$threadlibdir" \
+ $THREAD $THREAD/lib /usr/lib /usr/local/lib /usr/lib/X11 \
+ /usr/local/lib/X11 /usr/X11R6/lib /usr/local/X11R6/lib \
diff --git a/devel/root/files/patch-gcc34 b/devel/root/files/patch-gcc34
new file mode 100644
index 000000000000..04b4be260321
--- /dev/null
+++ b/devel/root/files/patch-gcc34
@@ -0,0 +1,51 @@
+===================================================================
+RCS file: /home/cvs/root/cint/src/gcc3strm.cxx,v
+retrieving revision 1.17
+retrieving revision 1.18
+diff -u -r1.17 -r1.18
+--- cint/src/gcc3strm.cxx 2004/04/26 21:50:31 1.17
++++ cint/src/gcc3strm.cxx 2004/07/01 20:02:52 1.18
+@@ -139,7 +139,8 @@
+ }
+
+ static int G__G__stream_5_4_0(G__value *result7,G__CONST char *funcname,struct G__param *libp,int hash) {
+- G__letint(result7,108,(long)((const fpos<mbstate_t>*)(G__getstructoffset()))->operator long());
++ const fpos<mbstate_t>*pos = (const fpos<mbstate_t>*)(G__getstructoffset());
++ G__letint(result7,108,(long)(*pos));
+ return(1 || funcname || hash || result7 || libp) ;
+ }
+
+@@ -2023,13 +2024,13 @@
+ return(1 || funcname || hash || result7 || libp) ;
+ }
+
+-static int G__G__stream__1_16(G__value *result7,G__CONST char *funcname,struct G__param *libp,int hash) {
+- {
+- const ostream& obj=operator<<(*(ostream*)libp->para[0].ref,*(streampos*)libp->para[1].ref);
+- result7->ref=(long)(&obj); result7->obj.i=(long)(&obj);
+- }
+- return(1 || funcname || hash || result7 || libp) ;
+-}
++// static int G__G__stream__1_16(G__value *result7,G__CONST char *funcname,struct G__param *libp,int hash) {
++// {
++// const ostream& obj=operator<<(*(ostream*)libp->para[0].ref,*(streampos*)libp->para[1].ref);
++// result7->ref=(long)(&obj); result7->obj.i=(long)(&obj);
++// }
++// return(1 || funcname || hash || result7 || libp) ;
++// }
+
+ static int G__G__stream__2_16(G__value *result7,G__CONST char *funcname,struct G__param *libp,int hash) {
+ {
+@@ -3621,9 +3622,9 @@
+ G__memfunc_setup("operator<<",996,G__G__stream__0_16,117,G__get_linked_tagnum(&G__G__streamLN_basic_ostreamlEcharcOchar_traitslEchargRsPgR),G__defined_typename("ostream"),1,2,1,1,0,
+ "u 'basic_ostream<char,char_traits<char> >' 'ostream' 1 - - g - - 0 - -",(char*)NULL
+ ,(void*)NULL,0);
+- G__memfunc_setup("operator<<",996,G__G__stream__1_16,117,G__get_linked_tagnum(&G__G__streamLN_basic_ostreamlEcharcOchar_traitslEchargRsPgR),G__defined_typename("ostream"),1,2,1,1,0,
+-"u 'basic_ostream<char,char_traits<char> >' 'ostream' 1 - - u 'fpos<mbstate_t>' 'streampos' 11 - -",(char*)NULL
+-,(void*)NULL,0);
++// G__memfunc_setup("operator<<",996,G__G__stream__1_16,117,G__get_linked_tagnum(&G__G__streamLN_basic_ostreamlEcharcOchar_traitslEchargRsPgR),G__defined_typename("ostream"),1,2,1,1,0,
++// "u 'basic_ostream<char,char_traits<char> >' 'ostream' 1 - - u 'fpos<mbstate_t>' 'streampos' 11 - -",(char*)NULL
++// ,(void*)NULL,0);
+ G__memfunc_setup("operator>>",1000,G__G__stream__2_16,117,G__get_linked_tagnum(&G__G__streamLN_basic_istreamlEcharcOchar_traitslEchargRsPgR),G__defined_typename("istream"),1,2,1,1,0,
+ "u 'basic_istream<char,char_traits<char> >' 'istream' 1 - - c - - 1 - -",(char*)NULL
+ ,(void*)NULL,0);
diff --git a/devel/root/files/patch-test::Makefile.arch b/devel/root/files/patch-test::Makefile.arch
index fda34e13eef8..e144e7e95b8a 100644
--- a/devel/root/files/patch-test::Makefile.arch
+++ b/devel/root/files/patch-test::Makefile.arch
@@ -1,25 +1,40 @@
---- test/Makefile.arch.orig Sat Apr 17 10:25:16 2004
-+++ test/Makefile.arch Sat Apr 17 10:41:58 2004
-@@ -9,7 +9,6 @@
- ARCH := $(shell root-config --arch)
- PLATFORM = $(ARCH)
-
--CXX =
- ObjSuf = o
- SrcSuf = cxx
- ExeSuf =
-@@ -426,10 +425,10 @@
-
- ifeq ($(ARCH),freebsd4)
- # FreeBSD with glibc
--CXX = g++
--CXXFLAGS = -O -pipe -W -Wall -fPIC
--LD = g++
--LDFLAGS = -O
-+#CXX = g++
-+CXXFLAGS += -W -Wall -fPIC
-+LD = $(CXX)
-+#LDFLAGS = -O
- SOFLAGS = -shared -Wl,-x
- endif
-
+*** test/Makefile.arch.orig Tue Jun 15 20:02:44 2004
+--- test/Makefile.arch Wed Jun 16 10:05:39 2004
+***************
+*** 9,15 ****
+ ARCH := $(shell root-config --arch)
+ PLATFORM = $(ARCH)
+
+- CXX =
+ ObjSuf = o
+ SrcSuf = cxx
+ ExeSuf =
+--- 9,14 ----
+***************
+*** 426,435 ****
+
+ ifeq ($(ARCH),freebsd4)
+ # FreeBSD with glibc
+! CXX = g++
+! CXXFLAGS = -O -pipe -W -Wall -fPIC
+! LD = g++
+! LDFLAGS = -O
+ SOFLAGS = -shared -Wl,-x
+ endif
+
+--- 425,439 ----
+
+ ifeq ($(ARCH),freebsd4)
+ # FreeBSD with glibc
+! CXXFLAGS += -W -Wall -fPIC
+! LD = $(CXX)
+! SOFLAGS = -shared -Wl,-x
+! endif
+!
+! ifeq ($(ARCH),freebsd5)
+! # FreeBSD with glibc
+! CXXFLAGS += -W -Wall -fPIC
+! LD = $(CXX)
+ SOFLAGS = -shared -Wl,-x
+ endif
+