aboutsummaryrefslogtreecommitdiff
path: root/devel/ros
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2010-10-27 08:29:01 +0000
committerRene Ladan <rene@FreeBSD.org>2010-10-27 08:29:01 +0000
commitc292882c64a4d92b65fb053eb56c453be5d0e5c9 (patch)
tree0524acea8836e8ffac7b4b00793fa7a2f25bbe36 /devel/ros
parente028a2f9bf21023c33f88f5848760acb07c894fb (diff)
downloadports-c292882c64a4d92b65fb053eb56c453be5d0e5c9.tar.gz
ports-c292882c64a4d92b65fb053eb56c453be5d0e5c9.zip
Notes
Diffstat (limited to 'devel/ros')
-rw-r--r--devel/ros/Makefile4
-rw-r--r--devel/ros/distinfo6
-rw-r--r--devel/ros/files/patch-308339
-rw-r--r--devel/ros/files/patch-308524
-rw-r--r--devel/ros/pkg-plist8
5 files changed, 12 insertions, 69 deletions
diff --git a/devel/ros/Makefile b/devel/ros/Makefile
index 7298ebe80755..ac6c6a6fcd13 100644
--- a/devel/ros/Makefile
+++ b/devel/ros/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= ros
-PORTVERSION= 1.2.3
+PORTVERSION= 1.2.4
CATEGORIES= devel
MASTER_SITES= ftp://rene-ladan.nl/pub/distfiles/${PORTNAME}/
DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.bz2 gtest-1.3.0.tar.gz SWIG-1.3.29-wx.tar.gz
@@ -211,7 +211,7 @@ do-install:
.endfor
# make scripts executable
.for f in 3rdparty/gtest/gtest/bin/gtest-config 3rdparty/wxswig/bin/swig \
- core/rosbuild/bin/check_same_directories.py \
+ core/mk/make_pydev_project.py core/rosbuild/bin/check_same_directories.py \
core/rosbuild/bin/checkout_latest_stable \
core/rosbuild/bin/create_release.py core/rosbuild/bin/download_checkmd5.py \
core/rosbuild/bin/makestackdist core/rosbuild/bin/package_source.py \
diff --git a/devel/ros/distinfo b/devel/ros/distinfo
index 575d1666f2a2..5683fc80ea32 100644
--- a/devel/ros/distinfo
+++ b/devel/ros/distinfo
@@ -1,6 +1,6 @@
-MD5 (ros/ros-1.2.3.tar.bz2) = 0f7e04efb2f4ae16b76c237a250208f6
-SHA256 (ros/ros-1.2.3.tar.bz2) = 4061e746a45f90592a01b22db04849a3e2c8201c0cc3009206c32c23962f7478
-SIZE (ros/ros-1.2.3.tar.bz2) = 1534842
+MD5 (ros/ros-1.2.4.tar.bz2) = f1b20ea6beb303ce64bf2a10a40bb71a
+SHA256 (ros/ros-1.2.4.tar.bz2) = 199bd4d9f2578a165dfb42cd24bd0a5bfa489ec2085cd1ac8e5f6d2ab2ef2516
+SIZE (ros/ros-1.2.4.tar.bz2) = 1535133
MD5 (ros/gtest-1.3.0.tar.gz) = 714e9c00c0616ea72ba076c6c5f401d2
SHA256 (ros/gtest-1.3.0.tar.gz) = 03a4c85cb7cf1754e052317b289625daa73485da664ede18ba21cf754d3e8bd7
SIZE (ros/gtest-1.3.0.tar.gz) = 636326
diff --git a/devel/ros/files/patch-3083 b/devel/ros/files/patch-3083
deleted file mode 100644
index fa3e2a4e77ae..000000000000
--- a/devel/ros/files/patch-3083
+++ /dev/null
@@ -1,39 +0,0 @@
-Index: rosdep.yaml
-===================================================================
---- rosdep.yaml (revision 11635)
-+++ rosdep.yaml (working copy)
-@@ -14,7 +14,7 @@
- macports: apr apr-util
- gentoo: dev-libs/apr dev-libs/apr-util
- cygwin: libapr1 libaprutil1
-- freebsd: apr-ipv6-gdbm-db42
-+ freebsd: builtin # i.e. ignore, only needed to manually build log4cxx on other OSes
- python:
- ubuntu: python-dev
- debian: python-dev
-@@ -161,7 +161,6 @@
- gentoo: dev-libs/boost
- cygwin: libboost-devel libboost1.40
- freebsd: boost-python-libs
-- # freebsd: boost-pyste is more complete
- zlib:
- ubuntu: zlib1g-dev
- debian: zlib1g-dev
-@@ -351,7 +350,7 @@
- arch: autoconf
- macports: autoconf
- gentoo: sys-devel/autoconf
-- freebsd: autoconf213 autoconf262
-+ freebsd: autoconf213 autoconf268
- automake:
- ubuntu: automake
- debian: automake
-@@ -360,7 +359,7 @@
- arch: automake
- macports: automake
- gentoo: sys-devel/automake
-- freebsd: automake14 automake15 automake16 automake17 automake18 automake19 automake110
-+ freebsd: automake14 automake111
- libtool:
- ubuntu:
- '10.04': libtool libltdl-dev
diff --git a/devel/ros/files/patch-3085 b/devel/ros/files/patch-3085
deleted file mode 100644
index 6e12ca575fe3..000000000000
--- a/devel/ros/files/patch-3085
+++ /dev/null
@@ -1,24 +0,0 @@
-Index: core/roslib/src/roslib/packages.py
-===================================================================
---- core/roslib/src/roslib/packages.py (revision 11635)
-+++ core/roslib/src/roslib/packages.py (working copy)
-@@ -502,7 +502,8 @@
- if m in files:
- test_path = os.path.join(p, node_type)
- s = os.stat(test_path)
-- if (s.st_mode & stat.S_IRWXU == stat.S_IRWXU):
-+ if (s.st_mode & (stat.S_IRUSR | stat.S_IXUSR) ==
-+ (stat.S_IRUSR | stat.S_IXUSR)):
- return test_path
- if '.svn' in dirs:
- dirs.remove('.svn')
-@@ -514,7 +515,8 @@
- if node_type in files:
- test_path = os.path.join(p, node_type)
- s = os.stat(test_path)
-- if (s.st_mode & stat.S_IRWXU == stat.S_IRWXU):
-+ if (s.st_mode & (stat.S_IRUSR | stat.S_IXUSR) ==
-+ (stat.S_IRUSR | stat.S_IXUSR)):
- return test_path
- if '.svn' in dirs:
- dirs.remove('.svn')
diff --git a/devel/ros/pkg-plist b/devel/ros/pkg-plist
index 0a8988e35a60..c41b284a01de 100644
--- a/devel/ros/pkg-plist
+++ b/devel/ros/pkg-plist
@@ -828,6 +828,7 @@ ros/core/mk/download_unpack_build.mk
ros/core/mk/eclipse.awk
ros/core/mk/git_checkout.mk
ros/core/mk/manifest.xml
+ros/core/mk/make_pydev_project.py
ros/core/mk/svn_checkout.mk
ros/core/rosbuild/FindPkgConfig.cmake
ros/core/rosbuild/ROS_NOBUILD
@@ -1088,7 +1089,6 @@ ros/core/roslib/msg_gen/cpp/include/roslib/Log.h
ros/core/roslib/msg_gen/generated
ros/core/roslib/rosdoc.yaml
ros/core/roslib/scripts/gendeps
-ros/core/roslib/scripts/python-reserved-words.txt
ros/core/roslib/scripts/pythontest
ros/core/roslib/src/debug.cpp
ros/core/roslib/src/package.cpp
@@ -2711,6 +2711,7 @@ ros/test/test_rospy/msg/EmbedTest.msg
ros/test/test_rospy/msg/Floats.msg
ros/test/test_rospy/msg/HeaderHeaderVal.msg
ros/test/test_rospy/msg/HeaderVal.msg
+ros/test/test_rospy/msg/PythonKeyword.msg
ros/test/test_rospy/msg/TestConstants.msg
ros/test/test_rospy/msg/TestFixedArray.msg
ros/test/test_rospy/msg/TransitiveImport.msg
@@ -2722,6 +2723,7 @@ ros/test/test_rospy/msg/lisp/test_rospy/.EmbedTest.asd-dep
ros/test/test_rospy/msg/lisp/test_rospy/.Floats.asd-dep
ros/test/test_rospy/msg/lisp/test_rospy/.HeaderHeaderVal.asd-dep
ros/test/test_rospy/msg/lisp/test_rospy/.HeaderVal.asd-dep
+ros/test/test_rospy/msg/lisp/test_rospy/.PythonKeyword.asd-dep
ros/test/test_rospy/msg/lisp/test_rospy/.TestConstants.asd-dep
ros/test/test_rospy/msg/lisp/test_rospy/.TestFixedArray.asd-dep
ros/test/test_rospy/msg/lisp/test_rospy/.TransitiveImport.asd-dep
@@ -2733,6 +2735,7 @@ ros/test/test_rospy/msg/lisp/test_rospy/EmbedTest.lisp
ros/test/test_rospy/msg/lisp/test_rospy/Floats.lisp
ros/test/test_rospy/msg/lisp/test_rospy/HeaderHeaderVal.lisp
ros/test/test_rospy/msg/lisp/test_rospy/HeaderVal.lisp
+ros/test/test_rospy/msg/lisp/test_rospy/PythonKeyword.lisp
ros/test/test_rospy/msg/lisp/test_rospy/TestConstants.lisp
ros/test/test_rospy/msg/lisp/test_rospy/TestFixedArray.lisp
ros/test/test_rospy/msg/lisp/test_rospy/TransitiveImport.lisp
@@ -2745,6 +2748,7 @@ ros/test/test_rospy/msg/lisp/test_rospy/_package_EmbedTest.lisp
ros/test/test_rospy/msg/lisp/test_rospy/_package_Floats.lisp
ros/test/test_rospy/msg/lisp/test_rospy/_package_HeaderHeaderVal.lisp
ros/test/test_rospy/msg/lisp/test_rospy/_package_HeaderVal.lisp
+ros/test/test_rospy/msg/lisp/test_rospy/_package_PythonKeyword.lisp
ros/test/test_rospy/msg/lisp/test_rospy/_package_TestConstants.lisp
ros/test/test_rospy/msg/lisp/test_rospy/_package_TestFixedArray.lisp
ros/test/test_rospy/msg/lisp/test_rospy/_package_TransitiveImport.lisp
@@ -2757,6 +2761,7 @@ ros/test/test_rospy/msg_gen/cpp/include/test_rospy/EmbedTest.h
ros/test/test_rospy/msg_gen/cpp/include/test_rospy/Floats.h
ros/test/test_rospy/msg_gen/cpp/include/test_rospy/HeaderHeaderVal.h
ros/test/test_rospy/msg_gen/cpp/include/test_rospy/HeaderVal.h
+ros/test/test_rospy/msg_gen/cpp/include/test_rospy/PythonKeyword.h
ros/test/test_rospy/msg_gen/cpp/include/test_rospy/TestConstants.h
ros/test/test_rospy/msg_gen/cpp/include/test_rospy/TestFixedArray.h
ros/test/test_rospy/msg_gen/cpp/include/test_rospy/TransitiveImport.h
@@ -2773,6 +2778,7 @@ ros/test/test_rospy/src/test_rospy/msg/_EmbedTest.py
ros/test/test_rospy/src/test_rospy/msg/_Floats.py
ros/test/test_rospy/src/test_rospy/msg/_HeaderHeaderVal.py
ros/test/test_rospy/src/test_rospy/msg/_HeaderVal.py
+ros/test/test_rospy/src/test_rospy/msg/_PythonKeyword.py
ros/test/test_rospy/src/test_rospy/msg/_TestConstants.py
ros/test/test_rospy/src/test_rospy/msg/_TestFixedArray.py
ros/test/test_rospy/src/test_rospy/msg/_TransitiveImport.py