aboutsummaryrefslogtreecommitdiff
path: root/devel/rote
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2005-06-10 05:07:21 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2005-06-10 05:07:21 +0000
commitf048ecd2d8313c31e7b6a573c8aa3768c6b5a5b2 (patch)
tree3c68c6567d807c3a0cd4a1f28bbf588ce7ebd5be /devel/rote
parent5140032e039da78941a05aa5aff2bf7f36c3bf5d (diff)
downloadports-f048ecd2d8313c31e7b6a573c8aa3768c6b5a5b2.tar.gz
ports-f048ecd2d8313c31e7b6a573c8aa3768c6b5a5b2.zip
Notes
Diffstat (limited to 'devel/rote')
-rw-r--r--devel/rote/Makefile25
-rw-r--r--devel/rote/distinfo2
-rw-r--r--devel/rote/files/patch-rote.c15
-rw-r--r--devel/rote/pkg-descr8
4 files changed, 50 insertions, 0 deletions
diff --git a/devel/rote/Makefile b/devel/rote/Makefile
new file mode 100644
index 000000000000..e354bedee1ec
--- /dev/null
+++ b/devel/rote/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: ROTE
+# Date created: 10 Jun 2005
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rote
+PORTVERSION= 0.2.6
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= A simple library for VT102 terminal emulation
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+
+PLIST_FILES= bin/rote-config include/rote/rote.h lib/librote.so.0.2.6 \
+ lib/librote.so.0 lib/librote.so
+PLIST_DIRS= include/rote
+
+.include <bsd.port.mk>
diff --git a/devel/rote/distinfo b/devel/rote/distinfo
new file mode 100644
index 000000000000..5fa32ebfef81
--- /dev/null
+++ b/devel/rote/distinfo
@@ -0,0 +1,2 @@
+MD5 (rote-0.2.6.tar.gz) = a80074dc2fbabd6e204bc07a61e57120
+SIZE (rote-0.2.6.tar.gz) = 61440
diff --git a/devel/rote/files/patch-rote.c b/devel/rote/files/patch-rote.c
new file mode 100644
index 000000000000..5256da180776
--- /dev/null
+++ b/devel/rote/files/patch-rote.c
@@ -0,0 +1,15 @@
+--- rote.c.orig Wed Oct 6 19:18:49 2004
++++ rote.c Fri Jun 10 11:57:27 2005
+@@ -21,8 +21,11 @@
+
+ #include "rote.h"
+ #include "roteprivate.h"
++#include <sys/types.h>
++#include <sys/ioctl.h>
++#include <termios.h>
++#include <libutil.h>
+ #include <stdlib.h>
+-#include <pty.h>
+ #include <stdio.h>
+ #include <string.h>
+
diff --git a/devel/rote/pkg-descr b/devel/rote/pkg-descr
new file mode 100644
index 000000000000..8a0f834b1f86
--- /dev/null
+++ b/devel/rote/pkg-descr
@@ -0,0 +1,8 @@
+ROTE is a simple C library for VT102 terminal emulation. It allows the
+programmer to set up virtual 'screens' and send them data. The virtual
+screens will emulate the behavior of a VT102 terminal, interpreting escape
+sequences, control characters and such. The library supports ncurses as
+well so that you may render the virtual screen to the real screen when you
+need to.
+
+WWW: http://rote.sourceforge.net/