aboutsummaryrefslogtreecommitdiff
path: root/devel/rpc2/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2008-04-15 03:48:26 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2008-04-15 03:48:26 +0000
commitf4fa978598a53baea9cd83f9edbd1755a716123f (patch)
tree3f677b265db3de3b487a4e8f3d5b23402b39f32f /devel/rpc2/Makefile
parent7fde5f11d3e630897127e2a2638cfdb9458d2f83 (diff)
downloadports-f4fa978598a53baea9cd83f9edbd1755a716123f.tar.gz
ports-f4fa978598a53baea9cd83f9edbd1755a716123f.zip
Notes
Diffstat (limited to 'devel/rpc2/Makefile')
-rw-r--r--devel/rpc2/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/devel/rpc2/Makefile b/devel/rpc2/Makefile
index ce9d80a4defa..d617210ec492 100644
--- a/devel/rpc2/Makefile
+++ b/devel/rpc2/Makefile
@@ -6,23 +6,31 @@
#
PORTNAME= rpc2
-PORTVERSION= 2.5
+PORTVERSION= 2.7
CATEGORIES= devel
MASTER_SITES= ftp://ftp.coda.cs.cmu.edu/pub/rpc2/src/ \
ftp://ftp.wu-wien.ac.at/pub/systems/coda/src/ \
ftp://ftp.planetmirror.com/pub/coda/src/ \
ftp://ftp.nctu.edu.tw/mirror/Coda/src/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= wenheping@gmail.com
COMMENT= An interprocess communication library
LIB_DEPENDS= lwp.2:${PORTSDIR}/devel/lwp
USE_GMAKE= yes
+USE_GNOME= pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_PERL5= yes
USE_LDCONFIG= yes
+post-extract:
+.for file in pkgs/Makefile.in
+ @${REINPLACE_CMD} -e \
+ 's#(libdir)#{prefix}/libdata#g' \
+ ${WRKSRC}/${file}
+.endfor
+
.include <bsd.port.mk>