aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-amstd
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-08-07 17:15:06 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-08-07 17:15:06 +0000
commitcd1d50eb08fefd091401ac45d81c225ac24920fc (patch)
treef5195afcb927cef5e3ed6aec9dd6e655c101af1e /devel/ruby-amstd
parentc8b2a40e7936d06271e36a2b20c453a478fe308e (diff)
downloadports-cd1d50eb08fefd091401ac45d81c225ac24920fc.tar.gz
ports-cd1d50eb08fefd091401ac45d81c225ac24920fc.zip
Notes
Diffstat (limited to 'devel/ruby-amstd')
-rw-r--r--devel/ruby-amstd/Makefile66
-rw-r--r--devel/ruby-amstd/distinfo1
-rw-r--r--devel/ruby-amstd/pkg-comment1
-rw-r--r--devel/ruby-amstd/pkg-descr17
-rw-r--r--devel/ruby-amstd/pkg-plist26
5 files changed, 111 insertions, 0 deletions
diff --git a/devel/ruby-amstd/Makefile b/devel/ruby-amstd/Makefile
new file mode 100644
index 000000000000..b0ab5d003c2f
--- /dev/null
+++ b/devel/ruby-amstd/Makefile
@@ -0,0 +1,66 @@
+# New ports collection makefile for: Ruby-amstd
+# Date created: 7 Aug 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= amstd
+PORTVERSION= 1.9.3
+CATEGORIES= devel # ruby
+MASTER_SITES= http://www1.u-netsurf.ne.jp/~brew/mine/soft/
+PKGNAMEPREFIX= ruby-
+
+MAINTAINER= knu@FreeBSD.org
+
+RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+
+NO_BUILD= yes
+
+PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
+
+RUBY= ${LOCALBASE}/bin/ruby
+RUBY_VER= 1.4
+RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+
+DOCS_EN= README.en
+DOCS_JA= README.ja
+MODULES= bench.rb \
+ bug.rb \
+ collfrom.rb \
+ dispatch.rb \
+ errutil.rb \
+ extmod.rb \
+ fileutils.rb \
+ futils.rb \
+ gconst.rb \
+ getdep.rb \
+ info.rb \
+ must.rb \
+ pipeline.rb \
+ rbparams.rb \
+ recycle.rb \
+ rubyemu.rb \
+ strquote.rb \
+ symbol.rb \
+ timer.rb \
+ to_s.rb \
+ version.rb
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/ruby/site_ruby/${RUBY_VER}/amstd
+.for f in ${MODULES}
+ ${INSTALL_DATA} ${WRKSRC}/lib/amstd/${f} \
+ ${PREFIX}/lib/ruby/site_ruby/${RUBY_VER}/amstd/
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/ruby/amstd/ja
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/amstd/
+.endfor
+.for f in ${DOCS_JA}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/amstd/ja/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-amstd/distinfo b/devel/ruby-amstd/distinfo
new file mode 100644
index 000000000000..a6e9a38b536d
--- /dev/null
+++ b/devel/ruby-amstd/distinfo
@@ -0,0 +1 @@
+MD5 (amstd-1.9.3.tar.gz) = 7a7bb9606d848a16e2f1ddc8a3364216
diff --git a/devel/ruby-amstd/pkg-comment b/devel/ruby-amstd/pkg-comment
new file mode 100644
index 000000000000..5af1e7c61a06
--- /dev/null
+++ b/devel/ruby-amstd/pkg-comment
@@ -0,0 +1 @@
+A collection of miscellaneous Ruby modules
diff --git a/devel/ruby-amstd/pkg-descr b/devel/ruby-amstd/pkg-descr
new file mode 100644
index 000000000000..b521016fc69b
--- /dev/null
+++ b/devel/ruby-amstd/pkg-descr
@@ -0,0 +1,17 @@
+This is the AMbicious STanDard library, available under GPL2.
+
+It is a collection of miscellaneous Ruby modules by Minero Aoki.
+Several modules of his are using those modules.
+
+bench.rb: very simple benchmark packing.rb: makes package (.tar.gz)
+bug.rb: 'bug!' method pipeline.rb: filter file
+dispatch.rb: "event handler" method rbparams.rb: parameters related ruby
+errutil.rb: protects exception recycle.rb: recycles objects
+extmod.rb: abstract/property methods rubyemu.rb: ruby emuration
+futils.rb: file utilities strquote.rb: String#quoted
+gconst.rb: defines global constant timer.rb: timer class
+getdep.rb: gets file dependency to_s.rb: _name2str, _type2str
+inst.rb: helps installation version.rb: VersionNumber class
+must.rb: must/must_have/must_be methods
+
+WWW: http://www1.u-netsurf.ne.jp/~brew/mine/en/index.html
diff --git a/devel/ruby-amstd/pkg-plist b/devel/ruby-amstd/pkg-plist
new file mode 100644
index 000000000000..3c401737d6ae
--- /dev/null
+++ b/devel/ruby-amstd/pkg-plist
@@ -0,0 +1,26 @@
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/bench.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/bug.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/collfrom.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/dispatch.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/errutil.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/extmod.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/fileutils.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/futils.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/gconst.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/getdep.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/info.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/must.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/pipeline.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/rbparams.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/recycle.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/rubyemu.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/strquote.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/symbol.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/timer.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/to_s.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/version.rb
+@dirrm lib/ruby/site_ruby/%%RUBY_VER%%/amstd
+share/doc/ruby/amstd/README.en
+share/doc/ruby/amstd/ja/README.ja
+@dirrm share/doc/ruby/amstd/ja
+@dirrm share/doc/ruby/amstd