aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-aspectr
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-04-23 19:54:18 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-04-23 19:54:18 +0000
commita6475f0168b297fee7278520c55fade628b1f502 (patch)
treeb62f1fb7053dbce4937f44691ba595a1444367ef /devel/ruby-aspectr
parent0b1899cc4e4f107635c0590afebf547347469dfc (diff)
downloadports-a6475f0168b297fee7278520c55fade628b1f502.tar.gz
ports-a6475f0168b297fee7278520c55fade628b1f502.zip
Notes
Diffstat (limited to 'devel/ruby-aspectr')
-rw-r--r--devel/ruby-aspectr/Makefile37
-rw-r--r--devel/ruby-aspectr/distinfo1
-rw-r--r--devel/ruby-aspectr/pkg-comment1
-rw-r--r--devel/ruby-aspectr/pkg-descr6
-rw-r--r--devel/ruby-aspectr/pkg-plist7
5 files changed, 52 insertions, 0 deletions
diff --git a/devel/ruby-aspectr/Makefile b/devel/ruby-aspectr/Makefile
new file mode 100644
index 000000000000..fa41fcc8a1af
--- /dev/null
+++ b/devel/ruby-aspectr/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: ruby-aspectr
+# Date created: 08 April 2002
+# Whom: Sean Chittenden <sean@chittenden.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aspectr
+PORTVERSION= 0.3.5
+CATEGORIES= devel ruby
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/./-/g}
+DIST_SUBDIR= ruby
+
+MAINTAINER= sean@chittenden.org
+
+RUN_DEPENDS= ${RUBY_SITELIBDIR}/runit/error.rb:${PORTSDIR}/devel/ruby-unit
+
+USE_RUBY= yes
+
+NO_BUILD= yes
+
+DOCS= CHANGELOG README TODO
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/lib/aspectr.rb ${RUBY_SITELIBDIR}/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PORTDOCS}${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/examples/logger.rb ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-aspectr/distinfo b/devel/ruby-aspectr/distinfo
new file mode 100644
index 000000000000..60209983194f
--- /dev/null
+++ b/devel/ruby-aspectr/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/aspectr-0-3-5.tar.gz) = c640a1a82802ddb107c3ee1245a22705
diff --git a/devel/ruby-aspectr/pkg-comment b/devel/ruby-aspectr/pkg-comment
new file mode 100644
index 000000000000..254ec65f2c82
--- /dev/null
+++ b/devel/ruby-aspectr/pkg-comment
@@ -0,0 +1 @@
+Ruby libraries for Aspect programming
diff --git a/devel/ruby-aspectr/pkg-descr b/devel/ruby-aspectr/pkg-descr
new file mode 100644
index 000000000000..39bd0093638b
--- /dev/null
+++ b/devel/ruby-aspectr/pkg-descr
@@ -0,0 +1,6 @@
+This package allows Ruby developers to write their code using aspect-
+oriented programming style. AspectR is somewhat similar to AspectJ.
+
+WWW: http://aspectr.sourceforge.net/
+
+- Sean Chittenden <sean@chittenden.org>
diff --git a/devel/ruby-aspectr/pkg-plist b/devel/ruby-aspectr/pkg-plist
new file mode 100644
index 000000000000..c45a420b6e3d
--- /dev/null
+++ b/devel/ruby-aspectr/pkg-plist
@@ -0,0 +1,7 @@
+%%RUBY_SITELIBDIR%%/aspectr.rb
+%%PORTDOCS%%%%RUBY_DOCDIR%%/aspectr/CHANGELOG
+%%PORTDOCS%%%%RUBY_DOCDIR%%/aspectr/README
+%%PORTDOCS%%%%RUBY_DOCDIR%%/aspectr/TODO
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/aspectr
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/aspectr/logger.rb
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/aspectr