aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-date2/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-08-07 17:15:06 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-08-07 17:15:06 +0000
commitcd1d50eb08fefd091401ac45d81c225ac24920fc (patch)
treef5195afcb927cef5e3ed6aec9dd6e655c101af1e /devel/ruby-date2/Makefile
parentc8b2a40e7936d06271e36a2b20c453a478fe308e (diff)
downloadports-cd1d50eb08fefd091401ac45d81c225ac24920fc.tar.gz
ports-cd1d50eb08fefd091401ac45d81c225ac24920fc.zip
Notes
Diffstat (limited to 'devel/ruby-date2/Makefile')
-rw-r--r--devel/ruby-date2/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/devel/ruby-date2/Makefile b/devel/ruby-date2/Makefile
new file mode 100644
index 000000000000..24fba534182c
--- /dev/null
+++ b/devel/ruby-date2/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: Ruby-date2
+# Date created: 7 Aug 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= date2
+PORTVERSION= 2
+CATEGORIES= devel # ruby
+MASTER_SITES= http://www.kt.rim.or.jp/~tadf/
+PKGNAMEPREFIX= ruby-
+
+MAINTAINER= knu@FreeBSD.org
+
+RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+
+NO_BUILD= yes
+
+PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
+
+RUBY= ${LOCALBASE}/bin/ruby
+RUBY_VER= 1.4
+RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+
+MODULES= date2.rb date3.rb holiday.rb odate.rb \
+ parsedate2.rb parsedate2.ry parsedate3.rb \
+ qholiday.rb strftime.rb strptime.rb
+
+DOCS_EN= CHANGES.en MANUAL.en README.en
+DOCS_JA= MANUAL README
+EXAMPLES_EN= cal.rb daylight.rb goodfriday.rb
+EXAMPLES_JA= ncal.rb
+
+do-install:
+.for f in ${MODULES}
+ ${INSTALL_DATA} ${WRKSRC}/lib/${f} ${PREFIX}/lib/ruby/site_ruby/
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/ruby/date2/examples/ja
+ ${MKDIR} ${PREFIX}/share/doc/ruby/date2/ja
+.for f in ${EXAMPLES_EN}
+ ${INSTALL_DATA} ${WRKSRC}/sample/${f} ${PREFIX}/share/doc/ruby/date2/examples/
+.endfor
+.for f in ${EXAMPLES_JA}
+ ${INSTALL_DATA} ${WRKSRC}/sample/${f} ${PREFIX}/share/doc/ruby/date2/examples/ja/
+.endfor
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/date2/
+.endfor
+.for f in ${DOCS_JA}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/date2/ja/
+.endfor
+.endif
+
+.include <bsd.port.mk>