aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-date2/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-09-07 07:29:07 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-09-07 07:29:07 +0000
commit1fa355ad263385a73305e7a1b85ce06f4b39bcda (patch)
tree68e79cb942601c0800cd13157eb5a2fbae6ddbce /devel/ruby-date2/Makefile
parentef19b346c19e1e342e952f369c5aff7ab7128a10 (diff)
downloadports-1fa355ad263385a73305e7a1b85ce06f4b39bcda.tar.gz
ports-1fa355ad263385a73305e7a1b85ce06f4b39bcda.zip
Notes
Diffstat (limited to 'devel/ruby-date2/Makefile')
-rw-r--r--devel/ruby-date2/Makefile28
1 files changed, 12 insertions, 16 deletions
diff --git a/devel/ruby-date2/Makefile b/devel/ruby-date2/Makefile
index f0842292d173..651273408a11 100644
--- a/devel/ruby-date2/Makefile
+++ b/devel/ruby-date2/Makefile
@@ -9,21 +9,15 @@ PORTNAME= date2
PORTVERSION= 2
CATEGORIES= devel ruby
MASTER_SITES= http://www.kt.rim.or.jp/~tadf/
-PKGNAMEPREFIX= ruby-
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
-RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+USE_RUBY= yes
NO_BUILD= yes
-PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
-
-RUBY?= ${LOCALBASE}/bin/ruby
-RUBY_VER?= 1.4
-RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
-
MODULES= date2.rb date3.rb holiday.rb odate.rb \
parsedate2.rb parsedate2.ry parsedate3.rb \
qholiday.rb strftime.rb strptime.rb
@@ -35,23 +29,25 @@ EXAMPLES_JA= ncal.rb
do-install:
.for f in ${MODULES}
- ${INSTALL_DATA} ${WRKSRC}/lib/${f} ${PREFIX}/lib/ruby/site_ruby/
+ ${INSTALL_DATA} ${WRKSRC}/lib/${f} ${RUBY_SITELIBDIR}
.endfor
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/examples/ruby/date2/ja
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/date2/ja
.for f in ${EXAMPLES_EN}
- ${INSTALL_DATA} ${WRKSRC}/sample/${f} ${PREFIX}/share/examples/ruby/date2/
+ ${INSTALL_DATA} ${WRKSRC}/sample/${f} ${RUBY_EXAMPLESDIR}/date2/
.endfor
.for f in ${EXAMPLES_JA}
- ${INSTALL_DATA} ${WRKSRC}/sample/${f} ${PREFIX}/share/examples/ruby/date2/ja/
+ ${INSTALL_DATA} ${WRKSRC}/sample/${f} ${RUBY_EXAMPLESDIR}/date2/ja/
.endfor
- ${MKDIR} ${PREFIX}/share/doc/ruby/date2/ja
+ ${MKDIR} ${RUBY_DOCDIR}/date2/ja
.for f in ${DOCS_EN}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/date2/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/date2/
.endfor
.for f in ${DOCS_JA}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/date2/ja/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/date2/ja/
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.ruby.mk"
+.include <bsd.port.post.mk>